Enabling hotspot when Wi-Fi is off breaks Wi-Fi

Bug #1492280 reported by Jonas G. Drange on 2015-09-04
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Alejandro J. Cura
indicator-network (Ubuntu)
High
Pete Woods

Bug Description

current build number: 105
device name: arale
channel: ubuntu-touch/rc-proposed/meizu.en
last update: 2015-09-04 11:06:40
version version: 105
version ubuntu: 20150904
version device: 20150818-0b38025
version custom: 20150814-887-8-46

Reproduce:
1. Make sure you have a hotspot
2. Wi-Fi OFF
3. Hotspot ON
4. Hotspot OFF

What happens:
Indicator toggles are in the correct state, but no access points appear and no connection with known networks is established.

What should happen:
Should connect to the known network

Bill Filler (bfiller) on 2015-09-04
Changed in indicator-network (Ubuntu):
assignee: nobody → Pete Woods (pete-woods)
importance: Undecided → High
Changed in canonical-devices-system-image:
milestone: none → ww40-2015
assignee: nobody → Alejandro J. Cura (alecu)
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-network (Ubuntu):
status: New → Confirmed
Changed in canonical-devices-system-image:
status: New → Confirmed
Changed in canonical-devices-system-image:
milestone: ww40-2015 → ww46-2015
Pete Woods (pete-woods) wrote :

Can you guys re-check this after my recent "hotspot refactoring" landing? I put a bunch of effort into making the hotspot code in the connectivity service a lot more robust in that landing. I've tried reproducing this a number of times today on Arale image 153 and haven't managed to so far.

Changed in indicator-network (Ubuntu):
status: Confirmed → In Progress
Changed in canonical-devices-system-image:
status: Confirmed → In Progress
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Changed in indicator-network (Ubuntu):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers