indicator shows (dozens of) out of range access points

Bug #1427205 reported by Jean-Baptiste Lallement on 2015-03-02
44
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Undecided
Unassigned
indicator-network (Ubuntu)
High
Unassigned
network-manager (Ubuntu)
High
Mathieu Trudel-Lapierre

Bug Description

current build number: 129
device name: krillin
channel: ubuntu-touch/devel-proposed
alias: ubuntu-touch/vivid-proposed
last update: 2015-03-02 07:41:43
version version: 129
version ubuntu: 20150302
version device: 20150210-95b6a9f
version custom: 20150302

TEST CASE:
1. Enable Wifi
2. Have a walk with the DUT outside in an area with lot of visible access points.
3. Walk in and out of range of these access points.

EXPECTED RESULT:
After the walk only the access points that are in range are visible in the indicator

ACTUAL RESULT:
All the access points the device saw are listed in the indicator (up to several dozens)

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: indicator-network 0.5.1+15.04.20150217.1-0ubuntu1
Uname: Linux 3.4.67 armv7l
ApportVersion: 2.16.1-0ubuntu2
Architecture: armhf
Date: Mon Mar 2 14:02:40 2015
InstallationDate: Installed on 2015-03-02 (0 days ago)
InstallationMedia: Ubuntu Vivid Vervet (development branch) - armhf (20150302-020203)
SourcePackage: indicator-network
UpgradeStatus: No upgrade log present (probably fresh install)

Jean-Baptiste Lallement (jibel) wrote :
description: updated
summary: - indicator shows all the access points that became unavailable.
+ indicator shows out of range access points
summary: - indicator shows out of range access points
+ indicator shows (dozens of) out of range access points
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-network (Ubuntu):
status: New → Confirmed
Michał Sawicz (saviq) wrote :

I'm adding network-manager because I've had the same on my unity7 laptop - which uses nm-applet, not indicator-network.

Michał Sawicz (saviq) wrote :

FTR:

$ LANG=en apt-cache policy network-manager network-manager-gnome
network-manager:
  Installed: 0.9.10.0-4ubuntu11
  Candidate: 0.9.10.0-4ubuntu11
  Version table:
 *** 0.9.10.0-4ubuntu11 0
        500 http://archive.ubuntu.com/ubuntu/ vivid/main amd64 Packages
        100 /var/lib/dpkg/status
network-manager-gnome:
  Installed: 0.9.10.1-0ubuntu1
  Candidate: 0.9.10.1-0ubuntu1
  Version table:
 *** 0.9.10.1-0ubuntu1 0
        500 http://archive.ubuntu.com/ubuntu/ vivid/main amd64 Packages
        100 /var/lib/dpkg/status

Changed in network-manager (Ubuntu):
status: New → Confirmed
Changed in indicator-network (Ubuntu):
importance: Undecided → Low
Changed in network-manager (Ubuntu):
importance: Undecided → Low
Sergio Schvezov (sergiusens) wrote :

I see this on desktop too

NM also lists these networks, so it's unlikely to be an indicator issue after all. I'll mark it Incomplete for indicator for now. I have a fix ready to test for NM in my PPA: ppa:mathieu-tl/nv-build. We can upload this to a silo in the morning.

Changed in indicator-network (Ubuntu):
status: Confirmed → Incomplete
Changed in network-manager (Ubuntu):
status: Confirmed → In Progress
importance: Low → High
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
Tony Espy (awe) on 2015-03-23
Changed in indicator-network (Ubuntu):
importance: Low → High
Changed in canonical-devices-system-image:
status: New → In Progress
Dave Morley (davmor2) wrote :
tags: added: connectivity
Pete Woods (pete-woods) on 2015-03-26
Changed in indicator-network (Ubuntu):
status: Incomplete → Invalid
tags: added: lt-blocker lt-category-visible
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager - 0.9.10.0-4ubuntu13

---------------
network-manager (0.9.10.0-4ubuntu13) vivid; urgency=medium

  * d/p/0001-wwan-add-support-for-using-oFono-as-a-modem-manager.patch:
    Check that a connection matches the current modem IMSI when deciding
    whether it should be deemed "compatible" to use to connect to a data
    network. (LP: #1431471)
  * d/p/0002-wifi-cull-the-scan-list-before-signalling-ScanDone-b.patch:
    Update the last seen timestamp in cull_scan_list() using the new
    nm_ap_update_last_seen() function rather than setting it to time(NULL),
    otherwise the timestamp will appear too far in the future and break the
    removals on last_seen value comparison. (LP: #1427205)
 -- Mathieu Trudel-Lapierre <email address hidden> Tue, 31 Mar 2015 23:00:31 -0400

Changed in network-manager (Ubuntu):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: In Progress → Fix Released
milestone: none → ww15-2015
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers