Wifi list is empty

Bug #1416424 reported by Niklas Wenzel on 2015-01-30
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
indicator-network (Ubuntu)
High
Dave Morley
network-manager (Ubuntu)
Undecided
Unassigned
ubuntu-system-settings (Ubuntu)
High
Unassigned

Bug Description

On recent vivid-proposed builds for mako (e.g. r83), the Wifi list in the network indicator as well as in the system settings is empty, even when the phone has automatically connected to a saved network.

phablet@ubuntu-phablet:~$ system-image-cli -i
current build number: 84
device name: mako
channel: ubuntu-touch/devel-proposed
alias: ubuntu-touch/vivid-proposed
last update: 2015-01-30 14:45:36
version version: 84
version ubuntu: 20150130
version device: 20150129
version custom: 20150130

Systems Effected:
Mako
Flo
Manta

Dave Morley (davmor2) wrote :
Dave Morley (davmor2) wrote :

phablet@ubuntu-phablet:~$ nmcli dev wifi list
* SSID MODE CHAN RATE SIGNAL BARS SECURITY
   davmor2 Infra 1 54 Mbit/s 100 ▂▄▆█ WPA1 WPA2
   davmor2-5g Infra 40 54 Mbit/s 97 ▂▄▆█ WPA1 WPA2
   SKY31983 Infra 6 54 Mbit/s 19 ▂___ WPA2
   virginmedia5828324 Infra 11 54 Mbit/s 17 ▂___ WPA1 WPA2
Segmentation fault (core dumped)

tags: added: qa-sanity
Dave Morley (davmor2) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-network (Ubuntu):
status: New → Confirmed
Changed in ubuntu-system-settings (Ubuntu):
status: New → Confirmed
Dave Morley (davmor2) on 2015-01-30
description: updated
Niklas Wenzel (nikwen) wrote :

Thank you, Dave. :)

Dave Morley (davmor2) wrote :

OTA upgrading from 81 (Last known working image) to 84 leads to a Working auto connect system but you can not connect to a new network.

Dave Morley (davmor2) on 2015-01-30
description: updated
Sebastien Bacher (seb128) wrote :

Closing the settings side, it's a backend/indicator issue. Is that still wrong? IRC discussions suggested that https://launchpad.net/ubuntu/+source/network-manager/0.9.10.0-4ubuntu3 could have addressed that one

Changed in indicator-network (Ubuntu):
importance: Undecided → High
Changed in ubuntu-system-settings (Ubuntu):
importance: Undecided → High
status: Confirmed → Invalid
Sebastien Bacher (seb128) wrote :

is that still an issue?

tags: added: lt-blocker lt-category-visible
Thomas Strehl (strehl-t) on 2015-04-14
Changed in indicator-network (Ubuntu):
assignee: nobody → Antti Kaijanmäki (kaijanmaki)
Antti Kaijanmäki (kaijanmaki) wrote :

as per sebastiens comment, this issue should have been fixed after the NM upload in february. Have not been able to repro myself. Assigning to OR for more info. Closing this as Fix Released if no new reports come in one month.

Changed in indicator-network (Ubuntu):
status: Confirmed → Incomplete
assignee: Antti Kaijanmäki (kaijanmaki) → Dave Morley (davmor2)
Niklas Wenzel (nikwen) wrote :

I haven't seen it anymore either, so it looks like it was fixed.

Pete Woods (pete-woods) on 2015-06-04
Changed in network-manager (Ubuntu):
status: New → Fix Released
Changed in indicator-network (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers