[TOPBLOCKER] Network indicator is sometimes blank

Bug #1381041 reported by Rick Spencer on 2014-10-14
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
indicator-network (Ubuntu)
Critical
Antti Kaijanmäki
Utopic
Undecided
Antti Kaijanmäki
Vivid
Critical
Antti Kaijanmäki
indicator-network (Ubuntu RTM)
Critical
Antti Kaijanmäki

Bug Description

This is on krillin r103, but it has been happening for a while.

See attached photo. I am not certain what triggers it. but I think it may happen when wifi APs become in and out of range while walking around town (as if the list does not refresh reliably).

Related branches

Antti Kaijanmäki (kaijanmaki) wrote :

Thanks Rick!

Looking from the screenshot it seems that i-network is not running anymore (and I assume the menu does not populate it self after you see it empty, right?). The only thing I could think of is that for some reason i-network has hit the upstart respawn limit.

I filed this bug to remedy the missing information on those respawns in the future:
https://bugs.launchpad.net/ubuntu/+source/upstart/+bug/1381075

If there are a lot of APs coming and going at the same time, part of the problem might be this one:
https://bugs.launchpad.net/dbus-cpp/+bug/1361642

We see that affecting the indicator when you toggle on and off the flight mode and NM offers a large list of access points (basically going from 0 to n in one go).

I will keep an eye on the crash reports on errors.ubuntu.com if anything pops up.

Changed in indicator-network (Ubuntu):
status: New → Incomplete
assignee: nobody → Antti Kaijanmäki (kaijanmaki)
importance: Undecided → Medium
Tony Espy (awe) wrote :

@Antti

I think we should bump the priority of this... if the network-menu is blank, the user ends up with drastically reduced control over their device.

Also regarding bug #1381075, as has been discussed on the mailing list, simply reporting the failed respawns of indicator-network to errors.ubuntu.com isn't sufficient. We really need to consider some sort of automatic reboot and/or prompted reboot if/when critical components fail in this manner.

@Rick

If you hit this again, can you check two things:

1. see if there are any indicator-network crash files in /var/crash, as Antti has theorized that the indicator has crashed.

2. check to see if indicator-network is still running. A simple 'status indicator-network' ( as phablet-user ) should tell you the current upstart status.

Tony Espy (awe) on 2014-10-22
tags: added: rtm14
Thomas Strehl (strehl-t) on 2014-10-23
Changed in indicator-network (Ubuntu):
importance: Medium → Critical
Changed in indicator-network (Ubuntu):
status: Incomplete → In Progress
Changed in indicator-network (Ubuntu RTM):
importance: Undecided → Critical
status: New → In Progress
Antti Kaijanmäki (kaijanmaki) wrote :

OK, after getting a partial log, I saw a lot of dbus timeouts on i-network side.
The attached branches fix these issues and prevent i-network from hitting the upstart respawn limit.

Olli Ries (ories) on 2014-10-24
tags: added: touch-2014-10-30
Changed in indicator-network (Ubuntu RTM):
assignee: nobody → Antti Kaijanmäki (kaijanmaki)
Thomas Strehl (strehl-t) on 2014-10-30
Changed in indicator-network (Ubuntu Utopic):
assignee: nobody → Antti Kaijanmäki (kaijanmaki)
summary: - Network indicator is sometimes blank
+ [TOPBLOCKER] Network indicator is sometimes blank

This issue is related to a number conditions where the indicator may crash. Once the process has crashed beyond its upstart respawn limit, it no longer recovers (hence the empty indicator). I've just linked yet another branch (fix-gmainloop-syncing) that includes some fixes to a number of synchronisation issues that contributed to these crashes.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-network - 0.5.1+15.04.20141103-0ubuntu1

---------------
indicator-network (0.5.1+15.04.20141103-0ubuntu1) vivid; urgency=low

  [ CI bot ]
  * Resync trunk

  [ Jussi Pakkanen ]
  * Use std::quick_exit. (LP: #1381041)

  [ Marcus Tomlinson ]
  * Fix GMainLoopDispatch dispatching ordering when. called inside
    GMainLoop already Fix GMainLoopDispatch locking. Force all signals
    from external (dbus-cpp) threads through. GMainLoopDispatch (LP:
    #1374419)

  [ Antti Kaijanmäki ]
  * Increase the default timeouts to match industry standards. (LP:
    #1381041)
  * Fix GMainLoopDispatch dispatching ordering when. called inside
    GMainLoop already Fix GMainLoopDispatch locking. Force all signals
    from external (dbus-cpp) threads through. GMainLoopDispatch (LP:
    #1374419)

indicator-network (0.5.1+14.10.20141015-0ubuntu1) 14.09; urgency=low

  [ Antti Kaijanmäki ]
  * deadlock if calling unlock() inside ready signal for a modem that
    does not require unlocking. (LP: #1333121)
 -- Ubuntu daily release <email address hidden> Mon, 03 Nov 2014 11:48:11 +0000

Changed in indicator-network (Ubuntu Vivid):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-network - 0.5.1+14.10.20141031.3~rtm-0ubuntu1

---------------
indicator-network (0.5.1+14.10.20141031.3~rtm-0ubuntu1) 14.09; urgency=low

  [ Jussi Pakkanen ]
  * Use std::quick_exit. (LP: #1381041)

  [ Marcus Tomlinson ]
  * Fix GMainLoopDispatch dispatching ordering when. called inside
    GMainLoop already Fix GMainLoopDispatch locking. Force all signals
    from external (dbus-cpp) threads through. GMainLoopDispatch (LP:
    #1374419)

  [ Antti Kaijanmäki ]
  * Increase the default timeouts to match industry standards. (LP:
    #1381041)
  * Fix GMainLoopDispatch dispatching ordering when. called inside
    GMainLoop already Fix GMainLoopDispatch locking. Force all signals
    from external (dbus-cpp) threads through. GMainLoopDispatch (LP:
    #1374419)
 -- Ubuntu daily release <email address hidden> Fri, 31 Oct 2014 14:16:08 +0000

Changed in indicator-network (Ubuntu RTM):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-network (Ubuntu Utopic):
status: New → Confirmed

This was fixed in 0.5.1+14.10.20141031.3~rtm-0ubuntu1

Changed in indicator-network (Ubuntu Utopic):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers