"Clear" is present and sensitive when it doesn't do anything (e.g. when there are no pending messages)

Bug #839459 reported by Jeremy Bicha on 2011-09-02
30
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Messaging Menu
Fix Released
Medium
Unassigned
indicator-messages (Ubuntu)
Medium
Unassigned

Bug Description

indicator-messages 0.4.95-0ubuntu1

1. Log in to a guest session.
2. Open the messaging menu.
3. Set up a Twitter client and receive some tweets.
4. Open the messaging menu.
5. Choose "Clear".
6. Open the messaging menu again.

What happens:
2. "Clear" is present and sensitive.
4. "Clear" is present and sensitive.
6. "Clear" is present and sensitive.

What should happen:
2. "Clear" is not present.
4. "Clear" is present and sensitive.
6. "Clear" is present and insensitive.

https://wiki.ubuntu.com/MessagingMenu#clear

Jeremy Bicha (jbicha) wrote :

On Fri, 2011-09-02 at 10:40 +0000, Jeremy Bicha wrote:
> According to the spec, "Clear" should only show in the Messaging Menu if
> there are active messages to be cleared. Currently, the "Clear
> Attention" button always shows.
>
> https://wiki.ubuntu.com/MessagingMenu#A.2BIBw-Clear.2BIB0_item

Hmm, that's not how I read the spec. It says:

        The “Clear” item should be sensitive whenever there is at least
        one application with a draw_attention request. Activating the
        item should restore the menu title to the no-new-messages state,
        but should keep any message sources, counts, and times in the
        menu.

Which states to me that it should adjust sensitivity not whether it is
present or not.

  status invalid

Changed in indicator-messages:
status: New → Invalid

The two mockups at the top of the wiki page show the initial appearance without the Clear button so. I think that the specification is unclear since the visual mockup doesn't match the text description so I guess we need Design to clarify.

summary: - [UIFe] Clear should not show in Messaging Menu if there aren't any
- pending messages
+ Clear should not show in Messaging Menu if there aren't any pending
+ messages
Changed in indicator-messages:
status: Invalid → New
status: New → Incomplete
Changed in indicator-messages (Ubuntu):
status: New → Confirmed
Matthew Paul Thomas (mpt) wrote :

Sorry, my mistake, I forgot to specify when the item should be present. It's absent from the first sketch because it should be present only when any applications are set up to use the messaging menu. Specification updated. <https://wiki.ubuntu.com/MessagingMenu?action=diff&rev2=79&rev1=78>

Changed in ayatana-design:
assignee: nobody → Matthew Paul Thomas (mpt)
status: New → Fix Committed
description: updated
Changed in indicator-messages:
status: Incomplete → Confirmed
summary: - Clear should not show in Messaging Menu if there aren't any pending
- messages
+ "Clear" is present and sensitive when it doesn't do anything
Omer Akram (om26er) on 2011-09-15
Changed in indicator-messages:
importance: Undecided → Medium
Changed in indicator-messages (Ubuntu):
importance: Undecided → Medium
John Lea (johnlea) on 2011-10-18
tags: added: udo
Changed in ayatana-design:
importance: Undecided → Wishlist
John Lea (johnlea) on 2011-10-18
Changed in ayatana-design:
importance: Wishlist → Low
John Lea (johnlea) on 2011-10-18
tags: added: udp
Changed in ayatana-design:
status: Fix Committed → Triaged

John, please don't reopen a bug report assigned to me without explaining why. Thanks.

Changed in ayatana-design:
status: Triaged → Fix Committed
Ted Gould (ted) wrote :

Switching to confirmed, I think that we need to somehow look at how the entires in the menu are handled in these various cases. We can't just clear all of the entries because some of them, for instance, are mailboxes not messages from users. I think that we should just not change the menu items as well, and have clear mean that it's changing the state of the icon on the panel.

Changed in ayatana-design:
status: Fix Committed → Confirmed
John Lea (johnlea) on 2011-11-25
summary: - "Clear" is present and sensitive when it doesn't do anything
+ "Clear" is present and sensitive when it doesn't do anything (e.g. when
+ there are no pending messages)
Changed in ayatana-design:
status: Confirmed → Triaged
assignee: Matthew Paul Thomas (mpt) → nobody
assignee: nobody → John Lea (johnlea)
assignee: John Lea (johnlea) → nobody
no longer affects: ayatana-design
Matthew Paul Thomas (mpt) wrote :

Ted, why does it matter if some of the items are mailboxes? The messaging menu is specifically about messages that are new, not generally about messages that are unread. Clear means "None of these items are new to me any more". Does that make sense?

Changed in indicator-messages:
importance: Medium → High
Olli Ries (ories) on 2012-03-26
tags: added: backlog
Changed in indicator-messages:
importance: High → Low
John Lea (johnlea) on 2012-04-24
Changed in ayatana-design:
assignee: nobody → Matthew Paul Thomas (mpt)
importance: Undecided → Medium
status: New → Triaged
John Lea (johnlea) on 2012-08-13
Changed in indicator-messages:
status: Confirmed → Triaged
Changed in indicator-messages (Ubuntu):
status: Confirmed → Triaged
Changed in indicator-messages:
importance: Low → Medium
Changed in ayatana-design:
status: Triaged → Fix Committed
Lars Karlitski (larsu) wrote :

Just tested this in indicator-messages 12.10.2 (which is in quantal): it works fine.

Changed in indicator-messages:
status: Triaged → Fix Released
Matthew Paul Thomas (mpt) wrote :

Yes, this is fixed with indicator-messages 12.10.4-0ubuntu1 in Ubuntu 12.10.

Changed in indicator-messages (Ubuntu):
status: Triaged → Fix Released
no longer affects: ayatana-design
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related blueprints