Every message gets new list item on empathy indicator

Bug #1302930 reported by Michal Zubkowicz on 2014-04-05
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
indicator-messages (Ubuntu)
Low
Lars Karlitski
telepathy-indicator (Ubuntu)
Undecided
Unassigned

Bug Description

In messaging indicator i see every message as a separate item, even with same person. So i have many notifications with same persons. Also opening empathy doesn't remove item from list. Only clicking on indicator element.

Related branches

It happens on 14.04. with empathy 3.8.6-0ubuntu9 and indicator-messages (13.10.1+14.04.20140321-0ubuntu1) and earlier versions also.

Lars Karlitski (larsu) wrote :

This seems to happen after empathy (the main window, not the chat window) is restarted. I've attached a branch for indicator-messages that should fix the issue.

Changed in indicator-applet:
status: New → Incomplete
status: Incomplete → In Progress
assignee: nobody → Lars Uebernickel (larsu)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-messages - 13.10.1+14.04.20140410-0ubuntu1

---------------
indicator-messages (13.10.1+14.04.20140410-0ubuntu1) trusty; urgency=low

  [ Lars Uebernickel ]
  * messages-service: listen to the ApplicationStoppedRunning call Prior
    to this patch, only applications that exit were marked as "not
    running". However, this must also happen when an application unrefs
    it's MessagingMenuApp instance. This is a problem for applications
    which implement messaging menu integration as a plugin (when
    unloading the plugin). Specifically, this causes bug #1302930, as
    telepathy-indicator doesn't exit when empathy exits. (LP: #1302930)
 -- Ubuntu daily release <email address hidden> Thu, 10 Apr 2014 12:07:10 +0000

Changed in indicator-messages (Ubuntu):
status: New → Fix Released
Lars Karlitski (larsu) on 2014-04-10
no longer affects: indicator-applet

It's not fixed after last update

Changed in indicator-messages (Ubuntu):
status: Fix Released → Confirmed

Screenshot of bug

Sebastien Bacher (seb128) wrote :

Did you restart your session? What steps do you use exactly to trigger the issue?

Changed in indicator-messages (Ubuntu):
importance: Undecided → Low

It happens every time even on fresh session, after reboot. Maybe it is cause of connecting to vpn (network change / disconnect)?

Sebastien Bacher (seb128) wrote :

You are sure you are uptodate and restarted your session? Could you describe what you do exactly? What sort of accounts are you using/are configured?

I've got newest version from repository (update mentioned earlier is installed)

I know how to reproduce that now:
1) Use Facebook account
2) Open chat with someone
3) Write, close chat window
4) Wait for response, don't open notification yet
5) Reconnect network
6) Write Reply to message another way (by messenger on phone, or in browser
7) Wait for reply from another side
8) Now you have two or more notifications

I can check later which steps are obligatory if you need, but with this workflow it happens every time.
Also i see side effect that number of notifications on dock is wrong.

Sebastien Bacher (seb128) wrote :

Thanks, it would be useful to lower the number of steps if possible (like if the reconnect is really needed) but that seems a good basis. I tried steps similar to that with a g+ account talking to a jabber one (so I could do both side), but it does require some devices/accounts and I might have got the mix wrong, at least I couldn't reproduce the issue...

Sebastien Bacher (seb128) wrote :

Ok, I can confirm that using gtalk accounts here, thanks for the steps!

Lars Karlitski (larsu) on 2014-04-15
Changed in indicator-messages (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Lars Uebernickel (larsu)

It was ok for some time, but now it's bad again.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package telepathy-indicator - 0.3.1+14.10.20140908-0ubuntu1

---------------
telepathy-indicator (0.3.1+14.10.20140908-0ubuntu1) utopic; urgency=low

  [ Lars Uebernickel ]
  * Remove source when a connection dies (LP: #1302930)
 -- Ubuntu daily release <email address hidden> Mon, 08 Sep 2014 16:39:27 +0000

Changed in telepathy-indicator (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers