Selecting "View terms and conditions HERE" opens browser with error message

Bug #1507793 reported by Michal Predotka on 2015-10-19
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
indicator-location (Ubuntu)
High
Charles Kerr

Bug Description

bq 4.5 Ubuntu Edition OTA-7

Steps to reproduce:
1. Open location indicator
2. Tap "View terms and conditions HERE"

Expected outcome:
You see "terms and conditions HERE"

What happens:
Browser appears with error message: "It appears you are having trouble viewing: file:///custom/vendor/here/location-provider/consent//en_GB.html"

Related branches

Michal Predotka (mpredotka) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-location (Ubuntu):
status: New → Confirmed
cm-t arudy (cm-t) wrote :

Same issue with same_path//fr_FR.html

Sergi Quiles Pérez (sergiqp) wrote :

For me same_path//en_US.html

Changed in indicator-location (Ubuntu):
importance: Undecided → High
Matthew Paul Thomas (mpt) wrote :

I can't reproduce this problem. But that menu item should not exist in the first place; I've reported bug 1535353 for that. So I guess the important question is: Does the same problem happen if you follow the equivalent link in System Settings?

Michal Predotka (mpredotka) wrote :

I tried just now on bq 4.5 with OTA 8.5 installed and indeed, the problem is gone. Now I see a webpage with links to privacy policy and service terms.
When I follow the link in Settings, the same text is displayed but not in the browser, just as a Page in System Settings.

Charles Kerr (charlesk) on 2016-01-24
Changed in indicator-location (Ubuntu):
assignee: nobody → Charles Kerr (charlesk)
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-location - 13.10.0+16.04.20160218-0ubuntu1

---------------
indicator-location (13.10.0+16.04.20160218-0ubuntu1) xenial; urgency=medium

  * Remove the "View HERE terms and conditions" menuitem (LP: #1507793,
    #1535353)
  * Style guide code cleanup. No functional changes.
  * Use core::Property<X> fields to notify the indicator when location
    settings change
  * When 'Location settings…' is clicked, invoke the uri
    'settings:///location' (LP: #1533835)

 -- Charles Kerr <email address hidden> Thu, 18 Feb 2016 17:05:40 +0000

Changed in indicator-location (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments