libgee-0.8-dev should be used, libgee-dev will be removed from the archive

Bug #1502094 reported by Matthias Klose on 2015-10-02
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
indicator-keyboard (Ubuntu)
Low
Unassigned
Xenial
Low
Unassigned
indicator-sound (Ubuntu)
High
Matthias Klose
Xenial
High
Matthias Klose
indicator-sound-gtk2 (Ubuntu)
High
Unassigned
Xenial
High
Unassigned
libfriends (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned
libgee (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned
unity-china-music-scope (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned
unity-china-video-scope (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned
unity-lens-applications (Ubuntu)
High
Matthias Klose
Xenial
High
Matthias Klose
unity-lens-files (Ubuntu)
High
Unassigned
Xenial
High
Unassigned
unity-lens-friends (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned
unity-lens-music (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned
unity-lens-video (Ubuntu)
High
Matthias Klose
Xenial
High
Matthias Klose
unity-scope-home (Ubuntu)
High
Matthias Klose
Xenial
High
Matthias Klose

Bug Description

The libgee source is obsolete, replaced by the libgee-0.8 source. Packages should change their build dependency to libgee-0.8-dev instead.

The libgee source was already removed in Debian; it will be removed in Ubuntu as well.

Related branches

Ken VanDine (ken-vandine) wrote :

I've filed bug 1502193 to have libfriends and unity-lens-friends removed from the archive

Matthias Klose (doko) wrote :

friends & co removed from the archive

Changed in libfriends (Ubuntu):
status: New → Fix Released
Changed in unity-lens-friends (Ubuntu):
status: New → Fix Released
Aron Xu (happyaron) on 2015-10-14
Changed in unity-china-music-scope (Ubuntu):
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-china-music-scope - 1.0.8-0ubuntu1

---------------
unity-china-music-scope (1.0.8-0ubuntu1) wily; urgency=medium

  * modify build-depends (LP: #1502094)

 -- ShuiLu Pi <email address hidden> Thu, 08 Oct 2015 11:41:56 +0800

Changed in unity-china-music-scope (Ubuntu):
status: Fix Committed → Fix Released
Aron Xu (happyaron) on 2015-10-15
Changed in unity-china-video-scope (Ubuntu):
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-china-video-scope - 1.3-0ubuntu1

---------------
unity-china-video-scope (1.3-0ubuntu1) wily; urgency=low

  * modify configure.ac (LP: #1502094)

 -- ShuiLu Pi <email address hidden> Thu, 15 Oct 2015 10:58:04 +0800

Changed in unity-china-video-scope (Ubuntu):
status: Fix Committed → Fix Released
Changed in indicator-keyboard (Ubuntu):
importance: Undecided → Low
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-keyboard - 0.0.0+16.04.20151125-0ubuntu1

---------------
indicator-keyboard (0.0.0+16.04.20151125-0ubuntu1) xenial; urgency=medium

  [ CI Train Bot ]
  * New rebuild forced.

  [ Sebastien Bacher ]
  * Depends on libgnomekbd-common since the code uses its schemas (LP:
    #1515562)
  * Use the current libgee version (LP: #1502094)

 -- Sebastien Bacher <email address hidden> Wed, 25 Nov 2015 08:45:35 +0000

Changed in indicator-keyboard (Ubuntu):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-lens-music - 6.9.1+16.04-0ubuntu1

---------------
unity-lens-music (6.9.1+16.04-0ubuntu1) xenial; urgency=medium

  * Remove music online store search code (LP: #1521208)
  * Remove unity-scope-musicstores package and add C/P against it to help apt
    transition.
  * Remove oauth and soup code and package dependencies now that we won't have
    this kind of results.
  * Bump version to 6.9.1
  * Build-depends on gee-0.8 and transition to compatible 0.8 pkgconfig files
    (LP: #1502094)

 -- Didier Roche <email address hidden> Mon, 30 Nov 2015 10:51:30 +0100

Changed in unity-lens-music (Ubuntu):
status: New → Fix Released
Changed in unity-lens-files (Ubuntu):
importance: Undecided → High
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-lens-files - 7.1.0+16.04.20151216.1-0ubuntu1

---------------
unity-lens-files (7.1.0+16.04.20151216.1-0ubuntu1) xenial; urgency=medium

  [ Ryan Tandy ]
  * Update the path to the bookmarks file. (LP: #1425714)

  [ Sebastien Bacher ]
  * Build with the current gee version (LP: #1502094)

 -- Sebastien Bacher <email address hidden> Wed, 16 Dec 2015 15:47:14 +0000

Changed in unity-lens-files (Ubuntu):
status: In Progress → Fix Released
Changed in indicator-sound (Ubuntu):
assignee: nobody → Xavi Garcia (xavi-garcia-mena)
Matthias Klose (doko) wrote :

this really has to be fixed. having both versions is probably not what we want

Changed in unity-lens-video (Ubuntu):
importance: Undecided → High
milestone: none → ubuntu-16.02
status: New → Confirmed
Changed in unity-scope-home (Ubuntu):
importance: Undecided → High
milestone: none → ubuntu-16.02
status: New → Confirmed
Changed in unity-lens-applications (Ubuntu):
importance: Undecided → High
status: New → Confirmed
Changed in indicator-sound-gtk2 (Ubuntu):
importance: Undecided → High
milestone: none → ubuntu-16.02
status: New → Confirmed
Changed in indicator-sound (Ubuntu):
importance: Undecided → High
milestone: none → ubuntu-16.02
status: New → Confirmed
Matthias Klose (doko) wrote :
Matthias Klose (doko) wrote :
Matthias Klose (doko) wrote :
Matthias Klose (doko) wrote :
Will Cooke (willcooke) on 2016-02-12
tags: added: u7-trello-import
tags: removed: u7-trello-import
tags: added: rls-x-incoming
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-sound-gtk2 - 12.10.0.1-0ubuntu5

---------------
indicator-sound-gtk2 (12.10.0.1-0ubuntu5) xenial; urgency=medium

  * Build using libgee-0.8-dev instead of libgee-dev. LP: #1502094.

 -- Matthias Klose <email address hidden> Fri, 12 Feb 2016 18:00:07 +0100

Changed in indicator-sound-gtk2 (Ubuntu Xenial):
status: Confirmed → Fix Released
Changed in unity-lens-video (Ubuntu Xenial):
assignee: nobody → Matthias Klose (doko)
status: Confirmed → In Progress
Changed in indicator-sound (Ubuntu Xenial):
assignee: Xavi Garcia (xavi-garcia-mena) → Matthias Klose (doko)
status: Confirmed → In Progress
Changed in unity-lens-applications (Ubuntu Xenial):
assignee: nobody → Matthias Klose (doko)
status: Confirmed → In Progress
Changed in unity-scope-home (Ubuntu Xenial):
assignee: nobody → Matthias Klose (doko)
status: Confirmed → In Progress
tags: added: patch
Iain Lane (laney) on 2016-02-15
tags: removed: rls-x-incoming
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-sound - 12.10.2+16.04.20160216-0ubuntu1

---------------
indicator-sound (12.10.2+16.04.20160216-0ubuntu1) xenial; urgency=medium

  [ Matthias Klose ]
  * Build using libgee-0.8-dev instead of libgee-dev (LP: #1502094)

 -- Marco Trevisan (Treviño) <mail@3v1n0.net> Tue, 16 Feb 2016 15:44:36 +0000

Changed in indicator-sound (Ubuntu Xenial):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-lens-applications - 7.1.0+16.04.20160217.2-0ubuntu1

---------------
unity-lens-applications (7.1.0+16.04.20160217.2-0ubuntu1) xenial; urgency=medium

  [ Marco Trevisan (Treviño), Matthias Klose ]
  * Build using libgee-0.8-dev instead of libgee-dev (LP: #1502094)

 -- Marco Trevisan (Treviño) <mail@3v1n0.net> Wed, 17 Feb 2016 15:31:32 +0000

Changed in unity-lens-applications (Ubuntu Xenial):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-scope-home - 6.8.2+16.04.20160212.1-0ubuntu1

---------------
unity-scope-home (6.8.2+16.04.20160212.1-0ubuntu1) xenial; urgency=medium

  [ Matthias Klose ]
  * Build using libgee-0.8-dev instead of libgee-dev (LP: #1502094)

 -- Marco Trevisan (Treviño) <mail@3v1n0.net> Fri, 12 Feb 2016 19:44:02 +0000

Changed in unity-scope-home (Ubuntu Xenial):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-lens-video - 0.3.15+16.04.20160212.1-0ubuntu1

---------------
unity-lens-video (0.3.15+16.04.20160212.1-0ubuntu1) xenial; urgency=medium

  [ Marco Trevisan (Treviño), Matthias Klose ]
  * Build using libgee-0.8-dev instead of libgee-dev (LP: #1502094,
    #1545078)

 -- Marco Trevisan (Treviño) <mail@3v1n0.net> Fri, 12 Feb 2016 19:43:49 +0000

Changed in unity-lens-video (Ubuntu Xenial):
status: In Progress → Fix Released
Matthias Klose (doko) wrote :

Removing packages from xenial:
 libgee 0.6.8-2ubuntu1 in xenial
  gir1.2-gee-1.0 0.6.8-2ubuntu1 in xenial amd64
  gir1.2-gee-1.0 0.6.8-2ubuntu1 in xenial arm64
  gir1.2-gee-1.0 0.6.8-2ubuntu1 in xenial armhf
  gir1.2-gee-1.0 0.6.8-2ubuntu1 in xenial i386
  gir1.2-gee-1.0 0.6.8-2ubuntu1 in xenial powerpc
  gir1.2-gee-1.0 0.6.8-2ubuntu1 in xenial ppc64el
  gir1.2-gee-1.0 0.6.8-2ubuntu1 in xenial s390x
  libgee-dev 0.6.8-2ubuntu1 in xenial amd64
  libgee-dev 0.6.8-2ubuntu1 in xenial arm64
  libgee-dev 0.6.8-2ubuntu1 in xenial armhf
  libgee-dev 0.6.8-2ubuntu1 in xenial i386
  libgee-dev 0.6.8-2ubuntu1 in xenial powerpc
  libgee-dev 0.6.8-2ubuntu1 in xenial ppc64el
  libgee-dev 0.6.8-2ubuntu1 in xenial s390x
  libgee2 0.6.8-2ubuntu1 in xenial amd64
  libgee2 0.6.8-2ubuntu1 in xenial arm64
  libgee2 0.6.8-2ubuntu1 in xenial armhf
  libgee2 0.6.8-2ubuntu1 in xenial i386
  libgee2 0.6.8-2ubuntu1 in xenial powerpc
  libgee2 0.6.8-2ubuntu1 in xenial ppc64el
  libgee2 0.6.8-2ubuntu1 in xenial s390x
  libgee2-dbg 0.6.8-2ubuntu1 in xenial amd64
  libgee2-dbg 0.6.8-2ubuntu1 in xenial arm64
  libgee2-dbg 0.6.8-2ubuntu1 in xenial armhf
  libgee2-dbg 0.6.8-2ubuntu1 in xenial i386
  libgee2-dbg 0.6.8-2ubuntu1 in xenial powerpc
  libgee2-dbg 0.6.8-2ubuntu1 in xenial ppc64el
  libgee2-dbg 0.6.8-2ubuntu1 in xenial s390x
Comment: lp: #1502094, remove libgee, superseded by libgee-0.8
1 package successfully removed.

Changed in libgee (Ubuntu Xenial):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers