Users not warned about switch to fcitx and no instructions are given

Bug #1430971 reported by Eric Chaskes on 2015-03-11
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
indicator-keyboard (Ubuntu)
High
Unassigned
unity-control-center (Ubuntu)
High
Unassigned
unity-settings-daemon (Ubuntu)
High
Unassigned

Bug Description

Received the newest update to 0.0.0+15.04.20150310 a few minutes ago. There is a significant change to behavior with the change to fcitx from ibus.

Users, however, are given no warning and no instructions on how to get their preferred input methods set up again.

This has the potential to cause major inconveniences to users of non-English input methods, especially for Asian and other languages where the user needs a full IM and not just an alternative keyboard.

1. Users need to be notified of the change and of the need install the necessary fcitx packages. Most users will need some instructions on what to do.

2. After installing fcitx-libpinyin, the Input Method Configuration dialog still showed only keyboard layouts -- even after a reboot. I had to restart fcitx using the restart option in the drop-down menu before additional (non-keyboard) options showed up in the list.

3. After that, finding pinyin input was still not intuitive. Past dialogs had you search for 'Chinese', then choose the appropriate method. In this case, however, 'Chinese' is only used in the 2nd (right) column, which is apparently not searched; so typing 'Chinese' led to no results. After removing the search term and scrolling to the bottom of the list, I saw that the IM's are listed by method name (Pinyin, BoPoMoFo, etc) and do not use the name of the language in the 1st (left) column. This is not expected by users and not consistent with the name of the keyboard methods.

Related branches

William Hua (attente) wrote :

> There is a significant change to behavior with the change to fcitx from ibus.

Hi, could you please elaborate on what happened with your update? That update doesn't switch your selected input method framework from ibus to fcitx. Also, the update should have been an effective no-op if Fcitx wasn't already installed in the first place...

Eric Chaskes (echaskes) wrote :

Thanks for your quick response.

I was running Vivid on 2 laptops. I did a dist-upgrade on each of them and had the experience described above on both laptops.

Additional details:

1. ibus and ibus-pinyin were installed during system installation as normal.

2. I added and then removed ibus-pinyin as an input method (on on computer, but not the other).

3. But I had not yet installed the additional ibus packages that I normally use, such is ibus-libpinyin, ibus-anthy, etc. on either computer.

4. The dist-upgrade contained the packages in the attached list, including fcitx (etc) as an automatic install and the new version of indicator-keyboard.

5. I added ibus-libpinyin, but could not add the method. After a little investigation I saw that fcitx was now the default IM. I assumed this was by design and added fcitx-libpinyin, etc.

6. I noticed an immediate change in the topbar input icon.

Please let me know if there's anything I can add.

William Hua (attente) wrote :

Thanks Eric,

The bug seems to be that the fcitx packages (particularly fcitx-bin) were pulled in somehow, but it isn't clear to me why this happened. Nothing has a hard depends on it, and trying to apt-get purge it doesn't remove anything suspicious (like indicator-keyboard, unity-settings-daemon, or unity-control-center).

Can you please try to do an apt-get purge of fcitx-bin? Please note any non-related fcitx packages that are removed as a consequence of that (if something particularly important like unity-settings-daemon or unity-control-center are removed, just abort).

Eric Chaskes (echaskes) wrote :

I've already removed all fcitx packages except fcitx-data, libfcitx-config4, libfcitx-glient0, libfcitx-utils0 (all required by Unity Control Center, as you know) and reset the system IM back to Ibus; so I'm back to normal.

I didn't really question the fcitx packages in the upgrade since it's now supported and it seemed reasonable to have it readily available.

I assumed the bug was with indicator-keyboard because that's where problem showed itself in a big way, but based on your earlier comment I wonder if the bug isn't in unity-settings-daemon and how the current IM is detected.

I have a third laptop that I had not yet upgraded. This time I added in ibus-libpinyin IM *before* doing the upgrade. This time fcitx was added to the startup programs and set itself in update-alternatives for xinput.d, but it did not replace Ibus as the system-wide IM in Language Support as it had before. The topbar had both indicators. When I switched the system-wide IM to fcitx and then set it back to Ibus (restarting each time), the ibus-libpinyin IM had been removed from Text Entry.

So apart from the question of the fcitx packages showing up in the upgrade, it seems like various config scripts are not correctly detecting Ibus.

If I can do any additional debugging, please let me know.

Eric Chaskes (echaskes) wrote :

I did a fresh install, then manually upgraded packages in the dist-upgrade one by one to isolate the ones pulling in fcitx.

indicator-keyboard did not pull in fcitx. It was unity-control-center and unity-settings-daemon that are each trying to pull in the fcitx packages.

William Hua (attente) on 2015-03-12
Changed in unity-control-center (Ubuntu):
status: New → Confirmed
Changed in unity-settings-daemon (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-keyboard (Ubuntu):
status: New → Confirmed
dino99 (9d9) wrote :

indicator-keyboard have a hard dependencie on libfcitx-gclient0

so fcitx can't be fully purged if the user does not care about it
myself i purge lot of things (if possible) to get rid of a bunch of packages i does not need. So hard dependencies are a nightmare.

tags: added: vivid
Changed in unity-control-center (Ubuntu):
importance: Undecided → High
Changed in indicator-keyboard (Ubuntu):
importance: Undecided → High
Changed in unity-settings-daemon (Ubuntu):
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-settings-daemon - 15.04.1+15.04.20150313-0ubuntu1

---------------
unity-settings-daemon (15.04.1+15.04.20150313-0ubuntu1) vivid; urgency=medium

  [ William Hua ]
  * Remove fcitx-data from Recommends and check if the required file,
    config.desc, is available at runtime. Trying to dist-upgrade
    currently pulls in the fcitx-bin which is higher priority than ibus.
    (LP: #1430971)
 -- CI Train Bot <email address hidden> Fri, 13 Mar 2015 12:54:01 +0000

Changed in unity-settings-daemon (Ubuntu):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-control-center - 15.04.0+15.04.20150313-0ubuntu1

---------------
unity-control-center (15.04.0+15.04.20150313-0ubuntu1) vivid; urgency=medium

  [ William Hua ]
  * Remove fcitx-data from Recommends and check if the required file,
    config.desc, is available at runtime. Trying to dist-upgrade
    currently pulls in the fcitx-bin which is higher priority than ibus.
    (LP: #1430971)
 -- CI Train Bot <email address hidden> Fri, 13 Mar 2015 12:53:31 +0000

Changed in unity-control-center (Ubuntu):
status: Confirmed → Fix Released
William Hua (attente) on 2015-03-18
Changed in indicator-keyboard (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers