Lockscreen does not turn off input methods

Bug #1301860 reported by Yung Shen on 2014-04-03
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
indicator-keyboard (Ubuntu)
High
William Hua

Bug Description

Login screen does not turn off input medthod for inputing login password.

Steps to reporduces:

1. super+space, switch to any input methods

2. press ctrl-alt-L to lock screen or type command: gnome-screensaver-command -l

3. wake screen by moving mouse or tapping touchpad

4. trying to input your password

Actual results:

User need to turn off input method to type their password.

Expected results:

Typing password directly without worry about input method.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: gnome-screensaver 3.6.1-0ubuntu11
ProcVersionSignature: Ubuntu 3.13.0-22.44-generic 3.13.8
Uname: Linux 3.13.0-22-generic x86_64
ApportVersion: 2.14-0ubuntu1
Architecture: amd64
CurrentDesktop: Unity
Date: Thu Apr 3 17:54:47 2014
GnomeSessionIdleInhibited: No
GnomeSessionInhibitors: 1: AppId = gedit, Flags = 1, Reason = 尚有未儲存的文件
GsettingsGnomeSession:
 org.gnome.desktop.session session-name 'ubuntu'
 org.gnome.desktop.session idle-delay uint32 60
InstallationDate: Installed on 2014-04-03 (0 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Beta amd64 (20140326)
SourcePackage: gnome-screensaver
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Yung Shen (kaxing) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for your bug report. You probably mean "lock screen" rather than "login screen", that should be addressed by the work on https://code.launchpad.net/~attente/indicator-keyboard/switch-layout-on-lock/+merge/213737

affects: gnome-screensaver (Ubuntu) → indicator-keyboard (Ubuntu)
Changed in indicator-keyboard (Ubuntu):
assignee: nobody → William Hua (attente)
importance: Undecided → High
status: New → In Progress
summary: - Login Screen does not turn off input methods on 14.04 beta 2
+ Lockscreen does not turn off input methods
tags: added: lockscreen
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-keyboard - 0.0.0+14.04.20140410.1-0ubuntu1

---------------
indicator-keyboard (0.0.0+14.04.20140410.1-0ubuntu1) trusty; urgency=low

  [ William Hua ]
  * If an IBus input source is active when the session is locked, switch
    to another non-IBus one instead. (LP: #1301860)
 -- Ubuntu daily release <email address hidden> Thu, 10 Apr 2014 16:49:00 +0000

Changed in indicator-keyboard (Ubuntu):
status: In Progress → Fix Released
Nobuto Murata (nobuto) wrote :

Hi, the fix works if user has non-IBus entry in addition to user's preferred IBus engine. However on clean install of trusty, only one entry "Japanese(Anthy)" is registered automatically in Japanese case. This behaviour is not sufficient for users, IMHO. I also posted a comment to Bug #1291302 which might be a duplicate of this bug.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers