Ubuntu 13.10, Thinkpad x230, Fn keys not working after upgrade

Bug #1242221 reported by Anders Hall on 2013-10-20
34
This bug affects 7 people
Affects Status Importance Assigned to Milestone
indicator-keyboard (Ubuntu)
Undecided
Unassigned

Bug Description

After uppgrade i cannot control screen brightness with Fn + keys on Lenovo Thinkpad x230. Worked in previous releases.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-keyboard (Ubuntu):
status: New → Confirmed
plush_cthulhu (n3tw4lk3r) wrote :

here, not only brightness, but all fn keys have stopped working,

thinkpad edge 13

Anders Hall (a.hall) wrote :

This morning after reboot the fn brightness keys worked again. I have the latest updates installed.

Christian González (droetker) wrote :

Here on a Samsung RF511, same issue. After update to 13.10 all Fn keys are dead within Ubuntu. Funnily the touchpad on/off switch (Fn+F10) seems to work (switches TP on/off), but Ubuntu does not recognize it nor give any notification.

Angeloribas (angeloribas) wrote :

Here on my Samsung NP530U3B (Intel Sandybridge 'ultrabook') running UbuntuGNOME 13.10, recently Fn keys for increase/decrease audio volume stoped working. On the other hand, Fn keys for increasing/decreasing brightness, as well as Fn keys for enabling/disabling audio, touchpad, wireless network, setting fan speed, page up/page down, home/end and print screen are working normally, including the respective notifications. The only problem with Fn keys regards increasing/decreasing audio volume.

Andreas Jonsson (sonofjon) wrote :

Fresh install of 13.10 on Thinkpad x230 here. Fn keys all work.

Rafał Ochmański (rmopl) wrote :

Same here on Dell V131. Fn keys seem to stop working after suspend.

Fadly H. Yusran (fhyusran) wrote :

Me, too. On ThinkPad Edge Type 0328-2TA. Help us, please!

orenl (orenlaadan) wrote :

Same here: Fn + key not working at all, running Kubuntu 13.10 with latest (to date) updates, even after reboot.

Bryan Quigley (bryanquigley) wrote :

There is a page on HotKey troubleshooting. If you still have this issue please go through the troubleshooting procedure so we can get a better idea where the bug is coming from..

https://wiki.ubuntu.com/Hotkeys/Troubleshooting

madbiologist (me-again) wrote :

This should be fixed for the Thinkpad X230 in the upstream 3.14-rc4 kernel by these two commits:

commit bd8ba20597f0cfef3ef65c3fd2aa92ab23d4c8e1 - ACPI / video: Filter the _BCL table for duplicate brightness values
commit 0e9f81d3b7cd0649a3bc437391b6a0650f98f844 - ACPI / video: Add systems that should favour native backlight interface

The first one has been cc'd to the stable kernel series. A PPA of the 3.14-rc4 kernel is available at http://kernel.ubuntu.com/~kernel-ppa/mainline/ and instructions on how to install an uninstall it are available at https://wiki.ubuntu.com/Kernel/MainlineBuilds

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers