Icon does not change with theme switch

Bug #1237749 reported by Edwin Pujols
98
This bug affects 14 people
Affects Status Importance Assigned to Milestone
indicator-keyboard (Ubuntu)
Fix Released
High
William Hua

Bug Description

If I start Unity with, say, Radiance theme and then switch the theme to Ambiance, the layout icon keeps Radiance dark color. I try clicking on it and passing the pointer over it, but the icon won't refresh to the new theme.

If I do `killall indicator-keyboard-service` the icon theme gets fixed, and adopts the current theme coloration.

BTW, the Ubuntu One indicator suffers from this too. But if I click its icon, the color changes immediately to reflect the current theme.

*Steps to reproduce*
 - After login, open Appearance and change the current color theme (Ambiance -> Radiance or vice versa). Notice the keyboard layout icon does not change color, making it difficult to read.

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: indicator-keyboard 0.0.0+13.10.20131004-0ubuntu1
ProcVersionSignature: Ubuntu 3.11.0-12.18-generic 3.11.3
Uname: Linux 3.11.0-12-generic i686
ApportVersion: 2.12.5-0ubuntu1
Architecture: i386
Date: Wed Oct 9 22:35:43 2013
InstallationDate: Installed on 2013-08-31 (39 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Alpha i386 (20130830)
MarkForUpload: True
SourcePackage: indicator-keyboard
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Revision history for this message
Edwin Pujols (edwinpm5) wrote :
description: updated
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-keyboard (Ubuntu):
status: New → Confirmed
Revision history for this message
beytu (beytu) wrote :

Hello,

i have the same issue with the message/sound/network indicators : http://imgur.com/J7lrQt6

Revision history for this message
Norbert (nrbrtx) wrote :
Changed in indicator-keyboard (Ubuntu):
importance: Undecided → Low
Revision history for this message
Adolfo Jayme Barrientos (fitojb) wrote :

Raising importance because of the number of duplicate reports and because this causes an accessibility problem for people with visual deficiencies (well, for everyone).

Changed in indicator-keyboard (Ubuntu):
importance: Low → High
status: Confirmed → Triaged
tags: added: a11y
Revision history for this message
Norbert (nrbrtx) wrote :

Bug exsits in Ubuntu 14.04. Please fix it (a11y problem).

tags: added: trusty
Changed in indicator-keyboard:
status: New → Confirmed
Revision history for this message
returningshadow (reidwicks) wrote :

Can confirm for 14.04 64-bit.

Changed in indicator-keyboard (Ubuntu):
assignee: nobody → Indicator Applet Developers (indicator-applet-developers)
Changed in indicator-keyboard (Ubuntu):
assignee: Indicator Applet Developers (indicator-applet-developers) → William Hua (attente)
tags: added: ubuntu-desktop-trusty
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-keyboard - 0.0.0+14.04.20140227.3-0ubuntu1

---------------
indicator-keyboard (0.0.0+14.04.20140227.3-0ubuntu1) trusty; urgency=low

  [ Sebastien Bacher ]
  * Drop unity8 test description, that indicator is used on desktop only

  [ William Hua ]
  * Do not set org.gnome.desktop.input-sources.current when unchanged
    (LP: #1256559). (LP: #1256559)
  * Update icons when icon theme changes. (LP: #1237749)

  [ Ubuntu daily release ]
  * New rebuild forced
 -- Ubuntu daily release <email address hidden> Thu, 27 Feb 2014 19:38:10 +0000

Changed in indicator-keyboard (Ubuntu):
status: Triaged → Fix Released
Revision history for this message
Adolfo Jayme Barrientos (fitojb) wrote :

Thank you, William!

no longer affects: indicator-keyboard
Revision history for this message
Norbert (nrbrtx) wrote :

Thank you, William!
But language icons inside keyboard indicator are small (this is related to bug #1263228, all indicators affected).

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers