IBus stops working when using Alt+Tab to switch between windows

Bug #1233037 reported by Hong Nguyen on 2013-09-30
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Indicator keyboard
Confirmed
Undecided
Unassigned
Unity HUD
New
Undecided
Unassigned
indicator-keyboard (Ubuntu)
Undecided
Unassigned

Bug Description

I'm using Ubuntu 13.10 final beta. I have installed ibus-unikey to type Vietnamese and added it to the new indicator-keyboard but there is some problem with it. While I was typing then using alt+tab to switch to another window then switched back and I couldn't type Vietnamese anymore. The indicator-keyboard's icon on the panel shows that I'm still using ibus-unikey but I can't type Vietnamese or see pre-edit working. Sometimes switching to another window then switching back solves the problem but sometimes it doesn't. I have to restart ibus every time this problem occurs to resolve it.
By the way, I can't edit the preferences of ibus-unikey with the Text Entry because there is no option to show the language bar.

Hong Nguyen (nghongbk) on 2013-09-30
description: updated

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1233037/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
Hong Nguyen (nghongbk) on 2013-09-30
description: updated
affects: ubuntu → indicator-keyboard (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-keyboard (Ubuntu):
status: New → Confirmed
Eduardo (ludentico) wrote :

I was also wondering what the problem may be, until I found your report and tested the Alt+Tab combination and got the same result. I have Spanish (Latin America) keyboard layout and then it goes to an English layout, although I don't have it as an input source. This happens frequently to me with skype and mendeley

tags: added: keyboard
removed: bot-comment
Eduardo (ludentico) on 2013-10-20
affects: indicator-keyboard (Ubuntu) → ibus
affects: ibus → indicator-keyboard
Eduardo (ludentico) wrote :

Workaround:

If something is wrong with the keyboard layout, press the ALT key to invoke HUD. Then it works with the "right" layout. So, my guess it has to do with the HUD

tags: added: hud

I'm experiencing this problem in Kubuntu 14.04 too. I'm using Ibus-anthy and Spanish, German, English, and Japanese languages in my system. My default language is Spanish and everything is up-to-date.

When I write on GTK programs like Firefox, Thunderbird or Libreoffice everything is fine. However if I do alt+tab, I lose the ability to write the Spanish accents. For some reason, this is persistent in Libreoffice and Thunderbird but not in Firefox. Any QT program doesn't experience this fortunately.

A workaround I found was to disable ibus and begin a new Libreoffice instance for example. By doing this, if I switch alt+tab everything seems cool.

Ted Gould (ted) on 2014-11-10
Changed in indicator-keyboard (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers