date/time indicator displays string 'Time' instead of date/time on Wubi installation

Bug #855287 reported by Jean-Baptiste Lallement on 2011-09-21
24
This bug affects 5 people
Affects Status Importance Assigned to Milestone
indicator-datetime (Ubuntu)
High
Michael Terry
Oneiric
High
Michael Terry
lupin (Ubuntu)
Undecided
Unassigned
Oneiric
Undecided
Unassigned

Bug Description

Oneiric Desktop 20110921 amd64 Wubi French

After a fresh wubi installation the indicator displays the string 'Time' instead of the date and time. Screenshot attached

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: indicator-datetime 0.2.95-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
Uname: Linux 3.0.0-11-generic x86_64
ApportVersion: 1.23-0ubuntu1
Architecture: amd64
Date: Wed Sep 21 09:13:46 2011
ProcEnviron:
 PATH=(custom, no user)
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
SourcePackage: indicator-datetime
UpgradeStatus: No upgrade log present (probably fresh install)

Jean-Baptiste Lallement (jibel) wrote :
Changed in indicator-datetime (Ubuntu Oneiric):
importance: Undecided → High
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
milestone: none → ubuntu-11.10
tags: added: iso-testing
Martin Pitt (pitti) on 2011-09-21
Changed in indicator-datetime (Ubuntu Oneiric):
assignee: Canonical Desktop Team (canonical-desktop-team) → Michael Terry (mterry)
Changed in indicator-datetime (Ubuntu Oneiric):
status: New → Confirmed
Evan (ev) wrote :

This was due to a bug in lupin that removed /etc/timezone.

Changed in lupin (Ubuntu Oneiric):
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lupin - 0.47

---------------
lupin (0.47) oneiric; urgency=low

  * Fix a typo that was preventing the timezone from getting set in Wubi
    disk image installs (LP: #855287).
  * Provide a warning that the desktop is not localized and that
    Language Support needs to be run, for Wubi disk image installs in
    languages other than English (LP: #855295).
 -- Evan Dandrea <email address hidden> Thu, 22 Sep 2011 12:20:19 +0100

Changed in lupin (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Pedro Villavicencio (pedro) wrote :

If the issue was due to lupin then i'm closing the indicator-datetime task as Invalid, thanks.

Changed in indicator-datetime (Ubuntu Oneiric):
status: Confirmed → Invalid
Changed in indicator-datetime (Ubuntu Oneiric):
status: Invalid → Confirmed
Jean-Baptiste Lallement (jibel) wrote :

Please leave a comment if you think the status 'Invalid' is wrong.

Changed in indicator-datetime (Ubuntu Oneiric):
status: Confirmed → Invalid
Bernard Banko (beernarrd) wrote :

I have updated from natty (not a wubi installation) and I have the "Time" string on the indicator instead of the time. I think this is the same issue.

Changed in indicator-datetime (Ubuntu Oneiric):
status: Invalid → New
Jean-Baptiste Lallement (jibel) wrote :

Thanks Bernard, coulod you please file a new report instead, this one was specific to Wubi.

Changed in indicator-datetime (Ubuntu Oneiric):
status: New → Invalid
Eric Belhaire (ebelhaire) wrote :

I have the exact same problem after an ubuntu update.
Running : "sudo dpkg-reconfigure tzdata" solved the problem by creating /etc/timezone
Hope this helps.
Eric

Christian Assig (chrassig) wrote :

Like Eric, I also had the problem after upgrading from natty to oneiric yesterday.

/etc/timezone was missing, and it was created when I was running:
sudo dpkg-reconfigure tzdata

This solved the problem for me.

Christian Assig (chrassig) wrote :

@Jean-Baptiste:

There are already a few bugs that are not related to wubi, for example #863341. But these bugs are marked as duplicates of this bug. Should someone change the status of one of these bugs from duplicate to confirmed?

I think they have been duplicated by mistake as this one was very specific to Wubi and disk image installation others are more generally affecting Unity. I'll fix the statuses.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers