Part of the time appears cut off when displaying the day of the week and date

Bug #730476 reported by David Planella on 2011-03-07
126
This bug affects 26 people
Affects Status Importance Assigned to Milestone
Indicator Date and Time
Fix Released
Medium
Ted Gould
Unity Foundations
Medium
Ted Gould
indicator-datetime (Ubuntu)
Low
Unassigned
xserver-xorg-video-intel (Ubuntu)
Low
Unassigned
xserver-xorg-video-nouveau (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: indicator-datetime

See the attached screenshot. The time part in the indicator label is cut off because the indicator does not grow to display all of its content.

That's with the Ubuntu Classic Destop (No effect) session, and removing indicator-complete from the panel and re-adding it does not make any difference.

Related branches

David Planella (dpm) wrote :
description: updated
Benjamin Drung (bdrung) wrote :

I experience the same issue with indicator-datetime 0.1.96-0ubuntu1 on an up-to-date natty system (screenshot attached).

Changed in indicator-datetime (Ubuntu):
status: New → Confirmed
Benjamin Drung (bdrung) wrote :
Lorenzo De Liso (blackz) wrote :

The problem happens even if the date isn't displayed. Screenshot attached.

Lorenzo De Liso (blackz) wrote :

The problem doesn't happen with the 3D drivers installed. I have a Nvidia GeForce 7500 LE and I installed the 3D open source drivers available for that card.

RedSingularity (redsingularity) wrote :

Can you run the following and paste all the output under "VGA compatible controller:"?

lspci -v

Thanks.

Benjamin Drung (bdrung) wrote :

My system:

00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09) (prog-if 00 [VGA controller])
 Subsystem: ASUSTeK Computer Inc. Device 844d
 Flags: bus master, fast devsel, latency 0, IRQ 51
 Memory at fe000000 (64-bit, non-prefetchable) [size=4M]
 Memory at c0000000 (64-bit, prefetchable) [size=256M]
 I/O ports at f000 [size=64]
 Expansion ROM at <unassigned> [disabled]
 Capabilities: <access denied>
 Kernel driver in use: i915
 Kernel modules: i915

Lorenzo De Liso (blackz) wrote :

02:00.0 VGA compatible controller: nVidia Corporation G72 [GeForce 7500 LE] (rev a1) (prog-if 00 [VGA controller])
 Flags: bus master, fast devsel, latency 0, IRQ 16
 Memory at fa000000 (32-bit, non-prefetchable) [size=16M]
 Memory at e0000000 (64-bit, prefetchable) [size=256M]
 Memory at fb000000 (64-bit, non-prefetchable) [size=16M]
 [virtual] Expansion ROM at fc000000 [disabled] [size=128K]
 Capabilities: <access denied>
 Kernel driver in use: nouveau
 Kernel modules: nouveau, nvidiafb

RedSingularity (redsingularity) wrote :

The error looks like its in the intel driver and the nouveau as well.

Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Confirmed
Changed in xserver-xorg-video-nouveau (Ubuntu):
status: New → Confirmed
Changed in indicator-datetime:
status: New → Invalid

The clock is part of the indicator-applet-complete package as the description said. That package, is in turn, part of the indicator-applet package, therefore I moved it accordingly.

affects: indicator-datetime (Ubuntu) → indicator-applet (Ubuntu)

Well this seems to be a duplicate of a large master bug. bug 439448. Marking.

David Planella (dpm) wrote :

RedSingularity, I'm not sure this is a duplicate.

Bug 439448 is about the contents of applets getting scrambled, which is not the case here. Also, the current one is always reproducible, whereas 439448 triggers in an apparently random fashion.

I'll unmark it for now, but if you think it still is, please feel free to elaborate on the reasons and mark it as a duplicate again.

Thanks!

Sebastien Bacher (seb128) wrote :

the issue is clearly not a video driver one nor a duplicate of this gnome-panel issue

Changed in xserver-xorg-video-intel (Ubuntu):
importance: Undecided → Low
status: Confirmed → Invalid
Changed in xserver-xorg-video-nouveau (Ubuntu):
status: Confirmed → Invalid
importance: Undecided → Low
Changed in indicator-datetime:
status: Invalid → New
Sebastien Bacher (seb128) wrote :

can't confirm the issue there though

Lucazade (lucazade) wrote :

https://bugs.launchpad.net/indicator-datetime/+bug/736092

same issue for me, present on different machines.

David Barth (dbarth) wrote :

It more sounds like a formatting problem that makes the indicator extend outside the limits of it's requested display area. Indicators can provide a template to help the panel allocate space for the worst case scenario. But in this case, it seems it outran the XX:XX template.

Sebastien Bacher (seb128) wrote :

is anybody getting the issue under unity or is a specific to the gnome-applet?

Changed in indicator-applet (Ubuntu):
importance: Undecided → Low
Lucazade (lucazade) wrote :

I get this issue under unity and also under classic gnome session (gnome-panel)

Florian Boucault (fboucault) wrote :

This bug also happens when you select the simplified chinese locale, see attached screenshot.

Florian Boucault (fboucault) wrote :

@Sebastien, given that is seems to affect Chinese users using GNOME and Unity 2D, I would raise the importance of the bug.

Sebastien Bacher (seb128) wrote :

right, what I'm trying to figure is where to assign the bug, it seems to not happen on unity-3d so it seems the issue is not in the indicator but in the renderer side, which is indicator-applet from GNOME, not sure for unity-2d?

Karl Lattimer (karl-qdh) wrote :

unity 2d uses the gnome panel as well I believe, and it's indicator-applet-complete or indicator-applet there are a few packages for various indicator bits in the gnome panel.

I've investigated this bug a bit, and there's a guide being set in indicator-datetime and that guide is adequate as it works for unity3d, so I took a poke at the indicator-applet-complete and couldn't find anything that may particularly limit it.

I imagine there's some calculation going wrong somewhere down the line and it'll be in indicator-applet somewhere.

Changed in indicator-datetime:
assignee: nobody → Karl Lattimer (karl-qdh)
status: New → In Progress
Karl Lattimer (karl-qdh) wrote :

Digging deeper into indicator-applet it appears this code just responds to the size request that the indicator makes, which should be perfectly ample.

I doubt there is a way to detect indicator side if you're unity2d or unity3d particularly easily, and even then I wouldn't really want to special case the size stuff for one over the other.

The effected code appears to be in indicator-datetime.c, guess_label_size.

I'll poke at this particular function and test some things and see what kinds of results I get.

Karl Lattimer (karl-qdh) wrote :

I think it's possible that the indicator might be calculating the size with the incorrect style, that style may be valid for unity3d but not for unity2d. The style would change after it has been packed into the container.

This might be quite difficult to fix.

Lucazade (lucazade) wrote :

some screenshots in all 3 different sessions...

gnome-panel: http://i.imgur.com/GNsR1.png
unity2D : http://i.imgur.com/kO8Rh.png
unity3D : http://i.imgur.com/1d8TC.png

Karl Lattimer (karl-qdh) on 2011-04-15
Changed in indicator-applet (Ubuntu):
assignee: nobody → Karl Lattimer (karl-qdh)
Lucazade (lucazade) wrote :

Any news on this issue?

Omer Akram (om26er) on 2011-05-29
affects: indicator-applet (Ubuntu) → indicator-datetime (Ubuntu)
Jörn Horstmann (jhorstmann) wrote :

I noticed this might be related to subpixel smoothing. When switching to monochrome font rendering the size of the label exactly matches the calculated size found in the logs. With subpixel smoothing enabled the label seems to be a bit wider.

Indicator-Datetime-Message: Checking against 84 posible times
Indicator-Datetime-Message: Guessing max time width: 57

Jörn Horstmann (jhorstmann) wrote :

Ok, in my case it was a different problem. I had configured language support to display numbers and dates in german, with an otherwise english installation. My custom date format included the name of the day. The indicator applet was then using one locale to measure the maximum size of the string, and another to actually render the string.

In the code, measuring is done using the strftime function while the rendering uses g_date_time_format. It seems these two functions use different parts of the locale settings.

I hacked the code to use g_date_time_format in both cases and it is now displaying correctly for me.

tags: added: patch
Remon Huijts (rahuijts) wrote :

"In the code, measuring is done using the strftime function while the rendering uses g_date_time_format. It seems these two functions use different parts of the locale settings."

This explains Bug #775113 as well.

Ted Gould (ted) on 2011-08-31
Changed in indicator-datetime:
assignee: Karl Lattimer (karl-qdh) → Ted Gould (ted)
Changed in indicator-datetime (Ubuntu):
assignee: Karl Lattimer (karl-qdh) → nobody
Changed in unity-foundations:
status: New → In Progress
assignee: nobody → Ted Gould (ted)
importance: Undecided → Medium
Changed in indicator-datetime:
importance: Undecided → Medium
Changed in unity-foundations:
milestone: none → oneiric-beta-2
Lucazade (lucazade) wrote :

will this be fixed also in Natty?

Ted Gould (ted) on 2011-09-21
Changed in unity-foundations:
milestone: oneiric-beta-2 → oneiric-final
Ted Gould (ted) on 2011-09-21
Changed in unity-foundations:
status: In Progress → Fix Committed
Changed in indicator-datetime:
status: In Progress → Fix Committed
milestone: none → 0.2.96
Ted Gould (ted) on 2011-09-29
Changed in indicator-datetime:
milestone: 0.2.96 → 0.3.0
Ted Gould (ted) on 2011-09-29
Changed in indicator-datetime:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-datetime - 0.3.0-0ubuntu1

---------------
indicator-datetime (0.3.0-0ubuntu1) oneiric; urgency=low

  [ Ken VanDine ]
  * debian/control
    - Added recommends for e-d-s

  [ Ted Gould ]
  * New upstream release.
    * Fix corrupt environment when LANGUAGE not set (LP: #861123)
    * Measure string size with GLib (LP: #730476)
    * Free ECals when they have errors (LP: #774071)
    * Fix untranslated string (LP: #853130)
 -- Ted Gould <email address hidden> Thu, 29 Sep 2011 15:39:41 -0500

Changed in indicator-datetime (Ubuntu):
status: Confirmed → Fix Released
Ted Gould (ted) on 2011-09-30
Changed in unity-foundations:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers