indicator-datetime-service crashed with SIGSEGV in update_appointment_menu_items()

Bug #729444 reported by Michael Blennerhassett on 2011-03-05
170
This bug affects 29 people
Affects Status Importance Assigned to Milestone
Indicator Date and Time
Fix Released
High
Karl Lattimer
Unity Foundations
High
Karl Lattimer
indicator-datetime (Ubuntu)
High
Karl Lattimer
Natty
High
Karl Lattimer

Bug Description

Binary package hint: indicator-datetime

At login

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: indicator-datetime 0.1.96-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-5.32-generic 2.6.38-rc6
Uname: Linux 2.6.38-5-generic x86_64
Architecture: amd64
CrashCounter: 1
Date: Sat Mar 5 12:08:23 2011
ExecutablePath: /usr/lib/indicator-datetime/indicator-datetime-service
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
ProcCmdline: /usr/lib/indicator-datetime/indicator-datetime-service
ProcEnviron:
 SHELL=/bin/bash
 LANGUAGE=en_AU:en
 LANG=en_AU.UTF-8
SegvAnalysis:
 Segfault happened at: 0x4048fa: mov 0x0(%rbp,%rcx,1),%edx
 PC (0x004048fa) ok
 source "0x0(%rbp,%rcx,1)" (0x00000000) not located in a known VMA region (needed readable region)!
 destination "%edx" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: indicator-datetime
StacktraceTop:
 ?? ()
 ?? ()
 ?? ()
 g_main_context_dispatch () from /lib/libglib-2.0.so.0
 ?? () from /lib/libglib-2.0.so.0
Title: indicator-datetime-service crashed with SIGSEGV in g_main_context_dispatch()
UpgradeStatus: Upgraded to natty on 2010-11-18 (106 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Related branches

visibility: private → public

StacktraceTop:
 update_appointment_menu_items (user_data=<value optimized out>) at datetime-service.c:780
 start_ecal_timer () at datetime-service.c:296
 check_for_calendar (user_data=<value optimized out>) at datetime-service.c:360
 g_main_dispatch (context=0x7f6d3c001e20) at /build/buildd/glib2.0-2.28.1/./glib/gmain.c:2440
 g_main_context_dispatch (context=0x7f6d3c001e20) at /build/buildd/glib2.0-2.28.1/./glib/gmain.c:3013

Changed in indicator-datetime (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Antono Vasiljev (antono) on 2011-03-06
Changed in indicator-datetime (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

seems similar to bug #729175

summary: indicator-datetime-service crashed with SIGSEGV in
- g_main_context_dispatch()
+ update_appointment_menu_items()
Changed in indicator-datetime:
importance: Undecided → Medium
status: New → Triaged
Changed in indicator-datetime (Ubuntu):
assignee: nobody → Karl Lattimer (karl-qdh)
Martin Pitt (pitti) wrote :

For the record, I can reproduce this perfectly, and am available for debugging. I have several Google calendars (which work fine in Evo).

Changed in indicator-datetime (Ubuntu Natty):
importance: Medium → High
Changed in indicator-datetime:
importance: Medium → High
David Barth (dbarth) on 2011-03-09
Changed in unity-foundations:
assignee: nobody → Karl Lattimer (karl-qdh)
importance: Undecided → High
milestone: none → ubuntu-11.04-beta-1
status: New → Confirmed
Changed in indicator-datetime:
assignee: nobody → Karl Lattimer (karl-qdh)
David Barth (dbarth) on 2011-03-14
Changed in unity-foundations:
milestone: unity-3.8.0-beta → unity-3.6.6
Karl Lattimer (karl-qdh) wrote :

@Martin can you try and reproduce with either the branch I'm about to propose or with trunk if it's merged.

My valgrinding shows the cause of the issue is gone, please try it out for yourself.

Ted Gould (ted) on 2011-03-16
Changed in indicator-datetime:
status: Triaged → Fix Released
milestone: none → 0.1.98
Changed in unity-foundations:
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-datetime - 0.1.98-0ubuntu1

---------------
indicator-datetime (0.1.98-0ubuntu1) natty; urgency=low

  * New upstream release.
    ∘ Make appointments match calendar month
    ∘ Fix time format of appointments
    ∘ Get date change signals from calendar and adjust based on them.
    ∘ Crash fixes (LP: #733833, LP: #729444)
    ∘ Valgrind invalid read (LP: #729175)
    ∘ Translation fixes to date label (LP: #729632)
    * Fix handling of reoccruing events
    * Handle settings in the indicator
    * Allow for hiding the calendar and the clock
 -- Ted Gould <email address hidden> Wed, 16 Mar 2011 16:17:38 -0500

Changed in indicator-datetime (Ubuntu Natty):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers