With indicator-datetime calendar focused, cannot use arrow keys to navigate to other indicators

Bug #676222 reported by Greg A on 2010-11-16
102
This bug affects 18 people
Affects Status Importance Assigned to Milestone
Indicator Date and Time
Triaged
Medium
Unassigned
Indicator Display Objects
Triaged
Medium
Unassigned
One Hundred Papercuts
Medium
Unassigned
Unity Foundations
Medium
Ted Gould
indicator-datetime (Ubuntu)
Medium
Unassigned

Bug Description

indicator-datetime 0.3.90-0ubuntu1, libido3-0.1-0 | 0.3.1-0ubuntu3, Ubuntu 12.04 beta 1 and earlier

If whilst the date indicator is focused, you press the down keyboard arrow (and focus the calendar) then the left/right keyboard navigation breaks. The keyboard effectively gets "stuck" - there's no escape from the calendar.

You cannot press the up arrow (which you might intuitively expect to undo the down arrow press).

1. Open the clock menu.
2. Press Down.
3. Press Down.
4. Press Up.
5. Press Left.

What happens:
2. The date item is highlighted.
3. Whichever date in the calendar was last highlighted in this Ubuntu session is highlighted.
4. If that date was in the first week of the month, nothing. Otherwise, the previous week is highlighted.
5. If that date was the first displayed, nothing. Otherwise, the previous date is highlighted.

What should happen:
2. The date item is highlighted.
3. The month element in the calendar is highlighted.
4. The date item is highlighted.
5. The sound menu is opened.

<https://wiki.ubuntu.com/TimeAndDate#menu-calendar>: "Up and Down should navigate to the previous and next weeks within the current month only; beyond the current month they should exit the grid."

Greg A (etulfetulf) wrote :
Changed in indicator-datetime (Ubuntu):
status: New → Confirmed

Thanks a lot for reporting this. The problem you describe arises from an inconsistency in the behaviour of the calendar applet and of the rest of the indicator applets. However, I have noticed from the latest 11.04 development release that the calendar applet has been redesigned to behave like the others, so there should no longer be a problem once Natty is released. Closing bug report.

Changed in hundredpapercuts:
status: New → Invalid
Greg A (etulfetulf) wrote :

Thank you for the comment Chris but I think you have missed the point of this bug. The problem is with the (new) Indicator applet (not with the old panel applet).

Changed in hundredpapercuts:
status: Invalid → New

Greg, I realise now I did indeed misunderstand the nature of this bug. I think the solution to this would be to require the user to use the up arrow to leave the current drop down menu and return to the panel. The expected behaviour is this case would be:

1) User clicks on a menu in the panel. The menu icon is highlighted with Ubuntu orange.
2) User clicks down to enter the menu, and does this several times. Each time the user presses the up/down arrow key while within the menu results in the menu item being highlighted in Ubuntu orange. This is the current behaviour.
3) Currently, the user can use the left/right arrow keys to cycle through the menus while focus is on one of the menu items i.e. they don't have to leave the menu. I think this should change. Instead, the user should be required to navigate back to the menu with the up arrow before they can move to an adjacent menu.

This would solve the problem currently experienced with the Datetime menu in Natty.

Confirming as a paper cut.

Changed in hundredpapercuts:
status: New → Triaged
importance: Undecided → Medium
Ted Gould (ted) on 2011-02-08
Changed in indicator-datetime:
status: New → Confirmed
importance: Undecided → Medium
Changed in indicator-datetime (Ubuntu):
importance: Undecided → Medium
Changed in ido:
status: New → Confirmed
importance: Undecided → Medium
Matthew Paul Thomas (mpt) wrote :

In any grid menu layout (such as the calendar), the Left and Right keys will often do something special instead of opening the previous/next top-level menu as they usually do. This is no great problem; the same is true for submenu titles, for example. What is important is that you can quickly navigate out of the grid, back to a point where Left and Right *do* open the previous/next top-level menu.

In this particular example, if a date in the first week of the month is highlighted, pressing Up once or (once bug 740821 is fixed) twice should return to a point where Left and Right will navigate to the previous/next top-level menu.

David Barth (dbarth) wrote :

Or, because that may require too much open heart surgery, prevent the keyboard focus to enter the calendar menu item at all, and just let the user navigate between "regular" items, up to the "Time & Date Settings..." one for example.

David Barth (dbarth) wrote :

@Karl: can you investigate whether IDO could ignore keyboard focus/navigation for the calender item?

Changed in indicator-datetime:
assignee: nobody → Karl Lattimer (karl-qdh)
tags: added: a11y
Changed in unity-foundations:
assignee: nobody → Karl Lattimer (karl-qdh)
importance: Undecided → Medium
status: New → Triaged
milestone: none → unity-3.8.0-beta
Karl Lattimer (karl-qdh) on 2011-03-24
Changed in indicator-datetime (Ubuntu):
status: Confirmed → In Progress
Karl Lattimer (karl-qdh) on 2011-03-24
Changed in unity-foundations:
status: Triaged → In Progress
Karl Lattimer (karl-qdh) wrote :

So I've checked in the code and it's definitely a case of either we can navigate the calendar with the keyboard, or we get stuck in it. This is another bug which points to us writing our own calendar widget.

I'll see if I can ignore the focus of the calendar by keyboard navigation, however if you disable all the focus stuff you'll never be able to click on the month/year buttons or select a day.

Prising these two bits apart might be tricky.

Karl Lattimer (karl-qdh) wrote :

After some deeper investigation it seems that no changes I make to the focus behaviour have any effect after restarting the indicator and the service. I tried removing the move-focus, select/deselect callbacks and yet the calendar still gets focus and doesn't let go.

David Barth (dbarth) wrote :

Ok, put that on hold then. There are other bugs with a higher priority for now.

Karl Lattimer (karl-qdh) wrote :

I've created the following bug to group these calendar widget related issues;

"IDO calendar should replace GtkCalendar wrapper with a grid layout menu"
https://bugs.launchpad.net/ubuntu/+source/ido/+bug/742370

Karl Lattimer (karl-qdh) on 2011-03-25
Changed in unity-foundations:
status: In Progress → Triaged
Changed in indicator-datetime (Ubuntu):
status: In Progress → Confirmed
David Barth (dbarth) on 2011-04-04
Changed in unity-foundations:
milestone: unity-3.8.2 → unity-3.8.4
Timo Jyrinki (timo-jyrinki) wrote :

For me the major problem I noticed besides smaller usability problems is that if I use only keyboard - ie. F10 to get to the menu and then navigate to indicators - if I get into the calendar widget, it seems there is _no key at all_ that can be pressed so that I could close the indicator or get out of the calendar widget. That means alt-tab, F10, Esc, arrows, nothing helps. Which means that without a pointing device, or eg. a broken pointing device, person is actually completely stuck inside the widget until forcefully rebooting the computer (or switching to terminal and killing some processes).

At the very least handling Esc in the calendar widget to close the indicator before natty release should be done (if changing the widget to another gets delayed).

David Barth (dbarth) on 2011-04-12
Changed in unity-foundations:
milestone: unity-3.8.4 → unity-3.8.6
David Barth (dbarth) on 2011-08-29
Changed in unity-foundations:
milestone: unity-3.8.6 → none
assignee: Karl Lattimer (karl-qdh) → Ted Gould (ted)
Changed in indicator-datetime:
assignee: Karl Lattimer (karl-qdh) → Ted Gould (ted)
Javier Jardón (jjardon) wrote :

This was fixed with the latest updates available in Oneiric

Changed in indicator-datetime:
status: Confirmed → Fix Released
Changed in ido:
status: Confirmed → Fix Released
Greg A (etulfetulf) wrote :

Hi Javier, I'm still seeing this bug in a fully updated Oneiric. Which package versions should the fix be in?

Greg A (etulfetulf) on 2011-10-08
Changed in indicator-datetime:
status: Fix Released → Confirmed
Changed in ido:
status: Fix Released → Confirmed

Hello Greg,

I can use the left/right keyboard arrows to navigate through the different indicators without any problems here. I have a Oneiric instalation updated as today.
Be sure that you have the 0.3.0-0ubuntu4 version of libido3 or later.

summary: - Broken/confusing keyboard navigation
+ Impossible to to use the left/right keyboard arrows to navigate through
+ the different indicators.
Changed in indicator-datetime:
status: Confirmed → Fix Released
Changed in ido:
status: Confirmed → Fix Released
Changed in indicator-datetime (Ubuntu):
status: Confirmed → Fix Released
Changed in unity-foundations:
status: Triaged → Fix Released
Changed in hundredpapercuts:
status: Triaged → Fix Released
Greg A (etulfetulf) wrote :

Dear Javier,

I think you have missed the core of this bug report. (I realise that its name was misleading.)

If whilst you the date indicator is focused, you press the down keyboard arrow (and focus the calendar) then the left/right keyboard navigation breaks. Also, you cannot press the up arrow (which you might intuitively expect to undo the down arrow press).

Greg A (etulfetulf) on 2011-10-08
summary: - Impossible to to use the left/right keyboard arrows to navigate through
- the different indicators.
+ Once indicator-datetime calendar is focused, cannot use left/right
+ keyboard arrows to navigate through different indicators.

Hello Greg

> If whilst you the date indicator is focused, you press the down keyboard arrow (and focus the calendar) then the left/right
> keyboard navigation breaks. Also, you cannot press the up arrow (which you might intuitively expect to undo the down arrow
> press).

Thats bug #758550, this bug is about navigate between the indicators.

Greg A (etulfetulf) wrote :

Ss the original reporter of this bug, I know that this bug is about what I just described.

So thank you for pointing out bug #758550. I have marked it as a duplicate of this bug so we don't lose the valuable comments on this bug, both about fixing it (from mpt, David Barth, Karl Lattimer) and about accessibility problems raised (from Timo Jyrinki).

description: updated
description: updated
tags: added: amd64 natty oneiric
removed: ubuntu-une
Greg A (etulfetulf) on 2011-10-13
Changed in indicator-datetime (Ubuntu):
status: Fix Released → Confirmed
Changed in indicator-datetime:
status: Fix Released → Confirmed
Changed in unity-foundations:
status: Fix Released → Confirmed
Changed in hundredpapercuts:
status: Fix Released → Invalid
Changed in ido:
status: Fix Released → Confirmed
Javier Jardón (jjardon) wrote :

@Greg:

Could you change the title and description then? I can navidate between different indicators without any problem after the latest ido update.

description: updated
summary: - Once indicator-datetime calendar is focused, cannot use left/right
- keyboard arrows to navigate through different indicators.
+ With indicator-datetime calendar focused, cannot use arrow keys to
+ navigate to other indicators
Charles Kerr (charlesk) on 2012-04-03
Changed in indicator-datetime:
assignee: Ted Gould (ted) → Charles Kerr (charlesk)
description: updated
Changed in indicator-datetime:
status: Confirmed → Triaged
Changed in ido:
status: Confirmed → Triaged
Ted Gould (ted) on 2012-09-10
Changed in unity-foundations:
status: Confirmed → Invalid
Charles Kerr (charlesk) on 2014-03-13
Changed in indicator-datetime:
assignee: Charles Kerr (charlesk) → nobody
Charles Kerr (charlesk) on 2016-03-19
Changed in indicator-datetime (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions