Calendar date is unreadable when using Ambience theme

Bug #649882 reported by James Troup on 2010-09-28
66
This bug affects 12 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Undecided
Unassigned
DBus Menu
Invalid
Wishlist
Ted Gould
Indicator Date and Time
Fix Released
Medium
Unassigned
light-themes
Invalid
Undecided
Unassigned
indicator-datetime (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: indicator-datetime

I can't read the date that appears below the time when you click on the time in the date time indicator. With the ambience theme it appears to be black text on a dark gray background.

Ted Gould (ted) wrote :

Adding in ayatana-design to get design feedback on it. Marking as incomplete in indicator-datetime as we'll need that feedback before making any code changes.

Changed in indicator-datetime:
status: New → Incomplete
importance: Undecided → Medium
Changed in indicator-datetime (Ubuntu):
status: New → Incomplete
importance: Undecided → Medium
Changed in ayatana-design:
status: New → Confirmed

When theses feedback comin?

Paul Sladen (sladen) on 2011-01-07
summary: - the date is unreadable when using the ambience theme
+ Calendar date is unreadable when using Ambience theme
Paul Sladen (sladen) wrote :

elmo: can you attach a screenshot if you're still seeing this; I can't replicate it on natty:

Paul Sladen (sladen) wrote :

Oops, that got posted instead of the attachment, I of course /can/ reproduce it on natty under both Luminance and Radiance as shown (see attachment).

The problem is an extremely low-contrast between text that needs to be read, and the background colour. It appears that it might be being rendered using the "disabled menu item" colour choices, but that probably isn't suitable for text that actually needs to be understood by the user.

I presume that the bottom of the two pieces of text "Time & Date Settings..." (and the specifc one that James originally spotted) is intended to be a menu-item link again long-term of this should be considered when doing any mockups to try and solve this.

Perhaps the solution would be to make the top date a clickable menu-item that resets the calendar to the current date (currently the calendar doesn't provide any indication the user whether the highlighted date is the current one, which can be misleading if forgotten).

Paul Sladen (sladen) wrote :

Root cause is probably bug #627796 ("Disabled text in menu bar is nearly invisible").

David Barth (dbarth) wrote :

The root cause is that we need a new item type to represent "informational" items, as opposed to disabled menu items used to represent informational elements.

This needs to be supported at the level of dbusmenu and be used explicitely by apps or system services.

Aurélien Gâteau (agateau) wrote :

Design has not had the time to provide feedback yet, so marking again as incomplete.

Changed in ayatana-design:
status: Confirmed → Incomplete
Dylan McCall (dylanmccall) wrote :

I think we could relate this to bug #709434; that the calendar widget is too complicated for its task as well. That bug is currently filed as a theme issue, but maybe a good solution is to have a custom informational calendar widget. The current calendar widget was designed for selecting a date; something we don't actually _use_ in the datetime indicator. It would make sense for that custom widget to display the current date as a label, since how that is presented is dependent on the calendar itself.

David Planella (dpm) wrote :

On the other hand, now that the day of the week and date can be shown in the indicator label by choosing them in the settings, is it really necessary to show them again on top of the calendar?

Marking as triaged - if we accept the logic behind David's comment #6 the work item here is to figure out if/how to support informational menu items (and then codify the outcome of that ofcourse).

Changed in dbusmenu:
assignee: nobody → Ted Gould (ted)
importance: Undecided → Low
status: New → Triaged
Ted Gould (ted) wrote :

Marking as incomplete for dbusmenu if the bug is that there needs to be a new way to express information then it's not yet ready to code for dbusmenu and needs more information.

Changed in dbusmenu:
importance: Low → Wishlist
status: Triaged → Incomplete
Ted Gould (ted) wrote :

Marking as confirmed for design as design is needed to say how this type of information should be visualized.

Changed in ayatana-design:
status: Incomplete → Confirmed
Paul Sladen (sladen) wrote :

I believe it's the same root-cause that makes Skype have unreadable menus too.

Sebastien Bacher (seb128) wrote :

is that on the list of issues to fix this cycle?

Karl Lattimer (karl-qdh) wrote :

With a recent change this might be fixed; https://bugs.launchpad.net/ubuntu/+source/indicator-datetime/+bug/740819

the idea is the date item will be sensitive when evolution is installed.

Karl Lattimer (karl-qdh) wrote :

I'm marking this as fix-released because the package now does not make the date insensitive all the time. If evolution is installed it will be insensitive and will show up dim and difficult to read.

I imagine eventually this will be fixed in some universal way in that all insensitive menu items will become more readable.

This is not the same issue which effects skype as far as I can tell.

Changed in indicator-datetime (Ubuntu):
status: Incomplete → Fix Released
Karl Lattimer (karl-qdh) wrote :

Sorry to correct what I wrote, if evolution ISN'T installed it'll show up insensitive.

Paul Sladen (sladen) on 2011-04-17
Changed in light-themes:
status: New → Incomplete
status: Incomplete → Invalid
Changed in indicator-datetime:
status: Incomplete → Fix Released
Changed in dbusmenu:
status: Incomplete → Invalid
Changed in ayatana-design:
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related blueprints