integration with Evolution calendar events and time locations

Bug #542218 reported by Ivan Zorin on 2010-03-19
58
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Indicator Date and Time
Fix Released
Medium
Karl Lattimer
indicator-datetime (Ubuntu)
Medium
Karl Lattimer

Bug Description

Disclaimer: this is not a bug actually, but some feature request (wishlist only) with some thoughts, proposes and its rationale.

Now we have almost consistent indicator-applet environment. As far as I understand, indicator-datetime should replace one of the last part - standart GNOME Clock Applet. But clock applet has good integration with events from evolution calendars and support time for different locations (see datetime_events_locations.png in attach). So, I've made some raw rough mockup, which I would like to propose as one way of possible solutions (see datetime_mockup.jpeg attach). As you can see:
 - if in current month should be some incoming events, it's should be shown under separator for date menu item (past events still could be there, but if so, then its should be unsensitive, for example);
- I can't see the point and adventages in "Open Calendar..." before "Calendar...", so I've just decided to rename it in my mockup;
- although, there is possible at least couple ways:
  1. clicking on any incoming event opens calendar, so there is no need in a separate "Calendar" item;
  2. clicking on incoming event opens selected event for edit - in this case "Calendar" item should be stay (just for open Evolution calendar as now);
- time locations: it can be "radio menu items", each of them should be shown with local time (i don't think that symbols like "GMT -3" or "CET +2" really necessary) and city name;
- clicking on some local time menu item switched indicator's time to selected location's time;
- I can't see the point in the changing system (!) time ("Set Time and Date..." menu item) by requiring administrative (!) privileges, in view of the facts, that it's:
  1. detects very well on booting
  2. can be switched in System -> Administration -> Time and Date
Instead of that user should be able just set up preffered locations, which detects time automatically (like Clock Applet does).
So, "Locations..." item should provide some easy to use dialog settings window, where user can set up locations (something like "Locations" tab in Clock Applet's "Preferences"); also there are should be some settings for time/date format (see also bug #542173 for this), because, for example, in some cultures they don't preffer to use AM/PM time division, etc.; of course, such custom settings should be affect on all local time menu items.

Thank you for your attention.

Related branches

Ivan Zorin (iaz) wrote :
tags: removed: experience interface user
Ivan Zorin (iaz) wrote :
Ted Gould (ted) on 2010-05-21
Changed in indicator-datetime:
status: New → Triaged
importance: Undecided → Wishlist
Adi Roiban (adiroiban) wrote :

If indicatator-datetime is going to be used by default on the desktop for Natty, I think that this bug should be changed from wishlist to a higher priority since not having multiple timezone clocks and calendar events integration is a big regression.

My mother may not need Evolution calendar integration, but she would like to know what is the time and weather for her friend living on the other side of the world.

My manager will definitely want to have all new tasks fetch by SyncEvolution into the clock applet.

any sign if this is on the roadmap for Natty?

Karl Lattimer (karl-qdh) on 2011-01-04
Changed in indicator-datetime:
assignee: nobody → Karl Lattimer (karl-qdh)
status: Triaged → In Progress
Karl Lattimer (karl-qdh) wrote :

Gourgi, I'm working on it now ;)

David Barth (dbarth) on 2011-01-24
Changed in indicator-datetime:
importance: Wishlist → Medium
Changed in indicator-datetime (Ubuntu):
assignee: nobody → Karl Lattimer (karl-qdh)
importance: Undecided → Medium
milestone: none → natty-alpha-2
status: New → In Progress
Karl Lattimer (karl-qdh) wrote :

The present branch has a weird dbusmenu problem in that it's messing with all the indicators most obviously the sound indicator by changing the volume repeatedly.

I can't see anything in my code that might be doing this, so I'm going to put a merge proposal in so we can get a diff between HEAD and my branch.

David Barth (dbarth) on 2011-02-03
Changed in indicator-datetime (Ubuntu):
milestone: natty-alpha-2 → natty-alpha-3
Karl Lattimer (karl-qdh) wrote :

2 new bug reports follow on from this one;

https://bugs.launchpad.net/indicator-datetime/+bug/715844 - Locations/Timezones
https://bugs.launchpad.net/indicator-datetime/+bug/715848 - Coloured icons for appointments

Changed in indicator-datetime:
status: In Progress → Fix Committed
Changed in indicator-datetime (Ubuntu):
status: In Progress → Fix Committed
David Barth (dbarth) wrote :

2 other bugs related as well:
 * https://bugs.launchpad.net/indicator-datetime/+bug/717203 - Improve the timezone selection dialog in the system preferences
 * https://bugs.launchpad.net/indicator-datetime/+bug/717209 - Support remote calendars, asynchronously

Karl Lattimer (karl-qdh) on 2011-02-28
Changed in indicator-datetime:
status: Fix Committed → Fix Released
Changed in indicator-datetime (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints