Use Ubuntu language packs for various Unity packages

Bug #1760435 reported by Khurshid Alam on 2018-04-01
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
indicator-datetime (Ubuntu)
Undecided
Simon Quigley
unity (Ubuntu)
Undecided
Simon Quigley
unity-greeter (Ubuntu)
Undecided
Simon Quigley
unity-lens-applications (Ubuntu)
Undecided
Simon Quigley
unity-lens-files (Ubuntu)
Undecided
Simon Quigley
unity-lens-music (Ubuntu)
Undecided
Simon Quigley
unity-lens-photos (Ubuntu)
Undecided
Simon Quigley
unity-lens-video (Ubuntu)
Undecided
Simon Quigley
unity-scope-calculator (Ubuntu)
Undecided
Simon Quigley
unity-scope-devhelp (Ubuntu)
Undecided
Simon Quigley
unity-scope-home (Ubuntu)
Undecided
Simon Quigley
unity-scope-manpages (Ubuntu)
Undecided
Simon Quigley

Bug Description

The Unity family of packages was previously part of standard Ubuntu. Thus all the translation templates were made available to the translators via Launchpad, and the translations were included in the language packs.

Since those packages are no longer part of standard Ubuntu, they have been moved from main to universe. And translations are dropped.

At the moment, it is feasible for us to keep using langpacks.

That means adding "X-Ubuntu-Use-Langpack: yes" to their debian/control
and doing an upload.

See: https://community.ubuntu.com/t/translation-of-unity-packages/4919

summary: - Use Ubuntu language packs for various unity-components
+ Use Ubuntu language packs for various indicators
Changed in indicator-datetime (Ubuntu):
status: New → Confirmed
Changed in indicator-messages (Ubuntu):
status: New → Confirmed
Changed in indicator-power (Ubuntu):
status: New → Confirmed
Changed in indicator-session (Ubuntu):
status: New → Confirmed
Changed in indicator-sound (Ubuntu):
status: New → Confirmed

Hello.

I'll prepare all of the uploads in Bileto: https://bileto.ubuntu.com/#/ticket/3221

This is mapped to this PPA: https://launchpad.net/~ci-train-ppa-service/+archive/ubuntu/3221/+packages

I'll upload this set of packages there, but then I'd like some verification that this is the whole stack that needs these changes. I also want to know that these changes work...

Changed in indicator-datetime (Ubuntu):
assignee: nobody → Simon Quigley (tsimonq2)
Changed in indicator-messages (Ubuntu):
assignee: nobody → Simon Quigley (tsimonq2)
Changed in indicator-power (Ubuntu):
assignee: nobody → Simon Quigley (tsimonq2)
Changed in indicator-session (Ubuntu):
assignee: nobody → Simon Quigley (tsimonq2)
Changed in indicator-sound (Ubuntu):
assignee: nobody → Simon Quigley (tsimonq2)
Simon Quigley (tsimonq2) wrote :

On further investigation, out of the packages marked as affected, only indicator-datetime needed the change.

Uploaded to the PPA.

Changed in indicator-messages (Ubuntu):
assignee: Simon Quigley (tsimonq2) → nobody
Changed in indicator-power (Ubuntu):
assignee: Simon Quigley (tsimonq2) → nobody
Changed in indicator-session (Ubuntu):
assignee: Simon Quigley (tsimonq2) → nobody
Changed in indicator-sound (Ubuntu):
assignee: Simon Quigley (tsimonq2) → nobody
Changed in indicator-messages (Ubuntu):
status: Confirmed → Invalid
Changed in indicator-session (Ubuntu):
status: Confirmed → Invalid
Changed in indicator-power (Ubuntu):
status: Confirmed → Invalid
Changed in indicator-sound (Ubuntu):
status: Confirmed → Invalid
Gunnar Hjalmarsson (gunnarhj) wrote :

I looked at:

https://launchpadlibrarian.net/362929320/indicator-datetime_15.10+17.10.20170829.2-0ubuntu3_15.10+17.10.20170829.2-0ubuntu4.diff.gz

and it looks perfectly fine to me. Ready for the archive IMO. :) Thanks!

Are you saying that that line is there already for all the other indicator-* packages?

Can you please also check out the unity-* packages, for instance those I mentioned in the community hub.

Gunnar Hjalmarsson (gunnarhj) wrote :

P.S. We will get a final confirmation that it works only after it has been uploaded. This is about what happens when building the package.

Simon Quigley (tsimonq2) wrote :

> Ready for the archive IMO. :) Thanks!

Cool!

> Are you saying that that line is there already for all the other indicator-* packages?

Yep.

> Can you please also check out the unity-* packages, for instance those I mentioned in the community hub.

I'd like a full list of packages needed here before I start making assumptions.

Thanks!

Gunnar Hjalmarsson (gunnarhj) wrote :

I just took a closer look at indicator-sound, and indeed I saw the line "X-Ubuntu-Use-Langpack: yes" which was added at the latest upload on 2017-08-29. And the translation template is present in artful, but not in bionic.

@Sebastien: Someone must have deleted it; I can't see another explanation.

I made an attempt to upload the template manually, but that seems to not have worked. Maybe another upload - just a no-change rebuild? - is needed to make LP acknowledge the template for bionic.

@Sebastien: We need your advice here. Are no-change rebuilds necessary, or is there a better way?

@Simon: As regards the unity-* packages: Yeah, I would like to see a full list too. Just noticed that unity-control-center has that line, but the unity package has not...

Possibly we need to upload all packages, whether that line is already there or not, and add it if it isn't there. But let's await Seb's response before proceeding.

Gunnar Hjalmarsson (gunnarhj) wrote :

I run a command in an attempt to identify Unity packages; see the attached file. It's a long list, and all those packages are reasonably not subject to translation, but it might be something to work with.

Ads20000 (ads20000) wrote :

Something else to work with could be the 17.04 manifest (its `unity` packages (use Ctrl+F) and the relevant dependencies of them).

Gunnar Hjalmarsson (gunnarhj) wrote :

Yep, that's another way.

But identifying each and every package may not be the most urgent thing. The big problem has proved to be that several (most?) Unity packages have the line "X-Ubuntu-Use-Langpack: yes" in the source, but their translation templates have been deleted from LP. Fixing this in one way or another for *the most visible packages with many translatable strings* should be prio one. Hope that Sebastien will advise us about it tomorrow.

Sebastien Bacher (seb128) wrote :

The issue there is/was again that most indicators had translations sharing enabled in launchpad which means the template was not imported from the package on upload. I did unset those now but some of the indicators might need an upload to trigger an import. I uploaded indicator-sound and hit the build failure from bug #1737834 and indicator-power which has its template in the import queue now.

Sebastien Bacher (seb128) wrote :

the templates were desactivated as well in e.g https://translations.launchpad.net/ubuntu/bionic/+source/indicator-power/+pots/indicator-power/+edit for some reason, I re-activated the indicators and unity ones so those package list translations again

Gunnar Hjalmarsson (gunnarhj) wrote :

Ok, so the templates were not deleted, but deactivated. In addition to those which Sebastien reactivated, I have reactivated unity-settings-daemon and unity-control-center for now.

So packages identified so far, which need to be uploaded with "X-Ubuntu-Use-Langpack: yes", are indicator-datetime and unity.

no longer affects: indicator-messages (Ubuntu)
no longer affects: indicator-power (Ubuntu)
no longer affects: indicator-session (Ubuntu)
no longer affects: indicator-sound (Ubuntu)
summary: - Use Ubuntu language packs for various indicators
+ Use Ubuntu language packs for various Unity packages
Gunnar Hjalmarsson (gunnarhj) wrote :

I have added a bunch of other affected packages, whose templates I reactivated and where there is a need to add "X-Ubuntu-Use-Langpack: yes". I also reactivated the templates for:

indicator-appmenu
indicator-keyboard
indicator-printers

which already have "X-Ubuntu-Use-Langpack: yes".

So now I'd say that the affected packages are ready to be uploaded. Hey Simon, are you there? ;)

Simon Quigley (tsimonq2) wrote :

I have uploaded these packages to Bileto, and I would like an ACK before landing them.

https://bileto.ubuntu.com/#/ticket/3221

Gunnar Hjalmarsson (gunnarhj) wrote :

Thanks Simon!

I checked the changes in the PPA for a sample of the packages, and it simply adds that line as we said.

There are some build failures in the PPA, though. However, I couldn't reproduce the failure when uploading unity-lens-photos to my own PPA, so I'd say: Please go ahead with real uploads. If some of those failures repeats itself when building for the archive, let's deal with it then.

For the record: The significance of adding "X-Ubuntu-Use-Langpack: yes" is that future additions and modifications of translatable strings will result in updated translation templates so the new/changed strings will be made available to the translators.

Simon Quigley (tsimonq2) wrote :

The difference between Bileto and a regular PPA is that Bileto does landing of source *and* binary packages directly into proposed. So these need to be addressed prior to landing.

Patches welcome.

Gunnar Hjalmarsson (gunnarhj) wrote :

I have never used Bileto, and don't know how it works. Are you saying that packages handled from there need some other set of Build-Depends than if you simply upload by dput'ing the source?

Anyway, my gut feeling tells me that adding dh-python to Build-Depends might help. I'd suggest that you try that for unity-lens-photos to start with.

Simon Quigley (tsimonq2) wrote :

> I have never used Bileto, and don't know how it works. Are you saying that packages handled from there need some other set of Build-Depends than if you simply upload by dput'ing the source?

With Bileto, it's like uploading to the archive. Once the checks are passed it's all just copied to -proposed.

> Anyway, my gut feeling tells me that adding dh-python to Build-Depends might help. I'd suggest that you try that for unity-lens-photos to start with.

Sure.

Simon Quigley (tsimonq2) wrote :

I'll take care of this today.

Changed in unity (Ubuntu):
assignee: nobody → Simon Quigley (tsimonq2)
status: New → Confirmed
Changed in unity-greeter (Ubuntu):
assignee: nobody → Simon Quigley (tsimonq2)
status: New → Confirmed
Changed in unity-lens-applications (Ubuntu):
assignee: nobody → Simon Quigley (tsimonq2)
status: New → Confirmed
Changed in unity-lens-files (Ubuntu):
assignee: nobody → Simon Quigley (tsimonq2)
status: New → Confirmed
Changed in unity-lens-music (Ubuntu):
assignee: nobody → Simon Quigley (tsimonq2)
status: New → Confirmed
Changed in unity-lens-photos (Ubuntu):
assignee: nobody → Simon Quigley (tsimonq2)
status: New → Confirmed
Changed in unity-lens-video (Ubuntu):
assignee: nobody → Simon Quigley (tsimonq2)
status: New → Confirmed
Changed in unity-scope-calculator (Ubuntu):
assignee: nobody → Simon Quigley (tsimonq2)
status: New → Confirmed
Changed in unity-scope-devhelp (Ubuntu):
assignee: nobody → Simon Quigley (tsimonq2)
status: New → Confirmed
Changed in unity-scope-home (Ubuntu):
assignee: nobody → Simon Quigley (tsimonq2)
status: New → Confirmed
Changed in unity-scope-manpages (Ubuntu):
assignee: nobody → Simon Quigley (tsimonq2)
status: New → Confirmed
Simon Quigley (tsimonq2) wrote :

> Anyway, my gut feeling tells me that adding dh-python to Build-Depends might help.

Indeed, that works.

I've uploaded everything to Bileto, and I plan to land it as soon as everything is built and Bileto does the usual magic.

Simon Quigley (tsimonq2) wrote :

> I plan to land it as soon as everything is built and Bileto does the usual magic.

Manual signoff is done after all builds have completed. Let's see if Britney has anything to say...

Simon Quigley (tsimonq2) wrote :

Landed.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.5.0+18.04.20180404-0ubuntu2

---------------
unity (7.5.0+18.04.20180404-0ubuntu2) bionic; urgency=medium

  * Add "X-Ubuntu-Use-Langpack: yes" to debian/control now that this package is
    in Universe (LP: #1760435).

 -- Simon Quigley <email address hidden> Sat, 07 Apr 2018 11:37:31 -0500

Changed in unity (Ubuntu):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-scope-devhelp - 0.1+14.04.20140328-0ubuntu3

---------------
unity-scope-devhelp (0.1+14.04.20140328-0ubuntu3) bionic; urgency=medium

  * Add "X-Ubuntu-Use-Langpack: yes" to debian/control now that this package is
    in Universe (LP: #1760435).

 -- Simon Quigley <email address hidden> Sat, 07 Apr 2018 11:47:09 -0500

Changed in unity-scope-devhelp (Ubuntu):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-lens-video - 0.3.15+16.04.20160212.1-0ubuntu3

---------------
unity-lens-video (0.3.15+16.04.20160212.1-0ubuntu3) bionic; urgency=medium

  * Add "X-Ubuntu-Use-Langpack: yes" to debian/control now that this package is
    in Universe (LP: #1760435).

 -- Simon Quigley <email address hidden> Thu, 05 Apr 2018 00:05:18 -0500

Changed in unity-lens-video (Ubuntu):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-lens-applications - 7.1.0+16.10.20160927-0ubuntu3

---------------
unity-lens-applications (7.1.0+16.10.20160927-0ubuntu3) bionic; urgency=medium

  * Add "X-Ubuntu-Use-Langpack: yes" to debian/control now that this package is
    in Universe (LP: #1760435).

 -- Simon Quigley <email address hidden> Thu, 05 Apr 2018 00:04:18 -0500

Changed in unity-lens-applications (Ubuntu):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-scope-home - 6.8.2+16.04.20160212.1-0ubuntu3

---------------
unity-scope-home (6.8.2+16.04.20160212.1-0ubuntu3) bionic; urgency=medium

  * Add "X-Ubuntu-Use-Langpack: yes" to debian/control now that this package is
    in Universe (LP: #1760435).

 -- Simon Quigley <email address hidden> Thu, 05 Apr 2018 00:05:54 -0500

Changed in unity-scope-home (Ubuntu):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-lens-photos - 1.0+17.10.20170605-0ubuntu3

---------------
unity-lens-photos (1.0+17.10.20170605-0ubuntu3) bionic; urgency=medium

  * Add "X-Ubuntu-Use-Langpack: yes" to debian/control now that this package is
    in Universe (LP: #1760435).

 -- Simon Quigley <email address hidden> Sat, 07 Apr 2018 11:42:38 -0500

Changed in unity-lens-photos (Ubuntu):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-lens-files - 7.1.0+17.10.20170605-0ubuntu2

---------------
unity-lens-files (7.1.0+17.10.20170605-0ubuntu2) bionic; urgency=medium

  * Add "X-Ubuntu-Use-Langpack: yes" to debian/control now that this package is
    in Universe (LP: #1760435).

 -- Simon Quigley <email address hidden> Thu, 05 Apr 2018 00:04:36 -0500

Changed in unity-lens-files (Ubuntu):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-scope-manpages - 3.0+14.04.20140324-0ubuntu3

---------------
unity-scope-manpages (3.0+14.04.20140324-0ubuntu3) bionic; urgency=medium

  * Add "X-Ubuntu-Use-Langpack: yes" to debian/control now that this package is
    in Universe (LP: #1760435).

 -- Simon Quigley <email address hidden> Sat, 07 Apr 2018 11:47:49 -0500

Changed in unity-scope-manpages (Ubuntu):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-lens-music - 6.9.1+16.04-0ubuntu3

---------------
unity-lens-music (6.9.1+16.04-0ubuntu3) bionic; urgency=medium

  * Add "X-Ubuntu-Use-Langpack: yes" to debian/control now that this package is
    in Universe (LP: #1760435).

 -- Simon Quigley <email address hidden> Thu, 05 Apr 2018 00:04:50 -0500

Changed in unity-lens-music (Ubuntu):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-scope-calculator - 0.1+14.04.20140328-0ubuntu3

---------------
unity-scope-calculator (0.1+14.04.20140328-0ubuntu3) bionic; urgency=medium

  * Add "X-Ubuntu-Use-Langpack: yes" to debian/control now that this package is
    in Universe (LP: #1760435).

 -- Simon Quigley <email address hidden> Sat, 07 Apr 2018 11:44:58 -0500

Changed in unity-scope-calculator (Ubuntu):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-greeter - 18.04.0+18.04.20180314.1-0ubuntu2

---------------
unity-greeter (18.04.0+18.04.20180314.1-0ubuntu2) bionic; urgency=medium

  * Add "X-Ubuntu-Use-Langpack: yes" to debian/control now that this package is
    in Universe (LP: #1760435).

 -- Simon Quigley <email address hidden> Thu, 05 Apr 2018 00:03:39 -0500

Changed in unity-greeter (Ubuntu):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-datetime - 15.10+17.10.20170829.2-0ubuntu4

---------------
indicator-datetime (15.10+17.10.20170829.2-0ubuntu4) bionic; urgency=medium

  * Add "X-Ubuntu-Use-Langpack: yes" to debian/control now that this package is
    in Universe (LP: #1760435).

 -- Simon Quigley <email address hidden> Sun, 01 Apr 2018 20:11:02 -0500

Changed in indicator-datetime (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers