Comment 32 for bug 1754872

Norbert (nrbrtx) wrote :

Bug still exists. Simple installation of Xubuntu Desktop on top of 19.04 (disco) mini.iso with `sudo apt install xubuntu-desktop` results in long list of unwanted GNOME packages.

I have created two outputs of `dpkg -l` before (mini.iso) and after xubuntu-desktop installation.

$ diff before after | grep gnome | awk '{print $3}'
language-pack-gnome-en
language-pack-gnome-en-base
libsoup-gnome2.4-1:amd64
gir1.2-gnomebluetooth-1.0:amd64
gir1.2-gnomedesktop-3.0:amd64
gkbd-capplet
gnome-accessibility-themes
gnome-bluetooth
gnome-control-center
gnome-control-center-data
gnome-control-center-faces
gnome-desktop3-data
gnome-font-viewer
gnome-icon-theme
gnome-keyring
gnome-keyring-pkcs11:amd64
gnome-menus
gnome-mines
gnome-online-accounts
gnome-power-manager
gnome-screensaver
gnome-session-bin
gnome-session-common
gnome-settings-daemon
gnome-settings-daemon-common
gnome-shell
gnome-shell-common
gnome-software
gnome-software-common
gnome-software-plugin-snap
gnome-startup-applications
gnome-sudoku
gnome-system-tools
gnome-themes-extra:amd64
gnome-themes-extra-data
gnome-themes-standard
gnome-user-docs
language-pack-gnome-en
language-pack-gnome-en-base
language-selector-gnome
libgnome-bluetooth13:amd64
libgnome-desktop-3-17:amd64
libgnome-games-support-1-3:amd64
libgnome-games-support-common
libgnome-menu-3-0:amd64
libgnomekbd-common
libgnomekbd8:amd64
libpam-gnome-keyring:amd64
libreoffice-gnome
libsoup-gnome2.4-1:amd64
network-manager-gnome
network-manager-pptp-gnome
pinentry-gnome3
policykit-1-gnome
yaru-theme-gnome-shell

and unity:

$ diff before after | grep unity | awk '{print $3}'
libmeanwhile1:amd64
libunity-control-center1
libunity-protocol-private0:amd64
libunity-scopes-json-def-desktop
libunity-settings-daemon1:amd64
libunity9:amd64
unity-control-center
unity-greeter
unity-settings-daemon
xubuntu-community-wallpapers
xubuntu-community-wallpapers-bionic
yaru-theme-gnome-shell

So user still can't simply install Xubuntu on top of minimal system.