indicator-datetime-service crashed with SIGABRT in __malloc_assert()

Bug #1681870 reported by Dave Morley on 2017-04-11
50
This bug affects 7 people
Affects Status Importance Assigned to Milestone
content-hub (Ubuntu)
Undecided
Unassigned
indicator-datetime (Ubuntu)
High
Łukasz Zemczak
indicator-transfer (Ubuntu)
Undecided
Unassigned
keeper (Ubuntu)
Undecided
Unassigned
libertine-scope (Ubuntu)
Undecided
Unassigned
pay-service (Ubuntu)
Undecided
Unassigned
qtmir (Ubuntu)
Undecided
Unassigned
ubuntu-app-launch (Ubuntu)
Undecided
Unassigned
ubuntu-push (Ubuntu)
Undecided
Unassigned
ubuntu-system-settings-online-accounts (Ubuntu)
Undecided
Unassigned
unity-scope-click (Ubuntu)
Undecided
Unassigned
unity8 (Ubuntu)
Undecided
Unassigned
url-dispatcher (Ubuntu)
Undecided
Unassigned

Bug Description

Install I386 version of desktop or run live desktop and the indicator is crashed.

Added other packages that could have been affected as the crash is due to some ABI break in ubuntu-app-launch.

ProblemType: Crash
DistroRelease: Ubuntu 17.04
Package: indicator-datetime 15.10+17.04.20170322-0ubuntu1
ProcVersionSignature: Ubuntu 4.10.0-19.21-generic 4.10.8
Uname: Linux 4.10.0-19-generic i686
ApportVersion: 2.20.4-0ubuntu4
Architecture: i386
CurrentDesktop: Unity:Unity7
Date: Tue Apr 11 15:41:03 2017
ExecutablePath: /usr/lib/i386-linux-gnu/indicator-datetime/indicator-datetime-service
ExecutableTimestamp: 1490207290
InstallationDate: Installed on 2017-04-11 (0 days ago)
InstallationMedia: Ubuntu 17.04 "Zesty Zapus" - Release i386 (20170411)
ProcCmdline: /usr/lib/i386-linux-gnu/indicator-datetime/indicator-datetime-service
ProcCwd: /home/davmor2
ProcEnviron:
 LANG=en_GB.UTF-8
 LANGUAGE=en_GB:en
 PATH=(custom, no user)
 SHELL=/bin/bash
 XDG_RUNTIME_DIR=<set>
Signal: 6
SourcePackage: indicator-datetime
StacktraceTop:
 __malloc_assert (assertion=assertion@entry=0xb6d27f38 "(old_top == initial_top (av) && old_size == 0) || ((unsigned long) (old_size) >= MINSIZE && prev_inuse (old_top) && ((unsigned long) old_end & (pagesize - 1)) == 0)", file=file@entry=0xb6d24696 "malloc.c", line=line@entry=2403, function=<optimised out>) at malloc.c:301
 sysmalloc (nb=nb@entry=264, av=av@entry=0xb6d7a780 <main_arena>) at malloc.c:2400
 _int_malloc (av=av@entry=0xb6d7a780 <main_arena>, bytes=bytes@entry=260) at malloc.c:3862
 __GI___libc_malloc (bytes=260) at malloc.c:2925
 operator new(unsigned int) () from /usr/lib/i386-linux-gnu/libstdc++.so.6
Title: indicator-datetime-service crashed with SIGABRT in __malloc_assert()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Dave Morley (davmor2) wrote :
information type: Private → Public

Stacktrace:
 #0 0xb775dcf9 in ?? ()
 No symbol table info available.
 #1 0x00000000 in ?? ()
 No symbol table info available.
StacktraceSource:
 #0 0xb775dcf9 in ?? ()
 #1 0x00000000 in ?? ()
StacktraceTop:
 ?? ()
 ?? ()

tags: added: apport-failed-retrace
tags: removed: need-i386-retrace
Brian Murray (brian-murray) wrote :

StacktraceTop:
 __malloc_assert (assertion=assertion@entry=0xb6d27f38 "(old_top == initial_top (av) && old_size == 0) || ((unsigned long) (old_size) >= MINSIZE && prev_inuse (old_top) && ((unsigned long) old_end & (pagesize - 1)) == 0)", file=file@entry=0xb6d24696 "malloc.c", line=line@entry=2403, function=<optimized out>) at malloc.c:301
 sysmalloc (nb=nb@entry=264, av=av@entry=0xb6d7a780 <main_arena>) at malloc.c:2400
 _int_malloc (av=av@entry=0xb6d7a780 <main_arena>, bytes=bytes@entry=260) at malloc.c:3862
 __GI___libc_malloc (bytes=260) at malloc.c:2925
 operator new (sz=260) at ../../../../src/libstdc++-v3/libsupc++/new_op.cc:50

Changed in indicator-datetime (Ubuntu):
importance: Undecided → Medium
tags: added: iso-testing
Iain Lane (laney) wrote :

We think this is an undisclosed ABI break and we'll rebuild for it (in a silo) to see if that works.

Changed in indicator-datetime (Ubuntu):
status: New → Triaged
importance: Medium → High
assignee: nobody → Łukasz Zemczak (sil2100)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in content-hub (Ubuntu):
status: New → Confirmed
Changed in indicator-transfer (Ubuntu):
status: New → Confirmed
Changed in keeper (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-push - 0.68+17.04.20170211-0ubuntu2

---------------
ubuntu-push (0.68+17.04.20170211-0ubuntu2) zesty; urgency=medium

  * No-change rebuild (LP: #1681870).

 -- Łukasz 'sil2100' Zemczak <email address hidden> Tue, 11 Apr 2017 17:33:31 +0100

Changed in ubuntu-push (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package content-hub - 0.3+17.04.20170403-0ubuntu2

---------------
content-hub (0.3+17.04.20170403-0ubuntu2) zesty; urgency=medium

  * No-change rebuild (LP: #1681870).

 -- Łukasz 'sil2100' Zemczak <email address hidden> Tue, 11 Apr 2017 17:32:34 +0100

Changed in content-hub (Ubuntu):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-app-launch - 0.12+17.04.20170404.2-0ubuntu2

---------------
ubuntu-app-launch (0.12+17.04.20170404.2-0ubuntu2) zesty; urgency=medium

  * No-change rebuild (LP: #1681870).

 -- Łukasz 'sil2100' Zemczak <email address hidden> Tue, 11 Apr 2017 17:33:25 +0100

Changed in ubuntu-app-launch (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-datetime - 15.10+17.04.20170322-0ubuntu2

---------------
indicator-datetime (15.10+17.04.20170322-0ubuntu2) zesty; urgency=medium

  * No-change rebuild (LP: #1681870).

 -- Łukasz 'sil2100' Zemczak <email address hidden> Tue, 11 Apr 2017 17:32:50 +0100

Changed in indicator-datetime (Ubuntu):
status: Triaged → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity8 - 8.15+17.04.20170404.7-0ubuntu3

---------------
unity8 (8.15+17.04.20170404.7-0ubuntu3) zesty; urgency=medium

  * No-change rebuild (LP: #1681870).

 -- Łukasz 'sil2100' Zemczak <email address hidden> Tue, 11 Apr 2017 17:33:55 +0100

Changed in unity8 (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qtmir - 0.5.1+17.04.20170404-0ubuntu2

---------------
qtmir (0.5.1+17.04.20170404-0ubuntu2) zesty; urgency=medium

  * No-change rebuild (LP: #1681870).

 -- Łukasz 'sil2100' Zemczak <email address hidden> Tue, 11 Apr 2017 17:33:18 +0100

Changed in qtmir (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pay-service - 15.10+17.04.20170211-0ubuntu2

---------------
pay-service (15.10+17.04.20170211-0ubuntu2) zesty; urgency=medium

  * No-change rebuild (LP: #1681870).

 -- Łukasz 'sil2100' Zemczak <email address hidden> Tue, 11 Apr 2017 17:33:12 +0100

Changed in pay-service (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-transfer - 0.2+17.04.20170215-0ubuntu2

---------------
indicator-transfer (0.2+17.04.20170215-0ubuntu2) zesty; urgency=medium

  * No-change rebuild (LP: #1681870).

 -- Łukasz 'sil2100' Zemczak <email address hidden> Tue, 11 Apr 2017 17:32:56 +0100

Changed in indicator-transfer (Ubuntu):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-system-settings-online-accounts - 0.7+17.04.20170308.2-0ubuntu3

---------------
ubuntu-system-settings-online-accounts (0.7+17.04.20170308.2-0ubuntu3) zesty; urgency=medium

  * No-change rebuild (LP: #1681870).

 -- Łukasz 'sil2100' Zemczak <email address hidden> Tue, 11 Apr 2017 17:33:39 +0100

Changed in ubuntu-system-settings-online-accounts (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libertine-scope - 1.3.2+17.04.20170228-0ubuntu2

---------------
libertine-scope (1.3.2+17.04.20170228-0ubuntu2) zesty; urgency=medium

  * No-change rebuild (LP: #1681870).

 -- Łukasz 'sil2100' Zemczak <email address hidden> Tue, 11 Apr 2017 17:33:06 +0100

Changed in libertine-scope (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package url-dispatcher - 0.1+17.04.20170328-0ubuntu2

---------------
url-dispatcher (0.1+17.04.20170328-0ubuntu2) zesty; urgency=medium

  * No-change rebuild (LP: #1681870).

 -- Łukasz 'sil2100' Zemczak <email address hidden> Tue, 11 Apr 2017 17:34:10 +0100

Changed in url-dispatcher (Ubuntu):
status: New → Fix Released
Changed in unity-scope-click (Ubuntu):
status: New → Won't Fix
description: updated
Download full text (3.7 KiB)

Antonio,
Thank you for your report saying the bug was fixed...
I must report I've had a few problems that I have reported.Like "system setting" wont open from the "gear" in the corner,and I lost the Ubuntu Software center from the launch pad andothers... However in searching for possible answers I found these 2 commands in one answer:
Sudo apt-get update && apt-get dist-upgrade, andSudo do-release upgrade -d
Running these 2 solved all my known problems. What they didI'm still not sure - maybe a total re-install I'm not sure. I'm trying to learn...
Again thanks.

    On Monday, June 5, 2017 4:41 PM, Launchpad Bug Tracker <email address hidden> wrote:

 ** Branch linked: lp:~ci-train-bot/indicator-datetime/indicator-
datetime-ubuntu-artful-2797

--
You received this bug notification because you are subscribed to a
duplicate bug report (1681127).
https://bugs.launchpad.net/bugs/1681870

Title:
  indicator-datetime-service crashed with SIGABRT in __malloc_assert()

Status in content-hub package in Ubuntu:
  Fix Released
Status in indicator-datetime package in Ubuntu:
  Fix Released
Status in indicator-transfer package in Ubuntu:
  Fix Released
Status in keeper package in Ubuntu:
  Confirmed
Status in libertine-scope package in Ubuntu:
  Fix Released
Status in pay-service package in Ubuntu:
  Fix Released
Status in qtmir package in Ubuntu:
  Fix Released
Status in ubuntu-app-launch package in Ubuntu:
  Fix Released
Status in ubuntu-push package in Ubuntu:
  Fix Released
Status in ubuntu-system-settings-online-accounts package in Ubuntu:
  Fix Released
Status in unity-scope-click package in Ubuntu:
  Won't Fix
Status in unity8 package in Ubuntu:
  Fix Released
Status in url-dispatcher package in Ubuntu:
  Fix Released

Bug description:
  Install I386 version of desktop or run live desktop and the indicator
  is crashed.

  Added other packages that could have been affected as the crash is due
  to some ABI break in ubuntu-app-launch.

  ProblemType: Crash
  DistroRelease: Ubuntu 17.04
  Package: indicator-datetime 15.10+17.04.20170322-0ubuntu1
  ProcVersionSignature: Ubuntu 4.10.0-19.21-generic 4.10.8
  Uname: Linux 4.10.0-19-generic i686
  ApportVersion: 2.20.4-0ubuntu4
  Architecture: i386
  CurrentDesktop: Unity:Unity7
  Date: Tue Apr 11 15:41:03 2017
  ExecutablePath: /usr/lib/i386-linux-gnu/indicator-datetime/indicator-datetime-service
  ExecutableTimestamp: 1490207290
  InstallationDate: Installed on 2017-04-11 (0 days ago)
  InstallationMedia: Ubuntu 17.04 "Zesty Zapus" - Release i386 (20170411)
  ProcCmdline: /usr/lib/i386-linux-gnu/indicator-datetime/indicator-datetime-service
  ProcCwd: /home/davmor2
  ProcEnviron:
   LANG=en_GB.UTF-8
   LANGUAGE=en_GB:en
   PATH=(custom, no user)
   SHELL=/bin/bash
   XDG_RUNTIME_DIR=<set>
  Signal: 6
  SourcePackage: indicator-datetime
  StacktraceTop:
   __malloc_assert (assertion=assertion@entry=0xb6d27f38 "(old_top == initial_top (av) && old_size == 0) || ((unsigned long) (old_size) >= MINSIZE && prev_inuse (old_top) && ((unsigned long) old_end & (pagesize - 1)) == 0)", file=file@entry=0xb6d24696 "malloc.c", line=line@entry=2403, function=<optimised out>) at malloc.c:301
   sysmalloc (nb...

Read more...

Daniel van Vugt (vanvugt) wrote :

Ralph, as this bug is closed you should open a new one if you have any continuing issues.

dino99 (9d9) wrote :

17.04 is now dead; so the version used into active release(s) are also newer.

Changed in keeper (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers