memory leak in indicator-datetime

Bug #1633319 reported by Jonathan Brier on 2016-10-14
80
This bug affects 17 people
Affects Status Importance Assigned to Milestone
indicator-datetime (Ubuntu)
Undecided
Unassigned

Bug Description

After upgrading from 16.04 to 16.10 on the System76 Serval WS indicator-datetime-service is consuming all the system memory from 3.7GB up to 32 GB in 30 seconds. The system kills the indicator-datetime-service process and indicator-datetime-service restarts and memory consumption repeats until killed again. All swap memory is consumed in this pattern.

ProblemType: Bug
DistroRelease: Ubuntu 16.10
Package: indicator-datetime 15.10+16.10.20160820.1-0ubuntu1
ProcVersionSignature: Ubuntu 4.8.0-22.24-generic 4.8.0
Uname: Linux 4.8.0-22-generic x86_64
NonfreeKernelModules: nvidia_uvm nvidia_drm nvidia_modeset nvidia
ApportVersion: 2.20.3-0ubuntu8
Architecture: amd64
CurrentDesktop: Unity
Date: Fri Oct 14 00:12:00 2016
EcryptfsInUse: Yes
SourcePackage: indicator-datetime
UpgradeStatus: Upgraded to yakkety on 2016-10-14 (0 days ago)

Jonathan Brier (brierjon) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-datetime (Ubuntu):
status: New → Confirmed
David (dklongley) wrote :

I get the same as described by the original poster. I have disabled the service for now.

April J (april-system76) wrote :

@dklongley -- Can you let me know if you're also running on System76 hardware? I am attempting to reproduce this now. Thank you!

Jonathan Brier (brierjon) wrote :

Ran valgrind on the indicator-datetime-service with the following command trying to track down the origin of the issue.

The following command and parameters were used:
G_SLICE=always-malloc G_DEBUG=gc-friendly valgrind -v --tool=memcheck --leak-check=full --num-callers=40 --log-file=valgrind.log /usr/lib/x86_64-linux-gnu/indicator-datetime/indicator-datetime-service

David (dklongley) wrote :

@April_J No my hardware is Samsung

I see this bug on a Thinkpad T61 and a Thinkpad X230t.

Upon killing gnome-session and logging in again, the problem is gone, but it reappears after reboot.

Jonathan Brier (brierjon) wrote :

I've been able to narrow down on my system that enabling "Evolution Data Server" for Access to the Google Calendar is the trigger for this memory issue. See the three screenshots. I even removed and reauthorized the Google account access with no change.

First screenshot shows the Evolution Data Service disabled and memory function is normal.
Second is toggling the Evolution Data Service from off to on. After ~10-5 seconds memory consumption appears at a rapid rate.
Third is after switching Evolution Data Service from on to off and killing the indicator-datetime-service process showing the memory issue no longer exists.

If Evolution Data Server is not switched to off killing the indicator-datetime-service process only restarts memory levels at the initial value and consumption growth appears nearly immediately following its automatic resume.

Krister (thekswenson) wrote :

This is urgent, as it renders and upgraded system completely useless.

Krister (thekswenson) wrote :

@brierjon: I don't see the same thing that you do in 16.10 (see attachment).
I am missing a Google account setting.

Krister (thekswenson) wrote :

This occurs on both my desktop and laptop.

Charles Kerr (charlesk) wrote :

From Jonathan's insights in comment 9, this sounds like a duplicate of bug #1342123.

Krister (thekswenson) wrote :

I found the correct Setting manager (the other one was for Unity8?) and have tried to reproduce the behavior described by Jonathan. Disabling the "Evolution Data Server" entry for my calendar does not fix the problem. All 8G of memory and 8G of swap gets devoured in under 10 seconds.

I think that marking this a duplicate of bug #1342123 is a mistake for two reasons:

1. bug #1342123 is a bug for mobile system (the corresponding bug for the desktop is bug #1589605)

2. they are talking about rather modest amounts of memory usage like 100MB, not 16G.

Krister (thekswenson) wrote :

In "Online Accounts" settings, I removed my Google account completely. This has not fixed the problem with indicator-datetime-service using all of my memory and swap.

Please remove the duplicate marking.

Arivukkadal (kadal27) wrote :

I am also facing the same problem. indicator-datetime-service uses all my memory and swap 32+32gb and system hangs. I am using AMD FX8350 Black on MSI 970 Gaming with 32 Gb of RAM.

David (dklongley) wrote :

This problem is still affecting me. I have disabled the service by commenting out lines in the conf file. I do not think it is a duplicate of the clendar problem.

Luke (mulletinc) wrote :

I fixed it by clearing out anything that was added to ~/.local/share/evolution/ when I added my Gmail account to Online Accounts. Through the various debugging methods I was using, it looked like it was an issue with the calendar events.

Krister (thekswenson) wrote :

@mulletinc: Thank you!
Comment #18 solved the problem for me.

This started affecting me as well this week. Killed all Evolution processes and indicator-datet then restarted Evo. Seems OK for now but don't fancy my chances after next restart.

Crimbo (ckhatton) wrote :

This seems to have been resolved now, since running a system update on Yakkety via 'Ubuntu Software'. Can anyone else confirm the same?

Crimbo (ckhatton) wrote :

Scrap that... I realised it was because I had the 'indicator-datetime-service' package set to 'stop' in the system monitor (which is a great temporary fix if anyone is having this same issue).

I do confirm Jonathan's findings from comment #9. Disabling eveolution-data-server's access to google calendar stops the excessive memory usage.

S-cimer (s-cimer) wrote :

Same problem here. Asus Rog 552. Disabling online accounts stops memory leak.
It is a big problem for me, I would need this functionality...

Dennis Shimer (dshimer) wrote :

I completely removed my google account and it still didn't help. Is there any way to set this service to not start at all?

At this point the only thing I have found to even make my laptop usable is 'killall unity-panel-service'

Killed my computer as soon as I activated my google online account.

Timothy J. Campbell (hysbyswr) wrote :

I tried what was suggested in post #18, but it didn't solve my problem.

The work around I came up with was to create a new user account (dropping to command-line BEFORE logging in to the old account), and giving that account full access to the old account. I did NOT add my Google account info to the new account (instead, I will use Thunderbird for email).

Robert Ruddy (bobruddy) wrote :

This also impacts 17.04 as installed on March 27th.

The leak comes as soon as I turn on evolution-data-server. If I turn that off, logout and back in then I don't have a problem.

I concur this was also an issue in 16.10.

Robert Ruddy (bobruddy) wrote :

Sorry I need to confirm that it impacts if i turn on evolution data server for google calendar.

Andrew (andrewlee.name) wrote :

I have the same issue on an Ubuntu 16.10 VM in VirtualBox running on Windows 7. Evolution was running fine until I added a fifth account.

PeterW (peter-waltman) wrote :

I have the same issue on a fresh install of 16.10, but this only occurred AFTER I installed gnome-shell 3.22, but logged in using Unity. When I logged in using GNOME, the problem did not occur - although I suspect that this is only because the evolution-data-server wasn't started when I logged in with the GNOME desktop.

Vadim Peretokin (vperetokin) wrote :

I had to disable Evolution accessing the calendar in Online Accounts, because the whole OS was completely unusable - as soon as I logged in, indicator-datetime-service would eat up all of the memory and lock the system up. That's it.

mirak (mirak-mirak) wrote :

I have this problem on 17.04, it appeared just like that.

Minas (minas-mina1990) wrote :

Had the same problem and managed to fix it. I did these two things, although I'm not sure which one solved it :)

1. Opened evolution and removed my gmail account from it.
2. Removed by Google account from Online Accounts.

To do this I had to install gnome-shell and do it from there. After the above steps Ubuntu no longer freezes.

Wendell Soares (wensiso) wrote :

I have this problem on 17.10.

Is there any way to resolve this problem without removing my Google account?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers