Date/time indicator doesn't update after changing time zone

Bug #1485659 reported by Seth Forshee on 2015-08-17
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
indicator-datetime (Ubuntu)
Low
Iain Lane

Bug Description

After changing the timezone the time displayed in the date/time indicator is still in my old time zone. I sent a signal to the indicator-datetime-service process, and after it restarted the correct time was displayed.

ProblemType: Bug
DistroRelease: Ubuntu 15.10
Package: indicator-datetime 13.10.0+15.10.20150728-0ubuntu2~gcc5.1
ProcVersionSignature: Ubuntu 4.1.0-3.3-generic 4.1.3
Uname: Linux 4.1.0-3-generic x86_64
ApportVersion: 2.18-0ubuntu6
Architecture: amd64
CurrentDesktop: Unity
Date: Mon Aug 17 08:51:44 2015
EcryptfsInUse: Yes
InstallationDate: Installed on 2015-02-19 (178 days ago)
InstallationMedia: Ubuntu 15.04 "Vivid Vervet" - Alpha amd64 (20150110)
SourcePackage: indicator-datetime
UpgradeStatus: Upgraded to wily on 2015-07-01 (46 days ago)

Related branches

Seth Forshee (sforshee) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-datetime (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Thank you for your bug report, how did you change the tz? Did you wait a minute to see if the indicator was refreshing on the next change?

Changed in indicator-datetime (Ubuntu):
importance: Undecided → Low
status: Confirmed → Incomplete
Sebastien Bacher (seb128) wrote :

Confirming using the indicator menu to change the tz or the settings map widget, the hour is correctly updated in the panel/on the system but the indicator doesn't catch up with the change even after minute changes

Changed in indicator-datetime (Ubuntu):
status: Incomplete → Confirmed
Charles Kerr (charlesk) wrote :

I'm seeing this as well on mako 15.10.

However, it works for me in krillin 15.04, and I believe the two have similar versions of the indicator-datetime codebase. This needs more investigation to figure out what the issue is.

Iain Lane (laney) wrote :

I think it's a glib GFileMonitor problem - it works again if I build 2.44 and run with that. The code here is watching /etc/timezone to know when it changes.

Iain Lane (laney) wrote :

We should instead watch timedated's Timezone property

Changed in indicator-datetime (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Iain Lane (laney)
desrt (desrt) wrote :

A couple of notes:

 - this is fixed upstream in GLib already

 - watching dbus for the signal is fine, but you should not use dbus to read the property in the first place. This will result in activation of the datetime service, which is expensive.

Charles Kerr (charlesk) wrote :

+1 on watching timedated and dropping /etc/timezone

Iain Lane (laney) wrote :

I think this is fixed

Changed in indicator-datetime (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers