Indicator-datetime doesn't list in-progress events

Bug #1302004 reported by Khurshid Alam on 2014-04-03
66
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Medium
Bill Filler
indicator-datetime (Ubuntu)
Medium
Charles Kerr

Bug Description

This bug is related to this bug: Bug #1293646 (Which is marked as fix released)

With latest update of indicator (13.10.0+14.04.20140328-0ubuntu1) it lists all events for all past selected dates properly (which was fixed in bug Bug #1293646) except today's date. When I click on any past date in calendar it shows:

1. all all-day events for the day.
2. all events with time for the day
3. upcoming (future) all-day events
4. upcoming (future) events with time

But when I click on today's date it only shows:

1. future all day events
2. future events with time

I still have to click on previous day's date to find out all all-day events for today.

The behavior (showing all events for a day) should be same for any date, including today's date.

<https://wiki.ubuntu.com/TimeAndDate#menu-events>: "If there are more than five, the events shown should be, in order of priority, * any events that start or end (a) for today, after the current minute, or (b) for any other date, at any time on that date, * any full-day events that span all of the selected date..."

Related branches

description: updated
description: updated
Khurshid Alam (khurshid-alam) wrote :

This bug is still present in Trusty...using indicator-datetime 13.10.0+14.04.20140415.3-0ubuntu1

tags: added: utopic
Khurshid Alam (khurshid-alam) wrote :

I can also reproduce this bug in Unity-7.x on Utopic (indicator-datetime 13.10.0+14.10.20140701-0ubuntu1).

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-datetime (Ubuntu):
status: New → Confirmed
Khurshid Alam (khurshid-alam) wrote :

I can reproduce this on Utopic & Vivid.

tags: added: vivid
summary: Indicator-datetime still doesn't list all events for today's date
- (Trusty)
+ (Trusty/Utopic/Vivid)
Changed in indicator-datetime (Ubuntu):
importance: Undecided → Medium

I'm also affected by this issue in Trusty.
I think that, for today, the indicator should list the events that END after the current time, instead of the ones that START after it.

Bruno Nova (brunonova) wrote :

Here's a simple patch for Trusty. It may also work in newer releases.
I've made a very short test but it seemed to work. Still, more testing is advisable!

The patch makes the list of upcoming events display, for today, the events that END before the current time, instead of the ones that START before it.
That means all-day events and ongoing events will now be displayed.

I think this is the best behavior. This is also the behavior of the Android calendar/agenda widget according to my tests, for example.
Today's all-day events should definitely be displayed! Displaying ongoing events is more debatable, but I still think they should be displayed.
If these events were not being displayed because the list only displays 5 events at most, just increase the limit! Actually, that limit should be increased anyway (unless there's a bigger problem).

Related and possibly duplicate bug: #1329048

The attachment "upcoming-after-end.patch" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Bruno Nova (brunonova) wrote :

Small correction to the patch (for Trusty, maybe it also works in newer releases).
The condition should be "begin < a.end" instead of "begin <= a.end", or else all-day events would also be displayed when the next day is selected.

I also tested events that span multiple days, and it works correctly. The ongoing events for today are correctly displayed.
The calendar, however, only highlights (in bold) the first day of multiple-days events, which is another small bug.

Charles Kerr (charlesk) wrote :

There are a couple of things going on in this ticket.

The original suggestion -- that the indicator show all the events happening that day -- is at odds with the indicator's design of showing "the next five calendar events, if any" <https://wiki.ubuntu.com/TimeAndDate#Coming_events>. The calendar app, is the proper place for the all-encompassing view this ticket describes.

However I like Bruno's suggestion on how to choose those "next five calendar events" by ending time rather than starting time. That way, in-progress meetings wouldn't disappear off the indicator as soon as they start, so people running late could use the indicator for a quick heads-up.

The design spec doesn't say how the five should be selected (probably because it seemed obvious at the time :), so forwarding to mpt for consideration.

Changed in indicator-datetime (Ubuntu):
assignee: nobody → Matthew Paul Thomas (mpt)
Matthew Paul Thomas (mpt) wrote :
Changed in indicator-datetime (Ubuntu):
assignee: Matthew Paul Thomas (mpt) → nobody
status: Confirmed → Triaged
Charles Kerr (charlesk) on 2015-05-11
Changed in indicator-datetime (Ubuntu):
assignee: nobody → Charles Kerr (charlesk)
description: updated
Charles Kerr (charlesk) on 2015-05-11
summary: - Indicator-datetime still doesn't list all events for today's date
- (Trusty/Utopic/Vivid)
+ Indicator-datetime doesn't list in-progress events
Bruno Nova (brunonova) wrote :

Hi, I checked the updated specification (didn't read everything, but I think it's good). It will require more changes in the code than just the patch I provided. :)

But, in the meantime, could the change in the patch be applied and backported to Trusty and Vivid?
I applied the patch to my system, and it's working fine, but I would prefer to not have to do it.

Khurshid Alam (khurshid-alam) wrote :

".......That way, in-progress meetings wouldn't disappear off the indicator as soon as they start, so people running late could use the indicator for a quick heads-up."

Yes, it should be like this. I have tested the patch on Trusty. It is working well for in-progress events.

I am ok with (updated) wiki specification. Thanks

Bruno Nova (brunonova) wrote :

In the meantime while this is not officially fixed, I have uploaded a fixed version of the package to a PPA.
The PPA is here: https://launchpad.net/~brunonova/+archive/ubuntu/indicator-datetime

The difference between the official version is just the patch that attached to this bug, plus the necessary changes to the debian/ files.
I uploaded packages for Trusty and Vivid, but only tested Trusty.

Also, Ubuntu developers: the package is still using the 1.0 source format? Why not 3.0 (quilt)?

Sebastien Bacher (seb128) wrote :

@Charles, is the patch there still something that needs review?

tags: added: rls-x-incoming
Selene ToyKeeper (toykeeper) wrote :

This behavior isn't always a bad thing. It might be good to make it a configurable option, since people sometimes want to see in-progress events and sometimes don't. The widget I use on other devices has an option to remove events on end rather than on start, show or hide all-day events, highlight in-progress events, use different colors for items from different calendars, and quite a few other things.

Charles Kerr (charlesk) on 2016-03-18
Changed in indicator-datetime (Ubuntu):
status: Triaged → In Progress
Bill Filler (bfiller) on 2016-04-15
Changed in canonical-devices-system-image:
assignee: nobody → Bill Filler (bfiller)
milestone: none → 11
importance: Undecided → Medium
status: New → In Progress
Bill Filler (bfiller) on 2016-04-22
tags: added: system-apps-11
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Changed in indicator-datetime (Ubuntu):
status: In Progress → Fix Released
Bruno Nova (brunonova) wrote :

This wasn't fixed in 16.04 and 14.04 yet, right?

By the way, for those interested, I already uploaded a "fixed" version for 16.04 to my PPA I mentioned before.

Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
Sam Bull (dreamsorcerer) wrote :

Shows an in-progress event, but doesn't make it clear that an event is in-progress. Registered a new bug for this: #1588376

Khurshid Alam (khurshid-alam) wrote :

This still doesn't work in zesty. If I have more than one all-day events and couple of holiday events spans throughout the calendar, it only shows a single full-day event. It doesn't show rest of the events.

Khurshid Alam (khurshid-alam) wrote :

@Bruno Nova Your patch is broken for zesty. Can you update your patch?

Khurshid Alam (khurshid-alam) wrote :

On Unity-7 this bug is easily reproducible.

1. I have more than 2 all-day events.

2. There are more 10 events starting next week (clearly after today).

Click on indicator-datetime.......

1. There is on a single event listed there. There should be 2 full-day events.

2. Instead showing all of my full-day events, it is showing those events starting next week.

What should happen:

1. It must display today's full-day event at top before showing any other events starting next week.

Sam Bull (dreamsorcerer) wrote :

It might be an idea to create separate bug reports for each condition that still fails to show all events.

Another one, if I remember correctly, is multi-day events, I believe it only shows the event on it's start date and it's end date. e.g. event starts Mon and ends Friday, it will not appear in indicator Tue-Thu.

Khurshid Alam (khurshid-alam) wrote :

I have already filed a new bug.....but nobody looked into it... #1698638

Khurshid Alam (khurshid-alam) wrote :

Filed a new bug here....although I wonder if anybody will look into it..LP: #1698638

Khurshid Alam (khurshid-alam) wrote :

The bug occurs for any event when DTSTART == DTEND

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers