indicator-datetime-service crashed: "Unable to get bus connection to own name 'com.canonical.indicator.datetime'"

Bug #1238737 reported by Markus Heberling on 2013-10-11
88
This bug affects 26 people
Affects Status Importance Assigned to Milestone
indicator-datetime (Ubuntu)
Medium
Charles Kerr

Bug Description

The time display in the menu bar crashed.

ProblemType: Crash
DistroRelease: Ubuntu 13.10
Package: indicator-datetime 13.10.0+13.10.20131011-0ubuntu1
ProcVersionSignature: Ubuntu 3.11.0-12.19-generic 3.11.3
Uname: Linux 3.11.0-12-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.12.5-0ubuntu1
Architecture: amd64
Date: Fri Oct 11 17:11:22 2013
ExecutablePath: /usr/lib/x86_64-linux-gnu/indicator-datetime-service
InstallationDate: Installed on 2012-01-20 (630 days ago)
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
MarkForUpload: True
ProcCmdline: /usr/lib/x86_64-linux-gnu/indicator-datetime-service
ProcEnviron:
 SHELL=/bin/false
 XDG_RUNTIME_DIR=<set>
 PATH=(custom, no user)
 LANG=de_DE.UTF-8
Signal: 5
SourcePackage: indicator-datetime
StacktraceTop:
 ?? ()
 ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
 g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 g_main_loop_run () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
Title: indicator-datetime-service crashed with signal 5 in g_main_context_dispatch()
UpgradeStatus: Upgraded to saucy on 2013-10-11 (0 days ago)
UserGroups:

Related branches

information type: Private → Public

StacktraceTop:
 on_name_lost (connection=0x0, name=0xbf0c00 "com.canonical.indicator.datetime", gself=0xbe2140) at service.c:1730
 call_in_idle_cb (_data=<optimized out>) at /build/buildd/glib2.0-2.38.0/./gio/gdbusnameowning.c:180
 g_main_dispatch (context=0xbe6420) at /build/buildd/glib2.0-2.38.0/./glib/gmain.c:3065
 g_main_context_dispatch (context=context@entry=0xbe6420) at /build/buildd/glib2.0-2.38.0/./glib/gmain.c:3641
 g_main_context_iterate (context=0xbe6420, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at /build/buildd/glib2.0-2.38.0/./glib/gmain.c:3712

Changed in indicator-datetime (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-datetime (Ubuntu):
status: New → Confirmed
Charles Kerr (charlesk) on 2013-10-15
summary: - indicator-datetime-service crashed with signal 5 in
- g_main_context_dispatch()
+ indicator-datetime-service crashed: "Unable to get bus connection to own
+ name 'com.canonical.indicator.datetime'"
Charles Kerr (charlesk) on 2013-10-16
Changed in indicator-datetime (Ubuntu):
assignee: nobody → Charles Kerr (charlesk)
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-datetime - 13.10.0+13.10.20131016.2-0ubuntu1

---------------
indicator-datetime (13.10.0+13.10.20131016.2-0ubuntu1) saucy; urgency=low

  [ Charles Kerr ]
  * Remove the g_error() call that caused an abort() in the call to
    on_name_lost() in our bus handler. (LP: #1238737)

  [ Didier Roche ]
  * remove invalid click recommends and downgrade to Suggests

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 274

indicator-datetime (13.10.0+13.10.20131016-0ubuntu1) saucy; urgency=low

  [ Charles Kerr ]
  * Use the Unity Mobile icon name for the alarm clock icon.
  * cache our internal GTimeZone instead of constantly re-creating it.
    (LP: #1238043)
  * Changes the phone profile's "Clock" menuitem in two ways: 1. instead
    of using a stock icon, try to use the clock app's icon. 2. when
    clicked, launch the clock app. (LP: #1227106)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 271
 -- Ubuntu daily release <email address hidden> Wed, 16 Oct 2013 15:30:10 +0000

Changed in indicator-datetime (Ubuntu):
status: In Progress → Fix Released
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1238737

tags: added: iso-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers