[FFe] Freeze exception for converged indicators

Bug #1215980 reported by Thomas Strehl on 2013-08-23
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
indicator-bluetooth (Ubuntu)
Undecided
Unassigned
indicator-datetime (Ubuntu)
Undecided
Unassigned
indicator-power (Ubuntu)
Undecided
Unassigned

Bug Description

All indicators on phone, except the networking, are fully converged meaning they share the same backend with desktop indicators. While we'll be feature complete on the indicator side until FF, we still need an exception as the settings application on the phone utilize the very same backends. We don't plan to change the code path required for the desktop indicators, but only add some more functionality required for phone settings. In particular, we're asking for FFe for the following packages:

- indicator-bluetooth
- indicator-network
- indicator-location
- indicator-datetime
- indicator-power

Thomas Strehl (strehl-t) on 2013-08-29
description: updated
Steve Langasek (vorlon) on 2013-08-31
affects: ubuntu → indicator-datetime (Ubuntu)
Steve Langasek (vorlon) wrote :

targeted this against the actual affected packages, for clarity.

Thomas, it appears that indicator-network is currently *NOT* included in the Ubuntu Desktop seed. Is it expected to be? Currently the package is in universe, and saucy desktop users do not have it pulled in automatically. In fact, on my system I've noticed that nm-applet is no longer being autostarted, leaving me with no network indicator of any kind on the desktop. Is this supposed to be a dependency of the 'unity' package, like the other indicators are? (For now, I'll leave the indicator-network package off of this FFe; once it's confirmed that the package will be included in the desktop, we can add the bug task.)

Trying to install indicator-network here on my desktop also pulls in some rather odd dependencies via liburl-dispatcher1:

 The following extra packages will be installed:
   click click-apparmor liburl-dispatcher1 python3-apparmor-click python3-click
   upstart-app-launch url-dispatcher

We probably don't want to pull these into the desktop for 13.10, so there may be some more work to be done here regarding the dependencies before this can be seeded.

As for the FFe itself: this sounds fine, in principle. Can you describe what steps you're taking to ensure that the changes made to these indicators don't affect the desktop code path for 13.10?

On Sat, 2013-08-31 at 19:32 +0000, Steve Langasek wrote:

> Thomas, it appears that indicator-network is currently *NOT* included in
> the Ubuntu Desktop seed. Is it expected to be?

No, that is correct. It is not in the desktop seed and we don't expect
it to be for 13.10.

> As for the FFe itself: this sounds fine, in principle. Can you describe
> what steps you're taking to ensure that the changes made to these
> indicators don't affect the desktop code path for 13.10?

Each indicator is built up of a set of actions, and then views on those
actions that are exported via GMenu over DBus. We export a different
view for each form factor, and also a view for the settings. We expect
to continue to modify the view for the settings and perhaps add actions,
but we don't expect to make feature changes the actions that are used in
the desktop views or the desktop views themselves.

Thomas Strehl (strehl-t) wrote :

Need a FFe also for indicator-sound as we need to adapt some MPRIS handling code to work properly on phone (won't touch any desktop code).

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-power - 12.10.6+13.10.20130918.2-0ubuntu1

---------------
indicator-power (12.10.6+13.10.20130918.2-0ubuntu1) saucy; urgency=low

  [ Timo Jyrinki ]
  * The dependency url-dispatcher was fixed to not pull in extra packages
    on the desktop images, fixing the issue that caused the previous revert
    (FFe bug - LP: #1215980)

  [ Ted Gould ]
  * Use URL dispatcher to show settings on the phone.

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 201
 -- Ubuntu daily release <email address hidden> Wed, 18 Sep 2013 13:57:00 +0000

Changed in indicator-power (Ubuntu):
status: New → Fix Released
Iain Lane (laney) wrote :

Looks (from comment #4) like this is in progress already, but anyway ACK. FFe granted for the packages this bug is targetted to, limited to the phone profiles / code paths only.

Changed in indicator-datetime (Ubuntu):
status: New → Confirmed
Changed in indicator-bluetooth (Ubuntu):
status: New → Confirmed
Stéphane Graber (stgraber) wrote :

Closing this FFe since we're now doing final image generation and that any change affecting binary packages on any of our released images is now forbidden (unless it's a critical bugfix).

Changed in indicator-bluetooth (Ubuntu):
status: Confirmed → Fix Released
Changed in indicator-datetime (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers