Bogus insensitive events after clicking on different date

Bug #1069177 reported by Tom Jaeger on 2012-10-20
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Indicator Date and Time
Fix Released
Low
Charles Kerr
indicator-datetime (Ubuntu)
Low
Unassigned
Quantal
Low
Unassigned

Bug Description

Impact:
Some events are incorrectly displayed in the indicator

Test Case:

The events indicator-datetime shows below the calendar depends on the selected date. When a new date is selected that has fewer associated events than the current date, some of the old events remain in the list, but are shown as insensitive rather than deleted. If for example the current date has events 'A B C D E', and the user clicks on a date with associated events 'X Y Z', then indicator-datetime will show the events 'X Y Z D E' with the last two events grayed out. Tested on quantal.

With the update the events should be correctly displayed

Regression potential:
Check that the correct events are listed and that they are not grayet out when they shouldn't

Related branches

Tom Jaeger (thjaeger) wrote :

The attachment "fix" of this bug report has been identified as being a patch in the form of a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-sponsors team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Tom Jaeger (thjaeger) wrote :

The call to hide_all_appointments in day_selected_cb should probably be removed as well to prevent ugly flickering, but I don't know if that has any unintended side effects.

Charles Kerr (charlesk) on 2012-10-25
Changed in indicator-datetime:
status: New → In Progress
assignee: nobody → Charles Kerr (charlesk)
milestone: none → 13.04.0
Changed in indicator-datetime (Ubuntu):
status: New → Confirmed
Charles Kerr (charlesk) wrote :

Good catch, thanks!

I think this should probably go in hide_all_appointments() rather than update_appointment_menu_items().

You're completely right about removing hide_all_appointments() from day_selected_cb() though -- the flickering is coming from the idle interval between day_selected_cb() and update_appointment_menu_items_idle().

Changed in indicator-datetime:
status: In Progress → Fix Committed
Changed in indicator-datetime:
importance: Undecided → Low
Changed in indicator-datetime (Ubuntu):
importance: Undecided → Low
Changed in indicator-datetime (Ubuntu Quantal):
importance: Undecided → Low
Changed in indicator-datetime (Ubuntu):
status: Confirmed → In Progress
Changed in indicator-datetime (Ubuntu Quantal):
status: New → In Progress
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-datetime - 12.10.2-0ubuntu4

---------------
indicator-datetime (12.10.2-0ubuntu4) raring; urgency=low

  * Backported r192 and r193, fix:
    - "shows all-day events one day too early" (lp: #1000182)
    - "Bogus insensitive events after clicking on different date"
       (lp: #1069177)
 -- Sebastien Bacher <email address hidden> Mon, 05 Nov 2012 17:23:13 +0100

Changed in indicator-datetime (Ubuntu):
status: In Progress → Fix Released

Hello Tom, or anyone else affected,

Accepted indicator-datetime into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/indicator-datetime/12.10.2-0ubuntu3.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in indicator-datetime (Ubuntu Quantal):
status: In Progress → Fix Committed
tags: added: verification-needed
Sebastien Bacher (seb128) wrote :

I didn't have an issue with the events index since the update

tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-datetime - 12.10.2-0ubuntu3.1

---------------
indicator-datetime (12.10.2-0ubuntu3.1) quantal-proposed; urgency=low

  * Backported r192 and r193, fix:
    - "shows all-day events one day too early" (lp: #1000182)
    - "Bogus insensitive events after clicking on different date"
       (lp: #1069177)
 -- Sebastien Bacher <email address hidden> Mon, 05 Nov 2012 17:23:13 +0100

Changed in indicator-datetime (Ubuntu Quantal):
status: Fix Committed → Fix Released
Charles Kerr (charlesk) on 2014-03-13
Changed in indicator-datetime:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Patches