NULL pointer access

Bug #1183293 reported by dino99 on 2013-05-23
50
This bug affects 11 people
Affects Status Importance Assigned to Milestone
indicator-cpufreq (Ubuntu)
High
Unassigned

Bug Description

Get that traceback with each gnome-shell session:

Traceback (most recent call last):
  File "/usr/bin/indicator-cpufreq", line 79, in <module>
    ind = MyIndicator(options.show_frequency)
  File "/usr/lib/python3/dist-packages/indicator_cpufreq/indicator.py", line 99, in __init__
    self.update_ui()
  File "/usr/lib/python3/dist-packages/indicator_cpufreq/indicator.py", line 110, in update_ui
    fmin, fmax, governor = cpufreq.get_policy(self.cpus[0])
  File "/usr/lib/python3/dist-packages/indicator_cpufreq/cpufreq.py", line 143, in get_policy
    policy = (p.contents.min, p.contents.max, p.contents.governor.decode())
ValueError: NULL pointer access

cpu: q9550

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: indicator-cpufreq 0.2.2-0ubuntu1
ProcVersionSignature: Ubuntu 3.9.0-2.7-generic 3.9.3
Uname: Linux 3.9.0-2-generic i686
NonfreeKernelModules: nvidia
ApportVersion: 2.10.2-0ubuntu1
Architecture: i386
Date: Thu May 23 12:30:34 2013
MarkForUpload: True
PackageArchitecture: all
SourcePackage: indicator-cpufreq
UpgradeStatus: No upgrade log present (probably fresh install)

dino99 (9d9) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-cpufreq (Ubuntu):
status: New → Confirmed
jose (o1485726) wrote :

affects me too, ubuntu 13.04, cpu: AMD A6-3400M

jose (o1485726) wrote :

I just left a comment here about this same bug: https://bugs.launchpad.net/indicator-cpufreq/+bug/797996 . Ill quote myself anyway...
So, I had this bug too. This happens when you disable "Cool n Quiet" from the BIOS in AMD systems (or if you enable HW thermal control, I'm not sure. I just have one AMD system, so I can't say much about other people...). When you do that, the file /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor will disappear, and the program will (obviously) not be able to find it, so it crashes...
I hope it helps.

Changed in indicator-cpufreq (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → High
Dennis Baudys (thecondordb) wrote :

Using Ubuntu 13.10 (64 bit), I have disabled speedstep function in bios and now I have the same problem with crashing indicator-cpufreq:

condor@herkules:~$ uname -a
Linux herkules 3.11.0-13-generic # 20-Ubuntu SMP Wed Oct 23 07:38:26 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

condor@herkules:~$ indicator-cpufreq
Traceback (most recent call last):
  File "/usr/bin/indicator-cpufreq", line 79, in <module>
    ind = MyIndicator(options.show_frequency)
  File "/usr/lib/python3/dist-packages/indicator_cpufreq/indicator.py", line 99, in __init__
    self.update_ui()
  File "/usr/lib/python3/dist-packages/indicator_cpufreq/indicator.py", line 110, in update_ui
    fmin, fmax, governor = cpufreq.get_policy(self.cpus[0])
  File "/usr/lib/python3/dist-packages/indicator_cpufreq/cpufreq.py", line 143, in get_policy
    policy = (p.contents.min, p.contents.max, p.contents.governor.decode())
ValueError: NULL pointer access

condor@herkules:~$ sudo apt-cache policy indicator-cpufreq
indicator-cpufreq:
  Installiert: 0.2.2-0ubuntu1
  Installationskandidat: 0.2.2-0ubuntu1
  Versionstabelle:
 *** 0.2.2-0ubuntu1 0
        500 http://de.archive.ubuntu.com/ubuntu/ saucy/universe amd64 Packages
        100 /var/lib/dpkg/status

condor@herkules:~$ cat /proc/cpuinfo
processor : 0
vendor_id : GenuineIntel
cpu family : 15
model : 4
model name : Intel(R) Pentium(R) 4 CPU 3.00GHz
stepping : 3
microcode : 0x5
cpu MHz : 3010.452
cache size : 2048 KB
physical id : 0
siblings : 2
core id : 0
cpu cores : 1
apicid : 0
initial apicid : 0
fpu : yes
fpu_exception : yes
cpuid level : 5
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx lm constant_tsc pebs bts nopl pni dtes64 monitor ds_cpl est cid cx16 xtpr
bogomips : 6020.90
clflush size : 64
cache_alignment : 128
address sizes : 36 bits physical, 48 bits virtual
power management:

processor : 1
vendor_id : GenuineIntel
cpu family : 15
model : 4
model name : Intel(R) Pentium(R) 4 CPU 3.00GHz
stepping : 3
microcode : 0x5
cpu MHz : 3010.452
cache size : 2048 KB
physical id : 0
siblings : 2
core id : 0
cpu cores : 1
apicid : 1
initial apicid : 1
fpu : yes
fpu_exception : yes
cpuid level : 5
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx lm constant_tsc pebs bts nopl pni dtes64 monitor ds_cpl est cid cx16 xtpr
bogomips : 6020.90
clflush size : 64
cache_alignment : 128
address sizes : 36 bits physical, 48 bits virtual
power management:

Xvani (fredrile+launchpad) wrote :

Hi,

Following up on what Jose said:

This happens when you disable Intel Speedstep in BIOS, as well as AMD Cool n quiet.

Hope this helps.

dino99 (9d9) wrote :

Looks like abandonware sadly, not upgraded since:

 -- Artem Popov <email address hidden> Fri, 08 Mar 2013 18:39:46 +0700

tags: added: trusty utopic
removed: saucy
tags: removed: gnome3-ppa
Ken Sharp (kennybobs) on 2015-01-29
tags: added: precise saucy
dino99 (9d9) wrote :

At least this has been rebuilt with the recent dependencies; and seems have solved that issue.

indicator-cpufreq (0.2.2-0ubuntu2) wily; urgency=medium

  * No-change rebuild for python3.5 transition

 -- Steve Langasek <email address hidden> Wed, 22 Jul 2015 17:14:13 +0000

Changed in indicator-cpufreq (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers