/usr/lib/x86_64-linux-gnu/indicator-bluetooth/indicator-bluetooth-service:11:bluez_update_device:___lambda5_:____lambda5__object_manager_interfaces_added:g_closure_invoke:signal_emit_unlocked_R

Bug #1497928 reported by errors.ubuntu.com bug bridge on 2015-09-21
36
This bug affects 5 people
Affects Status Importance Assigned to Milestone
indicator-bluetooth (Ubuntu)
High
Robert Ancell

Bug Description

The Ubuntu Error Tracker has been receiving reports about a problem regarding indicator-bluetooth. This problem was most recently seen with version 0.0.6+15.10.20150915-0ubuntu1, the problem page at https://errors.ubuntu.com/problem/5819c2721723a35013649535ed691c84f7eb06d7 contains more details.

Related branches

Sebastien Bacher (seb128) wrote :

Robert, could you have a look to this one? Seems to have start with the new bluez in wily

Changed in indicator-bluetooth (Ubuntu):
assignee: nobody → Robert Ancell (robert-ancell)
importance: Undecided → High
status: New → Confirmed
tags: added: rls-w-incoming
Robert Ancell (robert-ancell) wrote :

The stack traces are suggesting the crash is due to there not being a cached property "UUIDs" for the device. We check for NULL in the other properties, not for this one.

This is probably bad that this property doesn't exist but we still shouldn't crash.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-bluetooth - 0.0.6+15.10.20150929-0ubuntu1

---------------
indicator-bluetooth (0.0.6+15.10.20150929-0ubuntu1) wily; urgency=medium

  [ Robert Ancell ]
  * Check for NULL when getting cached properties Address and UUIDs.
    (LP: #1497928)

 -- Sebastien Bacher <email address hidden> Tue, 29 Sep 2015 09:36:03 +0000

Changed in indicator-bluetooth (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers