bluetooth indicator is missing when bluetooth antenna is off, giving the user no way to *enable* bluetooth

Bug #1134375 reported by Steve Langasek on 2013-02-27
88
This bug affects 18 people
Affects Status Importance Assigned to Milestone
indicator-bluetooth (Ubuntu)
High
Unassigned

Bug Description

In current raring, when the bluetooth antenna is disabled the bluetooth indicator icon is missing. This is a problem because the bluetooth indicator is the *only GUI interface* for enabling the bluetooth antenna when it's soft-disabled. So you can disable bluetooth in the indicator, which makes the indicator itself disappear so that you can never re-enable it.

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: indicator-bluetooth 0.0.6daily13.02.19-0ubuntu1
ProcVersionSignature: Ubuntu 3.8.0-6.13-generic 3.8.0-rc7
Uname: Linux 3.8.0-6-generic x86_64
ApportVersion: 2.8-0ubuntu4
Architecture: amd64
Date: Wed Feb 27 04:56:48 2013
InstallationDate: Installed on 2010-09-24 (887 days ago)
InstallationMedia: Ubuntu 10.04.1 LTS "Lucid Lynx" - Release amd64 (20100816.1)
MarkForUpload: True
SourcePackage: indicator-bluetooth
UpgradeStatus: Upgraded to quantal on 2013-01-25 (32 days ago)

Steve Langasek (vorlon) wrote :
Changed in indicator-bluetooth (Ubuntu):
importance: Undecided → High
status: New → Triaged
Giovanni Mellini (merlos) wrote :

There is some workaround to re-enable BT?
I tried from system setting -> hardware -> bluetooth but I cannot enable BT anymore

On Thu, Mar 07, 2013 at 02:05:21PM -0000, Giovanni Mellini wrote:
> There is some workaround to re-enable BT?
> I tried from system setting -> hardware -> bluetooth but I cannot enable
> BT anymore

You can certainly re-enable by running 'sudo rfkill unblock bluetooth' - we
just shouldn't have to resort to the commandline to do this. If that
doesn't work, then you're seeing an unrelated issue.

Giovanni Mellini (merlos) wrote :

@Steve tks, using the command you suggested I have back my BT icon :)

Jerker Nordh (ajn) wrote :

I can enable bluetooth from Settings->Bluetooth.

When enabled the icon is present in the notification field, when disabled the icon disappears making it cumbersome to reactive it.

Adam Niedling (krychek) wrote :

I'm exactly in the same situation as Jerker.

Solomon Nadar (solomonsunder) wrote :

I am also in the same situation as Jerker. Is this a bug or is it by design? It appears again in the notification bar if I activate bluetooth again from under 'System Settings'.

same here, I can also activate bluetooth from the System settings, but this makes the panel icon virtually useless, which is a shame after it became somewhat nicer in 13.04. if this a design, then a very stupid one...

Adam Niedling (krychek) wrote :

Steve: are you sure you have no way to re-enable BT after turning it off?

Steve Langasek (vorlon) wrote :

Adam, I certainly am able to re-enable bluetooth, from the /commandline/. But the UI for enabling/disabling it is gone, which is not supposed to happen.

tags: added: qa-touch

Same situation on phone (mako build 20130929) A UI way to re-enable it is to go to system-settings, but the user experience would be much better if the indicator was still present showing a disabled BT (like Wifi)

tags: removed: qa-touch
Adam Niedling (krychek) wrote :

This is still an issue in Ubuntu 13.10.

Adam Niedling (krychek) on 2013-10-14
tags: added: saucy
Holger Knust (hknust) on 2014-01-01
tags: added: trusty
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers