Does not support 'visible' gsettings key

Bug #1115394 reported by Michael Terry on 2013-02-04
34
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Bluetooth Menu
Fix Released
Medium
Robert Ancell
indicator-bluetooth (Ubuntu)
Medium
Unassigned

Bug Description

The old bluetooth indicator had a gsettings key for making it not visible:

<schema id="com.canonical.indicator.bluetooth" path="/com/canonical/indicator/bluetooth/">
  <key name="visible" type="b">
    <default>true</default>
    <_summary>Whether or not to show the bluetooth indicator in the menu bar.</_summary>
    <_description>Whether or not to show the bluetooth indicator in the menu bar.</_description>
  </key>
</schema>

But the new indicator does not use this key, which is a regression.

Related branches

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-bluetooth (Ubuntu):
status: New → Confirmed
Changed in indicator-bluetooth:
status: New → Triaged
importance: Undecided → Medium
Changed in indicator-bluetooth (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
Changed in indicator-bluetooth:
status: Triaged → In Progress
assignee: nobody → Robert Ancell (robert-ancell)
Changed in indicator-bluetooth:
status: In Progress → Fix Committed
Changed in indicator-bluetooth:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-bluetooth - 0.0.6-0ubuntu1

---------------
indicator-bluetooth (0.0.6-0ubuntu1) raring; urgency=low

  [ Michael Terry ]
  * debian/copyright:
    - Note that code is GPL-3, not GPL-3+
  * debian/control:
    - Add Vcs-Bzr entries
  * debian/source/format:
    - Switch to format 1.0, to match rest of indicator stack and for our
      daily landing support to work.
  * Automatic snapshot from revision 44 (bootstrap)

  [ Robert Ancell ]
  * New upstream release:
    - Add "Set Up New Device" menu item (LP: #1116292)
    - Only show indicator if Bluetooth adapter present (LP: #1116289)
    - Support existing gsettings key to disable indicator (LP: #1115394)
 -- Robert Ancell <email address hidden> Tue, 12 Feb 2013 10:44:19 +1300

Changed in indicator-bluetooth (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers