Ubuntu

hud-service crashed with SIGSEGV in g_variant_is_trusted()

Reported by Paolo Rotolo on 2012-02-17
110
This bug affects 16 people
Affects Status Importance Assigned to Milestone
Application Menu Indicator
High
Ted Gould
indicator-appmenu (Ubuntu)
High
Unassigned

Bug Description

HUD has crashed while I was using it...

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: indicator-appmenu 0.3.91-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-15.24-generic-pae 3.2.5
Uname: Linux 3.2.0-15-generic-pae i686
ApportVersion: 1.91-0ubuntu1
Architecture: i386
Date: Fri Feb 17 20:09:33 2012
ExecutablePath: /usr/lib/indicator-appmenu/hud-service
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha i386 (20120211)
ProcCmdline: /usr/lib/indicator-appmenu/hud-service
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANG=it_IT.UTF-8
SegvAnalysis:
 Segfault happened at: 0xb74a6a44: testb $0x4,0x10(%eax)
 PC (0xb74a6a44) ok
 source "$0x4" ok
 destination "0x10(%eax)" (0x00000010) not located in a known VMA region (needed writable region)!
SegvReason: writing NULL VMA
Signal: 11
SourcePackage: indicator-appmenu
StacktraceTop:
 ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
 g_variant_builder_add_value () from /lib/i386-linux-gnu/libglib-2.0.so.0
 ?? ()
 ?? () from /usr/lib/i386-linux-gnu/libgio-2.0.so.0
 ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
Title: hud-service crashed with SIGSEGV in g_variant_builder_add_value()
UpgradeStatus: Upgraded to precise on 2012-02-17 (0 days ago)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Paolo Rotolo (paolorotolo) wrote :

StacktraceTop:
 g_variant_is_trusted (value=0x0) at /build/buildd/glib2.0-2.31.16/./glib/gvariant-core.c:604
 g_variant_builder_add_value (builder=0xbf9fc7c0, value=0x0) at /build/buildd/glib2.0-2.31.16/./glib/gvariant.c:3393
 get_suggestions (query=<optimized out>, self=<optimized out>) at /build/buildd/indicator-appmenu-0.3.91/./src/hud-dbus.c:254
 bus_method (connection=0x9d6f000, sender=0xb1d31d10 ":1.38", object_path=0xb1d05740 "/com/canonical/hud", interface_name=0xb1d056e8 "com.canonical.hud", method_name=0xb1d56e48 "StartQuery", parameters=0xb1daa538, invocation=0x9d6dd80, user_data=0x9d6b200) at /build/buildd/indicator-appmenu-0.3.91/./src/hud-dbus.c:201
 call_in_idle_cb (user_data=0x9d6dd80) at /build/buildd/glib2.0-2.31.16/./gio/gdbusconnection.c:4698

Changed in indicator-appmenu (Ubuntu):
importance: Undecided → Medium
summary: - hud-service crashed with SIGSEGV in g_variant_builder_add_value()
+ hud-service crashed with SIGSEGV in g_variant_is_trusted()
tags: removed: need-i386-retrace
Changed in indicator-appmenu (Ubuntu):
status: New → Incomplete
status: Incomplete → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-appmenu (Ubuntu):
status: New → Confirmed
visibility: private → public
Changed in indicator-appmenu (Ubuntu):
importance: Medium → High
tags: added: hud
Ted Gould (ted) on 2012-02-20
Changed in indicator-appmenu:
status: New → In Progress
importance: Undecided → High
assignee: nobody → Ted Gould (ted)
Ted Gould (ted) on 2012-02-23
Changed in indicator-appmenu:
status: In Progress → Fix Committed
milestone: none → 0.3.92
Changed in indicator-appmenu (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-appmenu - 0.3.91-0ubuntu2

---------------
indicator-appmenu (0.3.91-0ubuntu2) precise; urgency=low

  * Backport r165 to fix a segfault in the hud service which gets quite
    some duplicates (lp: #934429)
 -- Sebastien Bacher <email address hidden> Mon, 27 Feb 2012 12:29:34 +0100

Changed in indicator-appmenu (Ubuntu):
status: Fix Committed → Fix Released
Ted Gould (ted) on 2012-03-07
Changed in indicator-appmenu:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers