Ubuntu

Menu bar - Ugly global menu behaviour with fullscreen window

Reported by Dylan McCall on 2011-04-03
44
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Medium
John Lea
Unity
Medium
Marco Trevisan (Treviño)
indicator-appmenu (Ubuntu)
Medium
Unassigned
unity (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: unity

Make a window fullscreen (so that it covers the menu bar) and press F10. It is possible to use and navigate the menu bar using the keyboard, but because the menu bar itself is hidden all you see are floating menus with no titles to tell you where they come from.

Desired Resolution:
- Opening the app menus when in full screen mode (either by pressing ALT or F10) should cause the top bar to temporally slide down over the top of the full screen application.
- After the user selects a action from any of the menus, the top bar and associated menus should slide back off the screen.
- Pressing ALT or F10 a second time should close the menu, and also cause the top bar to slide back off the screen.
- Pressing ESC should close the menu, and also cause the top bar to slide back off the screen.

Bilal Akhtar (bilalakhtar) wrote :

Reproduced with Firefox.

Changed in unity (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
Changed in unity:
status: New → Confirmed

Confirming. I guess we need input from design to know how to manage this corner situation.

Ok, sorry the design input was already there: https://wiki.ubuntu.com/MenuBar#full-screen

Changed in ayatana-design:
status: New → Fix Released
Changed in unity:
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in indicator-appmenu:
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
John Lea (johnlea) on 2011-09-22
description: updated
John Lea (johnlea) on 2011-09-22
summary: - Ugly global menu behaviour with fullscreen window
+ top bar - Ugly global menu behaviour with fullscreen window
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → Medium
status: Fix Released → Fix Committed
tags: added: onew udo
John Lea (johnlea) on 2011-09-28
Changed in ayatana-design:
status: Fix Committed → Fix Released
John Lea (johnlea) on 2011-10-18
tags: added: udp
Changed in unity:
milestone: none → backlog
Changed in ayatana-design:
status: Fix Released → Fix Committed

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-appmenu (Ubuntu):
status: New → Confirmed
Ted Gould (ted) wrote :

I'm not sure what needs to be done in indicator-appmenu for this. It seems this is mostly a Unity thing, no?

Changed in indicator-appmenu:
importance: Undecided → Wishlist
status: New → Incomplete
Tim Penhey (thumper) on 2012-09-14
Changed in unity:
milestone: backlog → none
John Lea (johnlea) on 2012-10-09
no longer affects: indicator-appmenu
summary: - top bar - Ugly global menu behaviour with fullscreen window
+ Menu bar - Ugly global menu behaviour with fullscreen window
Changed in unity:
importance: Undecided → Medium
Changed in indicator-appmenu (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
Changed in unity:
status: Confirmed → Triaged
Changed in unity (Ubuntu):
status: Confirmed → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints