Zend Studio doesn't have appmenu

Bug #725331 reported by Tomick on 2011-02-25
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Application Menu Indicator
Incomplete
Low
Unassigned
indicator-appmenu (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: indicator-appmenu

When I running Zend Studio on Unity Desktop default main menu is hidden and doesn't show in Unity panel too.
It's interesting, because main menu Eclipse Helios does not disappear.

Tomick (tomick) wrote :
Tomick (tomick) wrote :

Today i have updated version of Unity (3.6) and appmenu for Zend Studio has 3 items :-) "Source", "Run" and "Windows"

David Barth (dbarth) wrote :

We're progressing.

Sebastien Bacher (seb128) wrote :

thank you for your bug report, what ubuntu version do you run? do you know if zend studio is written in gtk?

Changed in indicator-appmenu (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Changed in indicator-appmenu:
importance: Undecided → Low
status: New → Incomplete
Tomick (tomick) wrote :

I have Ubuntu Natty with latest updates.

I don't think Zend Studio is written in GTK. Basically Zend Studio is Eclipse with Zend modifications. So it's Java application. In Appmenu i have five menu entries: Edit, Source, Navigate, Run and Window. Missing menu entries in Zend Studio are: File, Refactor, Search, Project and Help.

Sebastien Bacher (seb128) wrote :

ok, so it might be a duplicate of bug #618587

Changed in indicator-appmenu (Ubuntu):
status: Incomplete → New
Changed in indicator-appmenu:
status: Incomplete → New
Tomick (tomick) wrote :

Yes, maybe it's related with Eclipse, but in Eclipse I have blank menu ( File menu with Close option). In Zend situation is different

Krzysztof (krzysztof-kardasz) wrote :

Create for example ZendStudio.sh file with contents:
------------------------------------------------------------------------
#!/bin/bash
UBUNTU_MENUPROXY=0
./ZendStudio
------------------------------------------------------------------------

and run:
chmod +x ZendStudio.sh
./ZendStudio.sh

it solve this problem.

elzo valugi (valugi) wrote :

@Krzysztof your trick works

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-appmenu (Ubuntu):
status: New → Confirmed
Charles Kerr (charlesk) wrote :

libdbusmenu-0.4.90-0ubuntu1, which was released on 2011-06-24, contained a pair of fixes (LP: #770263 and LP: #618587) for working with Eclipse... I don't see any activity on this ticket after that date.

Is this behavior still happening in Zend Studio when run on 12.04?

Changed in indicator-appmenu:
status: New → Incomplete
Saji Nediyanchath (saji89) wrote :

@Charles,
    I'm using Zend studio 9.0.1 in Ubuntu 12.04 as of now. It shows the appmenu without any problems.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers