indicator-applet-appmenu crashed with SIGSEGV in dbusmenu_menuitem_send_about_to_show()

Bug #723463 reported by tamoihl on 2011-02-22
86
This bug affects 11 people
Affects Status Importance Assigned to Milestone
Application Menu Indicator
Invalid
Medium
Unassigned
indicator-appmenu (Ubuntu)
Medium
Unassigned
Natty
Medium
Unassigned

Bug Description

Binary package hint: indicator-applet

I've tried open Pigdin IM and this the crash report was generated. From an in icon on the desktop.

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: indicator-applet 0.4.9-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-4.31-generic 2.6.38-rc5
Uname: Linux 2.6.38-4-generic i686
Architecture: i386
Date: Wed Feb 23 00:48:27 2011
ExecutablePath: /usr/lib/indicator-applet/indicator-applet-appmenu
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110221)
ProcCmdline: /usr/lib/indicator-applet/indicator-applet-appmenu
ProcEnviron:
 SHELL=/bin/bash
 LC_MESSAGES=en_GB.UTF-8
 LANGUAGE=en_GB:en
 LANG=de_DE.UTF-8
SegvAnalysis:
 Segfault happened at: 0x70a7f66 <dbusmenu_menuitem_send_about_to_show+38>: mov (%esi),%edi
 PC (0x070a7f66) ok
 source "(%esi)" (0x69736976) not located in a known VMA region (needed readable region)!
 destination "%edi" ok
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: indicator-applet
StacktraceTop:
 dbusmenu_menuitem_send_about_to_show () from /usr/lib/libdbusmenu-glib.so.3
 window_menus_entry_activate () from /usr/lib/indicators/5/libappmenu.so
 ?? () from /usr/lib/indicators/5/libappmenu.so
 indicator_object_entry_activate () from /usr/lib/libindicator.so.3
 ?? ()
Title: indicator-applet-appmenu crashed with SIGSEGV in dbusmenu_menuitem_send_about_to_show()
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
XsessionErrors:
 (nautilus:1296): GConf-CRITICAL **: gconf_value_free: assertion `value != NULL' failed
 (nm-applet:1307): Gdk-CRITICAL **: IA__gdk_window_thaw_toplevel_updates_libgtk_only: assertion `private->update_and_descendants_freeze_count > 0' failed
 (nautilus:1296): GConf-CRITICAL **: gconf_value_free: assertion `value != NULL' failed
 (nautilus:1584): GConf-CRITICAL **: gconf_value_free: assertion `value != NULL' failed

Related branches

tamoihl (tamoihl1-gmx) wrote :

StacktraceTop:
 dbusmenu_server_class_init (klass=0x69736976) at ../../libdbusmenu-glib/server.c:210
 dbusmenu_server_class_intern_init (klass=0x69736976) at ../../libdbusmenu-glib/server.c:203
 window_menus_entry_activate (wm=0x8d67320, entry=0x8cc3ac8, timestamp=508599) at window-menus.c:801
 entry_activate (io=0x8bbb9d8, entry=0x8cc3ac8, timestamp=508599) at indicator-appmenu.c:955
 indicator_object_entry_activate (io=0x8bbb9d8, entry=0x8cc3ac8, timestamp=508599) at /build/buildd/libindicator-0.3.19/./libindicator/indicator-object.c:547

Changed in indicator-applet (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
visibility: private → public
affects: indicator-applet (Ubuntu) → indicator-appmenu (Ubuntu)
Kalle Valo (kvalo) on 2011-02-25
Changed in indicator-appmenu:
importance: Undecided → Medium
Michael Terry (mterry) wrote :

So the crash itself is due to GtkMenuItems created in entry_added() in indicator-applet hanging around after their IndicatorObjectEntry objects have gone. When they are activated, they start making function calls with the obsolete entry object and end up causing a crash.

This is borne out by the duplicates, which mention menu items sticking around from other applications. I haven't figured out why that happens yet, but am looking.

Michael Terry (mterry) wrote :

I'm having difficulty reproducing to find out how this situation occurs. Does anyone affected by this have suggestions for reproduction? Obviously I have to be not in unity, using the gnome-panel appmenu applet, but I've lived in it a little while, and nothing has come up.

Gary M (garym) on 2011-02-27
Changed in indicator-appmenu (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

The few duplicates don't not very useful descriptions...

Changed in indicator-appmenu (Ubuntu Natty):
assignee: nobody → Michael Terry (mterry)
milestone: none → ubuntu-11.04-beta-1
milestone: ubuntu-11.04-beta-1 → none
Changed in indicator-appmenu (Ubuntu Natty):
assignee: Michael Terry (mterry) → Chris Coulson (chrisccoulson)
Sebastien Bacher (seb128) wrote :

the bug was listed in this upload:

libdbusmenu (0.3.100-0ubuntu4) natty; urgency=low

  * libdbusmenu-gtk/parser.c
    - Ensure we set the CACHED_MENUITEM data on GtkWidget's, this fixes a few
      bugs (LP: #723463) (LP: #729128) (LP: #729194)

but not sure it does fix the crash as well or not

Ted Gould (ted) wrote :

Marking as incomplete, as it was mentioned but we need confirmation that it's fixed. Thanks!

Changed in indicator-appmenu:
status: New → Fix Released
status: Fix Released → Incomplete
Jungle Boy (mowgli80) wrote :

I still have this problem with latest packages ... can confirm has not been fixed

Changed in indicator-appmenu (Ubuntu):
assignee: Chris Coulson (chrisccoulson) → nobody
Changed in indicator-appmenu (Ubuntu Natty):
assignee: Chris Coulson (chrisccoulson) → nobody
Ted Gould (ted) wrote :

I'm going to go ahead and mark this as invalid so that if someone gets it again we can get a new stack trace. This one is too old to be of more use. Thanks everyone, hope we can get another trace.

Changed in indicator-appmenu:
status: Incomplete → Invalid
Changed in indicator-appmenu (Ubuntu):
status: Confirmed → Invalid
Changed in indicator-appmenu (Ubuntu Natty):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers