Ubuntu

indicator-appmenu breaks Alt accelerator keys

Reported by Barry Warsaw on 2010-10-19
76
This bug affects 11 people
Affects Status Importance Assigned to Milestone
Application Menu Indicator
High
Unassigned
Unity
High
Neil J. Patel
Unity Foundations
High
Michael Terry
indicator-appmenu (Ubuntu)
High
Unassigned
Natty
High
Unassigned
unity (Ubuntu)
Undecided
Unassigned
Natty
Undecided
Unassigned

Bug Description

Binary package hint: indicator-applet

When indicator-applet-appmenu is installed, no Alt-<key> menu accelerators work for any application. For example, try Alt+H in most apps to raise the Help menu. It doesn't work.

Omer Akram (om26er) on 2010-10-19
affects: indicator-applet (Ubuntu) → indicator-appmenu (Ubuntu)
Changed in indicator-appmenu (Ubuntu):
status: New → Confirmed
u-foka (ufooka) wrote :

I can confirm this!

Omer Akram (om26er) on 2010-10-30
summary: - indicator-applet-appmenu breaks Alt accelerator keys
+ indicator-appmenu breaks Alt accelerator keys
Changed in indicator-appmenu (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
Changed in indicator-appmenu:
status: New → Confirmed
Oleksij Rempel (olerem) wrote :

Hmm... gnome-terminal use "ctrl+shift+v" - this do not working on my setup. Interisting thing - "ctrl+shift+c" is working

David Barth (dbarth) wrote :

Hi, we cannot reproduce the issue, neither on Maverick with the classic gnome desktop session, nor on Natty.
Could you confirm that this bug still happens for you, and detail the environment and steps to reproduce please?

Thanks for your help

David Barth (dbarth) wrote :

Apologies, I can reproduce the problem now, and can confirm it with Natty running with the classic gnome session as well.

Changed in indicator-appmenu (Ubuntu):
status: Triaged → Confirmed
Changed in indicator-appmenu:
importance: Undecided → Medium
assignee: nobody → Ted Gould (ted)
David Barth (dbarth) on 2010-12-07
Changed in indicator-appmenu:
assignee: Ted Gould (ted) → Karl Lattimer (karl-qdh)
David Barth (dbarth) on 2010-12-17
Changed in indicator-appmenu (Ubuntu):
milestone: none → natty-alpha-2
assignee: nobody → Karl Lattimer (karl-qdh)
tags: added: keyboard
Changed in unity:
milestone: none → 3.4
status: New → Confirmed
importance: Undecided → High
Changed in indicator-appmenu:
importance: Medium → High
Changed in indicator-appmenu (Ubuntu):
importance: Medium → High
Changed in unity:
assignee: nobody → Karl Lattimer (karl-qdh)
Neil J. Patel (njpatel) on 2011-01-18
Changed in unity:
milestone: 3.4 → 3.6
Martin Pitt (pitti) on 2011-01-25
Changed in indicator-appmenu (Ubuntu Natty):
milestone: natty-alpha-2 → natty-alpha-3
Karl Lattimer (karl-qdh) wrote :

https://bugs.launchpad.net/indicator-appmenu/+bug/688018 - is a duplicate of this bug, but is apparently fixed.

Didier Roche (didrocks) on 2011-02-21
Changed in unity (Ubuntu Natty):
status: New → Confirmed
David Barth (dbarth) on 2011-02-21
Changed in indicator-appmenu:
assignee: Karl Lattimer (karl-qdh) → Michael Terry (mterry)
Changed in unity:
assignee: Karl Lattimer (karl-qdh) → Michael Terry (mterry)
Changed in indicator-appmenu (Ubuntu Natty):
assignee: Karl Lattimer (karl-qdh) → Michael Terry (mterry)
Martin Pitt (pitti) wrote :

This is a bug fix, can happen after FF, and isn't a release blocker.

Changed in indicator-appmenu (Ubuntu Natty):
milestone: natty-alpha-3 → none
Didier Roche (didrocks) on 2011-03-01
Changed in unity:
milestone: 3.6 → 3.6.2
Ding Zhou (tualatrix) wrote :

I can reproduce this bug.

In my GNOME Terminal, only Ctrl+Alt+C works, CTRL+ALT+V doesn't work.

And I can't use Alt+(NUMBER) to switch the tab in all applications: gedit, gnome-terminal and firefox.

Michael Terry (mterry) wrote :

Hmm, Alt+NUMBER in gedit works for me in natty classic session with an appmenu panel applet. Are there some more steps to reproduce?

The GNOME Terminal pasting issue is possibly different, as it uses shift, not alt. See bug 630383.

Michael Terry (mterry) wrote :

So, the Ctrl+Shift+V issue in GNOME Terminal (bug 630383) is now fixed. (Note that this did not use Alt.) The Alt+1/Alt+2 keys in gedit are working fine for me.

The issue I *can* see is that Alt+? does not activate menu items in the global menu bar. Is that what this bug is about?

Didier Roche (didrocks) on 2011-03-07
Changed in unity:
milestone: 3.6.2 → 3.6.4
Michael Terry (mterry) wrote :

Just to confirm, after talking with Neil about this bug, Alt+? mnemonics do seem to be what it's about. So that's cleared up. :)

I've now filed https://code.launchpad.net/~mterry/indicator-appmenu/emit-show-now-changed/+merge/52583 and its two related merges.

These pass the Alt press up through the appmenu indicator. Now Neil will take it away with some unity-side changes to show the indicator as needed and to render its underlines.

Changed in unity:
assignee: Michael Terry (mterry) → Neil J. Patel (njpatel)
Changed in indicator-appmenu:
status: Confirmed → In Progress
Changed in indicator-appmenu (Ubuntu Natty):
status: Confirmed → Triaged
status: Triaged → In Progress
description: updated
Michael Terry (mterry) on 2011-03-09
Changed in indicator-appmenu:
assignee: Michael Terry (mterry) → nobody
status: In Progress → Fix Committed
Changed in indicator-appmenu (Ubuntu Natty):
assignee: Michael Terry (mterry) → nobody
status: In Progress → Triaged
David Barth (dbarth) wrote :

Thanks mterry for the fix.

To be clear, once the branch is released, there are no other foundations aspect to it, and it becomes "just" a unity fix to add, right?

Changed in unity-foundations:
assignee: nobody → Ted Gould (ted)
importance: Undecided → High
milestone: none → ubuntu-11.04-beta-1
status: New → Fix Committed
Michael Terry (mterry) wrote :

To my knowledge. Let me know if that turns out not to be true.

Michael Terry (mterry) wrote :

OK, after talking with Neil, he set me straight. Unity should be able to show menus when Alt is pressed with my changes. But the ability to actually show a menu when Alt+F is pressed is still in the foundations stack. Looking at that now.

Changed in unity-foundations:
assignee: Ted Gould (ted) → Michael Terry (mterry)
status: Fix Committed → In Progress
Didier Roche (didrocks) on 2011-03-10
Changed in unity:
milestone: 3.6.4 → 3.6.6
Michael Terry (mterry) on 2011-03-15
Changed in unity-foundations:
status: In Progress → Fix Released
Changed in indicator-appmenu (Ubuntu Natty):
status: Triaged → Fix Released
Changed in indicator-appmenu:
status: Fix Committed → Fix Released
David Barth (dbarth) on 2011-03-15
Changed in unity-foundations:
milestone: unity-3.8.0-beta → unity-3.6.6
Neil J. Patel (njpatel) on 2011-03-17
Changed in unity:
status: Confirmed → Fix Committed
Didier Roche (didrocks) on 2011-03-17
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (4.8 KiB)

This bug was fixed in the package unity - 3.6.6-0ubuntu1

---------------
unity (3.6.6-0ubuntu1) natty; urgency=low

  * New upstream release:
    - drag and drop from dash to launcher issues (LP: #727675)
    - unity-panel-service crashed in g_type_class_meta_marshal (LP: #727788)
    - Dash: first-use text entry does not work until Alt-F2 version is used
      (LP: #735342)
    - compiz crashed with SIGSEGV in g_type_check_instance_is_a()
      (LP: #734721)
    - drag from dash to launcher (LP: #662616)
    - Dash - Create single widget for Dashboard (LP: #683729)
    - [FFe] Recently installed applications should be easy to run
      (LP: #670403)
    - Pressing Alt key does not underline mnemonics (LP: #689179)
    - indicator-appmenu breaks Alt accelerator keys (LP: #663030)
    - can't pin KTouch to the launcher (LP: #693755)
    - Unity paints multiple times with multi-screen (LP: #727116)
    - unitymtgrabhandles crashes when no key is set (LP: #727144)
    - SIGSEGV in PlaceEntryHome::SetSearch (LP: #731927)
    - [launcher] New Default favorites (LP: #714707)
    - Dash: Alt-F2 Pressing enter on the dash can start the first entry of the
      second group from the history (LP: #734738)
    - Dash: keyboard arrow navigation disappears off bottom (LP: #735347)
    - Increase the size of the top left Launcher reveal area from 1px to a 3px
      by 3px square (LP: #736034)
    - [dash] scrollbar's clickable zone should extend to the right border of
      the dash border (LP: #651398)
    - Launcher - Replace Dash lens Launcher icons with updated versions
      (LP: #676613)
    - NuxUtilAccessible requires to implement support to key event listeners
      (LP: #702672)
    - launcher icons dnd doesn't behave correctly when the dash is in use
      (LP: #708885)
    - Keyboard-navigation: highlight stays after losing focus (LP: #713632)
    - Implement AtkComponent for ATK objects in the panel service
      (LP: #715297)
    - Super shortcuts for application place and worskspace swither conflicts
      with compiz keys (LP: #723273)
    - Use DeeIndex instead of strcmp in PlaceEntryHome (LP: #724886)
    - [dash] text cursor not vertically centred in the entry (LP: #724927)
    - Moving cursor in dash text entry field causes cursor artifacts
      (LP: #725493)
    - Missing "children_changed" event emission from the atk support
      (LP: #727137)
    - Typing should immediately search; focusing the search field is fiddly
      (LP: #727295)
    - "Find Internet Apps", "Browse the Web", and "Check Mail" are scattered
      in default Dash (LP: #729009)
    - Press-holding on a icon in the Launcher should de-couple the icon and
      enable the user to reorder the icon vertically without leaving the
      Launcher. (LP: #727922)
    - "Shortcuts" heading in Dash seems pointless (LP: #729000)
    - intellihide is incompatible with totem fullscreen / Still some false
      positive on ws switch (LP: #730679)
    - Launcher - provide visual design for launcher keyboard navigation
      (LP: #702490)
    - Dash - Update the 'Shortcuts' dash home icon (LP: #689763)
    - The Unity panel service Does not connect to the
      INDICATOR_OBJECT...

Read more...

Changed in unity (Ubuntu Natty):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers