Maximised windows are automatically closed

Bug #637108 reported by Mitchell on 2010-09-13
64
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Application Menu Indicator
Fix Released
Undecided
Unassigned
Unity
Fix Released
Critical
Neil J. Patel
indicator-appmenu (Ubuntu)
Undecided
Ken VanDine
unity (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: unity

Wow... love the concept of Unity, but currently too buggy to use. I'm noticing crashes on most windows. Notably this includes Firefox, OpenOffice Word Processor, Tomboy, and Gimp. With both Tomboy and Gimp the issue was going from small screen to a maximized on. Did not like that.

Also, periodically Unity will just freeze up. I'm on an eeepc 901 netbook. Works great on desktop edition.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: unity 0.2.36-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.35-20.29-generic 2.6.35.4
Uname: Linux 2.6.35-20-generic i686
Architecture: i386
Date: Mon Sep 13 23:05:00 2010
InstallationMedia: Ubuntu-Netbook 10.10 "Maverick Meerkat" - Beta i386 (20100902.1)
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: unity

Related branches

Mitchell (curious-mitchell) wrote :
Didier Roche (didrocks) wrote :

thanks for reporting this bug and help to make ubuntu better,

do you mean the window is crashing or unity itself?

  Windows. unity does seem to need to reset itself periodically though,
at least once a session. This is when the whole screen blanks out, and
coes back refreshed. Seems like it's crashing, then restarting, to me.

On 09/13/2010 11:28 PM, Didier Roche wrote:
> thanks for reporting this bug and help to make ubuntu better,
>
> do you mean the window is crashing or unity itself?
>

I've been tracking this since this morning too. it happens intermittantly when you maximised a window (not always, but quite consitstantly). However, if you run unity without indicators, it doesn't happen. Targetting for this week.

Changed in unity:
assignee: nobody → Neil J. Patel (njpatel)
importance: Undecided → Critical
milestone: none → 2010-09-16
status: New → Triaged
summary: - Unity has LOTS of crashes... seemingly most windows
+ Maximised windows are automatically closed

  How do I run Unity without Indicators? Would like to spend more time
using it. At the moment, the desktop edition is my default.

On 09/14/2010 08:49 AM, Neil J. Patel wrote:
> I've been tracking this since this morning too. it happens
> intermittantly when you maximised a window (not always, but quite
> consitstantly). However, if you run unity without indicators, it doesn't
> happen. Targetting for this week.
>
> ** Also affects: unity
> Importance: Undecided
> Status: New
>
> ** Changed in: unity
> Importance: Undecided => Critical
>
> ** Changed in: unity
> Status: New => Triaged
>
> ** Changed in: unity
> Milestone: None => 2010-09-16
>
> ** Changed in: unity
> Assignee: (unassigned) => Neil J. Patel (njpatel)
>
> ** Summary changed:
>
> - Unity has LOTS of crashes... seemingly most windows
> + Maximised windows are automatically closed
>

Neil J. Patel (njpatel) wrote :

This seems to have been caused by the patch to fix the unminimising-windows-go-missing bug, we are investigating to try and get this fixed for todays release.

Didier Roche (didrocks) on 2010-09-14
affects: unity (Ubuntu) → mutter (Ubuntu)
Didier Roche (didrocks) on 2010-09-14
Changed in mutter (Ubuntu):
status: New → Fix Released
affects: mutter (Ubuntu) → indicator-appmenu (Ubuntu)
Changed in indicator-appmenu (Ubuntu):
assignee: nobody → Ken VanDine (ken-vandine)
milestone: none → ubuntu-10.10
status: Fix Released → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-appmenu - 0.0.11-0ubuntu2

---------------
indicator-appmenu (0.0.11-0ubuntu2) maverick; urgency=low

  * Cherry pick fix for maximized windows getting closed (LP: #637108)
 -- Ken VanDine <email address hidden> Thu, 16 Sep 2010 08:59:12 -0400

Changed in indicator-appmenu (Ubuntu):
status: Triaged → Fix Released
Erlan Sergaziev (sergeant) wrote :

Confirming that version of 0.0.11 of indicator-appmenu fixes it.

Changed in unity:
status: Triaged → Fix Released
Changed in indicator-appmenu:
status: New → Fix Released
Erlan Sergaziev (sergeant) wrote :

@dinky

Based on your initial post I believe you are affected by two bugs, one concerning maximization of windows (now fixed) and the other one concerning general Unity sluggishness and instability which should be filed as a separate bug.

Please also check bug 621690 as perhaps this is what's causing it.

daveW (net-davew) wrote :

I've come here from Bug #636764 via google as this exactly describes the problem I have, but I have version 0.0.13 of indicator-appmenu and shotwell windows still closes itself. I don't see this in other programs. Can anyone advise please?

Ken VanDine (ken-vandine) wrote :

Are you seeing this without any other windows that are maximized? Perhaps you are experiencing a crash in shotwell, can you run shotwell from a terminal and see if anything is output when the window closes? If so, please file a bug against the shotwell package for that. Thanks!

daveW (net-davew) wrote :

I just managed to re-create this in a new install of ubuntu desktop, but fixed it following the instruction from bug 675068:
https://bugs.launchpad.net/ubuntu/+source/shotwell/+bug/675068
this involved compiling the latest 0.8.0 from svn, but so far seems to be working. Now I have to decide if I compile it on 2 more machines or wait for a package!
cheers all,
Dave

Changed in unity (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers