Ubuntu

The LyX menu is not shown in Unity

Reported by rawphi on 2010-08-18
150
This bug affects 39 people
Affects Status Importance Assigned to Milestone
Application Menu Indicator
Low
Unassigned
DBus Menu
Low
Ted Gould
indicator-appmenu (Ubuntu)
Low
Unassigned
libdbusmenu (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: indicator-appmenu

when using the indicator appmenu applet, the menu of Lyx doesn't show up at all (empty applet)

Lyx itself works fine and if applet is not started, the menu is shown in the app window.

rawphi (raphael-ist) wrote :

Ubuntu 10.10 maverick

lyx:1.6.5-1ubuntu1
indicator-appmenu: 0.0.9-0ubuntu1
indicator-applet-appmenu: 0.4.3-0ubuntu1

Juha Siltala (topyli) wrote :

Confirming this. KeePassX works fine, so Qt apps are not categorically broken.

Changed in indicator-appmenu (Ubuntu):
status: New → Confirmed
Juha Siltala (topyli) wrote :

Is it possible, as a workaround, to make the applet ignore LyX so that the menu would at least be displayed in the application window? Currently LyX is unusable.

Juha Siltala (topyli) wrote :

I have learned that launching LyX with either 'QT_X11_NO_NATIVE_MENUBAR=1 lyx' or 'APPMENU_DISPLAY_BOTH=1 lyx' are usable workarounds.

I assume the latter is better, since it will normally display the menu in both the application window and the applet, so it allows us to notice when the bug is fixed. :)

m4lte (malte-koester) wrote :

How do I launch lyx with one of these options?

On Fri, Oct 15, 2010 at 15:49, m4lte <email address hidden> wrote:

> How do I launch lyx with one of these options?

Any command line will do. A terminal for example, or the Run dialog
(Alt+F2).

Changed in indicator-appmenu (Ubuntu):
importance: Undecided → Low
assignee: nobody → Canonical Desktop Experience Team (canonical-dx-team)

When launched from a terminal, LyX gives this output:

    QVariantMap DBusMenuExporterDBus::GetProperties(int, const QStringList&): Condition failed: action

Aurélien Gâteau (agateau) wrote :

The "Condition failed: action" messages are annoying (and will be fixed) but do not indicate a problem. LyX menubar is correctly exposed when running on KDE, so I think the problem is in indicator-appmenu.

Changed in indicator-appmenu:
assignee: nobody → Ted Gould (ted)
Waluyo Adi Siswanto (was-wlk) wrote :

I just installed LyX (from Ubuntu software center) in Ubuntu Netbook 10.10 (acer aspire one happy). I cannot see all menus. When I run from terminal, I got the same message as already mentioned in comment #7. Any possibility to see the menus? since LyX is unusable right now.

Waluyo Adi Siswanto (was-wlk) wrote :

Ooops sorry....., it works from the terminal (comment #4, by Juha Siltala, thanks)
QT_X11_NO_NATIVE_MENUBAR=1 lyx

Waluyo Adi Siswanto (was-wlk) wrote :

I tried to change the menu command using "QT_X11_NO_NATIVE_MENUBAR=1 lyx", but when I click LyX icon, it does not display. What is the command in LyX properties (System->Main Menu->Lyx, properties), so I do not need to type the command from terminal, but clicking the LyX icon as usual?

Waluyo Adi Siswanto (was-wlk) wrote :

I am sorry again (please disregard my previous messages). I have found the solution, and I have written here:
https://answers.launchpad.net/ubuntu/+question/134649

Jean-Marc Lasgouttes (jmarc) wrote :

With my LyX developer hat on (and my LyX menu system designer cap on my hat).

The bug is probably due to the fact that LyX generates its menus on the fly
when they are open (many things are dynamic). Is there some documentation
on how to do it properly? It already works on OS X, so it cannot be so
difficult...

David Barth (dbarth) wrote :

From what Aurélien is saying, it should not be a problem in either Lyx or or the QT patch. It's more an incompability between entries generated by the QT patch he developed and the gtk indicator end. The menus are correctly exposed under KDE if you use the plasma verion of the global menu.

cristo (ccristoo) wrote :

I have confirmed that using APPMENU_DISPLAY_BOTH=1 it also works for lyx in Ubuntu Netbook Edition 10.10. I also found another three bugs that seems to be a duplicate of this one. Shouldn't the importance of this bug be higher?

David Barth (dbarth) wrote :

There is a workaround, and we have no plan to provide a more complete Lyx support directly, sorry. But we welcome patches that would make Lyx use dbusmenu as a build time or runtime option.

Changed in indicator-appmenu (Ubuntu):
importance: Low → Wishlist
assignee: Canonical Desktop Experience Team (canonical-dx-team) → nobody
Ted Gould (ted) on 2011-02-03
Changed in indicator-appmenu:
assignee: Ted Gould (ted) → nobody
importance: Undecided → Wishlist
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Ted, why did you set that one as wishlist? It seems Aurelien said the qt side is ok, in any case an application have it's menu hidden but not exported seems a bug rather than a wishlist issue?

Changed in indicator-appmenu (Ubuntu):
assignee: nobody → Ted Gould (ted)

On Fri, 2011-03-11 at 15:02 +0000, Sebastien Bacher wrote:
> Ted, why did you set that one as wishlist? It seems Aurelien said the qt
> side is ok, in any case an application have it's menu hidden but not
> exported seems a bug rather than a wishlist issue?

I believe we had set it to wishlist because it wasn't seen as critical
for the netbook edition. Obviously now that we're doing desktop that's
different.

let's set it to low for now but it would be nice to see what's going on for natty

Changed in indicator-appmenu (Ubuntu):
importance: Wishlist → Low
Changed in indicator-appmenu:
importance: Wishlist → Low
Sebastien Bacher (seb128) wrote :

is that still an issue, do you have appmenu-qt installed?

Okay, this seems to be because Lyx uses AboutToShow for all of the menus
and doesn't provide any menus except the first by default. Here is a
call to GetLayout:

(9L,
 (0,
  {u'children-display': u'submenu'},
  [(1, {u'children-display': u'submenu', u'label': u'_File'}, []),
   (2, {u'children-display': u'submenu', u'label': u'_Edit'}, []),
   (3, {u'children-display': u'submenu', u'label': u'_View'}, []),
   (4, {u'children-display': u'submenu', u'label': u'_Insert'}, []),
   (5, {u'children-display': u'submenu', u'label': u'_Navigate'}, []),
   (6, {u'children-display': u'submenu', u'label': u'_Document'}, []),
   (7, {u'children-display': u'submenu', u'label': u'_Tools'}, []),
   (8, {u'children-display': u'submenu', u'label': u'_Help'}, [])]))

Ted Gould (ted) on 2011-03-28
affects: indicator-appmenu (Ubuntu) → libdbusmenu (Ubuntu)
affects: indicator-appmenu → dbusmenu
Changed in dbusmenu:
assignee: nobody → Ted Gould (ted)
bp (badpazzword) on 2011-04-03
summary: - does not show Lyx menu
+ The LyX menu is not shown in Unity
Ted Gould (ted) on 2011-04-05
Changed in indicator-appmenu:
status: New → In Progress
Changed in dbusmenu:
status: Confirmed → In Progress
Changed in libdbusmenu (Ubuntu):
status: Confirmed → Fix Committed
Changed in indicator-appmenu:
importance: Undecided → Low
Changed in indicator-appmenu (Ubuntu):
importance: Undecided → Low
status: New → Fix Committed
Changed in libdbusmenu (Ubuntu):
assignee: Ted Gould (ted) → nobody
Ted Gould (ted) on 2011-04-07
Changed in dbusmenu:
status: In Progress → Fix Committed
milestone: none → 0.4.2
Ted Gould (ted) on 2011-04-07
Changed in dbusmenu:
status: Fix Committed → Fix Released
Ted Gould (ted) on 2011-04-07
Changed in indicator-appmenu:
status: In Progress → Fix Committed
milestone: none → 0.2.0
Ted Gould (ted) on 2011-04-07
Changed in indicator-appmenu:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libdbusmenu - 0.4.2-0ubuntu1

---------------
libdbusmenu (0.4.2-0ubuntu1) natty; urgency=low

  * New upstream release.
    * Fix GIR scan to not include duplicate namespaces (LP: #750575)
    * Keep refs to the client and makes sure to disconnect all handlers.
      (LP: #749609)
    * Add GTK side handlers for the open/close events to ensure GTK apps
      can use those events still (LP: #750588)
    * Create submenus for menuitems that don't have children but still
      have told us they need them with the child-display property.
      (LP: #619811)
 -- Ted Gould <email address hidden> Thu, 07 Apr 2011 10:32:51 -0500

Changed in libdbusmenu (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-appmenu - 0.2.0-0ubuntu1

---------------
indicator-appmenu (0.2.0-0ubuntu1) natty; urgency=low

  * New upstream release.
    ∘ Adding a check of the indicator environment to hide the menu stubs
      under Unity (LP: #703555)
    ∘ Send about-to-show on menus that don't have any children currently
      (LP: #619811)
    ∘ Work around bugs in signaling by delaying the destruction of menu
      caches for five seconds (LP: #718926)
    ∘ Disconnecting client signal handlers on displose (LP: #738561)
    ∘ Remove menuitem signals on root changes (LP: #743404)
 -- Ted Gould <email address hidden> Thu, 07 Apr 2011 11:01:06 -0500

Changed in indicator-appmenu (Ubuntu):
status: Fix Committed → Fix Released
Phuah Yee Keat (ykphuah) wrote :

I am still seeing this on Natty 11.04 but for Adobe Reader (since that bug have been marked duplicate of this)

Ancho (ancho-corp) wrote :

Same problems as ykphuah. Still happening with Adobe Reader

Ivan Danov (danov) wrote :

Same with me. Ubuntu Oneiric Ocelot 11.10, still happens with Adobe Reader.

chethan (pchethan) wrote :

Still reproducible on ubuntu 11.10 with acrobat reader!

edyjun75 (edyjun75) wrote :

The problem with unreadable menu bar entry with adobe reader still persist on indicator-appmenu-0.2.1-0ubuntu2, I'm using natty 11.04, please help !

Sebastien Bacher (seb128) wrote :

to the people who comment there about acroread:
- you comment on a closed bug
- you comment on a bug which is different from the one you are having (they don't affect the same software)
- you should better open a new bug with extra details on your config, what you use and what issue you get

Note that bug #664647 is mentioning acroread and might be the issue you are having

This problem is present for me in 12.10 KUBUNTU for Adobe Reader and GNU Cash.
GNU Cash has repeated menu items. In the import menu, there are about 10 submenus all showing "convert".

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions