Menu items are greyed out in Libreoffice menu.

Bug #1296715 reported by LostinSpacetime on 2014-03-24
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
indicator-appmenu (Ubuntu)
High
William Hua
libreoffice (Ubuntu)
High
Björn Michaelsen

Bug Description

[Impact]

 * Unity-only bug

[Test Case]

 * Start LibreOffice Writer
 * click menu Insert->Object->Formula
 * press Escape to leave formula mode
 * Open Insert menu
 * expected behaviour: e.g. "Insert Bookmark" is enabled
 * actual behavious: "Insert Bookmark" is disabled

[Regression Potential]

 * limited:
   - patch has been released to the LibreOffice PPA for a while without
     any negative feedback
   - changes limited to vcl (mostly gtk backend) and framework (trivial)

[Other Info]

 * original report:

After adding a formula, OLE-Object or diagram to the document and then exiting the editing mode, one cannot choose several items from the menubar, neither using a mouse or the HUD. The affected items are greyed out and mostly in the "Add" and "Format" dropdown menu. After first navigating to that item with the mouse pointer, the second time the items become available.

After deinstalling the indicator-appmenu package, the Libreoffice menu works without problems.
---
ApportVersion: 2.13.3-0ubuntu1
Architecture: amd64
CurrentDesktop: Unity
DistroRelease: Ubuntu 14.04
InstallationDate: Installed on 2013-05-03 (324 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Release amd64 (20130424)
NonfreeKernelModules: nvidia
Package: indicator-appmenu 13.01.0+14.04.20140320-0ubuntu1
PackageArchitecture: amd64
ProcVersionSignature: Ubuntu 3.13.0-19.39-generic 3.13.6
Tags: third-party-packages trusty
Uname: Linux 3.13.0-19-generic x86_64
UpgradeStatus: Upgraded to trusty on 2014-03-16 (8 days ago)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
_MarkForUpload: True

This bug is present with the Libreoffice coming with Ubuntu 14.04 (4.2.2) as well as with the version from the prerelease PPA (4.2.3 RC1).

affects: indicator-datetime (Ubuntu) → indicator-appmenu (Ubuntu)

apport information

tags: added: apport-collected third-party-packages trusty
description: updated

apport information

Without the indicator-appmenu package, the menu in Libreoffice works just fine.

The issue occurs also after adding an OLE-Object or a diagram.

Sebastien Bacher (seb128) wrote :

Thank you for your bug report, could you describe exact steps to trigger the issue (simple ones if you can)?

Changed in hud (Ubuntu):
importance: Undecided → High
Changed in indicator-appmenu (Ubuntu):
importance: Undecided → High
description: updated

1. Open a new document.
2. Add a formula to the document.
3. Exit with ESC. ->the frame of the formula is still marked
4. Click on the document or push ESC again. ->now you can edit the document
5. Click on the "Add" item from the menubar. ->several items are greyed out
6. Move the mouse to another item on the menubar and then back to "Add". ->items are available
7. Move the mouse to "Object". ->all items are greyed out
8. Move the mouse to another item on the dropdown menu and then back to Object. ->all items are available

tags: added: ubuntu-desktop-trusty
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in hud (Ubuntu):
status: New → Confirmed
Changed in indicator-appmenu (Ubuntu):
status: New → Confirmed

I don't know if it is the same issue, but I'm seeing something similar in Calc in the Format menu. If I first click on the "Cell" option, the Submenus are greyed out. If I reopen the menu then they are available. I haven't tried uninstalling indicator-appmenu.

Changed in indicator-appmenu (Ubuntu):
assignee: nobody → William Hua (attente)
Pete Woods (pete-woods) on 2014-04-04
Changed in hud (Ubuntu):
status: Confirmed → Invalid
Ted Gould (ted) wrote :
Download full text (4.9 KiB)

It looks like this is an LO issue. Looking at the example of insert table, the action is set to disabled:

$ gdbus call --session --dest :1.194 --object-path /org/libreoffice/window/88080484/menus/menubar --method org.gtk.Menus.Start [0]
([(uint32 0, uint32 0, [{':section': <(uint32 0, uint32 5)>}]), (0, 5, [{':section': <(uint32 0, uint32 6)>}]), (0, 6, [{'command': <'.uno:PickList'>, 'label': <'_File'>, 'submenu-action': <'win..uno:PickList'>, ':submenu': <(uint32 72, uint32 0)>}, {'command': <'.uno:EditMenu'>, 'label': <'_Edit'>, 'submenu-action': <'win..uno:EditMenu'>, ':submenu': <(uint32 73, uint32 0)>}, {'command': <'.uno:ViewMenu'>, 'label': <'_View'>, 'submenu-action': <'win..uno:ViewMenu'>, ':submenu': <(uint32 74, uint32 0)>}, {'command': <'.uno:InsertMenu'>, 'label': <'_Insert'>, 'submenu-action': <'win..uno:InsertMenu'>, ':submenu': <(uint32 75, uint32 0)>}, {'command': <'.uno:FormatMenu'>, 'label': <'F_ormat'>, 'submenu-action': <'win..uno:FormatMenu'>, ':submenu': <(uint32 76, uint32 0)>}, {'command': <'.uno:TableMenu'>, 'label': <'T_able'>, 'submenu-action': <'win..uno:TableMenu'>, ':submenu': <(uint32 77, uint32 0)>}, {'command': <'.uno:ToolsMenu'>, 'label': <'_Tools'>, 'submenu-action': <'win..uno:ToolsMenu'>, ':submenu': <(uint32 78, uint32 0)>}, {'command': <'.uno:WindowList'>, 'label': <'_Window'>, 'submenu-action': <'win..uno:WindowList'>, ':submenu': <(uint32 79, uint32 0)>}, {'command': <'.uno:HelpMenu'>, 'label': <'_Help'>, 'submenu-action': <'win..uno:HelpMenu'>, ':submenu': <(uint32 80, uint32 0)>}])],)
$ gdbus call --session --dest :1.194 --object-path /org/libreoffice/window/88080484/menus/menubar --method org.gtk.Menus.Start [75]
([(uint32 75, uint32 6, [{'action': <'win..uno:InsertDoc'>, 'command': <'.uno:InsertDoc'>, 'label': <'_File...'>}]), (75, 0, [{':section': <(uint32 75, uint32 1)>}, {':section': <(uint32 75, uint32 2)>}, {':section': <(uint32 75, uint32 3)>}, {':section': <(uint32 75, uint32 4)>}, {':section': <(uint32 75, uint32 5)>}, {':section': <(uint32 75, uint32 6)>}]), (75, 1, [{'action': <'win..uno:InsertBreak'>, 'command': <'.uno:InsertBreak'>, 'label': <'Manual _Break...'>}, {'command': <'.uno:FieldMenu'>, 'label': <'Fiel_ds'>, 'submenu-action': <'win..uno:FieldMenu'>, ':submenu': <(uint32 94, uint32 0)>}, {'action': <'win..uno:InsertSymbol'>, 'command': <'.uno:InsertSymbol'>, 'label': <'S_pecial Character...'>}, {'command': <'.uno:FormattingMarkMenu'>, 'label': <'Formatting Mark'>, 'submenu-action': <'win..uno:FormattingMarkMenu'>, ':submenu': <(uint32 95, uint32 0)>}]), (75, 3, [{'command': <'.uno:InsertPageHeader'>, 'label': <'He_ader'>, 'submenu-action': <'win..uno:InsertPageHeader'>, ':submenu': <(uint32 96, uint32 0)>}, {'command': <'.uno:InsertPageFooter'>, 'label': <'Foote_r'>, 'submenu-action': <'win..uno:InsertPageFooter'>, ':submenu': <(uint32 97, uint32 0)>}, {'action': <'win..uno:InsertFootnoteDialog'>, 'command': <'.uno:InsertFootnoteDialog'>, 'label': <'Footnote/Endnote_...'>}, {'action': <'win..uno:InsertCaptionDialog'>, 'command': <'.uno:InsertCaptionDialog'>, 'label': <'Caption...'>}, {'action': <'win..uno:InsertBookmark'>, 'command': <'.uno:InsertBookmark'>, 'label': <'Bookma...

Read more...

Changed in indicator-appmenu (Ubuntu):
status: Confirmed → Invalid
Changed in libreoffice (Ubuntu):
importance: Undecided → High
assignee: nobody → Björn Michaelsen (bjoern-michaelsen)
status: New → Confirmed

So looking into this is like following the white rabbit:
The g_lo_action_group and g_lo_menu from vcl/unx/gtk/window/glo{actiongroup,menu}.cxx seem fine.
The vcl menu from include/vcl/menu.hxx seems fine too.
Neither VCLXMenu from include/toolkit nor the various Menubar classes from framework/ seem to be the issue
Now at sfx2 using the "insert bookmark" entry as an example to follow:
- This is provided by the SwTextShell with SlotId:20302
- When leaving the formula mode, a new SwTextShell is instantiated and pushed on the stack of the SfxDispatcher (but only upon flush() with a timeout callback to make things more interesting to debug)

So the shell seems to be there, but doesnt claim the slot. Investigating on from here.

Please test version 1:4.2.4~rc2-0ubuntu1~trusty3 or later from https://launchpad.net/~libreoffice/+archive/ppa -- it should solve the issue.

Changed in libreoffice (Ubuntu):
status: Confirmed → Fix Committed
description: updated

the version from the ppa seems to work fine, thank you! :)

I have ubuntu 14.04 and when i want for example to UNDO something, the option is greyed out but if i move to the next tab for example from tab EDIT to VIEW and back to EDIT then the option of UNDO is clickable.

@junka: Please test the version from the ppa as suggested in comment 13.

Adolfo Jayme (fitojb) on 2014-06-09
no longer affects: hud (Ubuntu)

Hello LostinSpacetime, or anyone else affected,

Accepted libreoffice into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/libreoffice/1:4.2.4-0ubuntu2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Adam Conrad (adconrad) wrote :

Hello LostinSpacetime, or anyone else affected,

Accepted libreoffice-l10n into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/libreoffice-l10n/1:4.2.4-0ubuntu2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Looks good in 4.2.4-0ubuntu2 from -proposed.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libreoffice - 1:4.2.4-0ubuntu2

---------------
libreoffice (1:4.2.4-0ubuntu2) trusty; urgency=medium

  * bump upstream version
  * refresh patch queue
  * remove upstreamed patches:
    - fdo-74981.diff
    - fdo-50672.diff
  * bump help virtual version to 4.2
  * fix unity menu after insert formula (LP: #1296715)
  * avoid use of invalidated pointers (LP: #1219245)
  * add VBA macro patch
  * use internal npapi as this breaks with Firefox 30
 -- Bjoern Michaelsen <email address hidden> Fri, 13 Jun 2014 17:11:09 +0200

Changed in libreoffice (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers