on_indicator_menu_show() called with a NULL entry

Bug #1197071 reported by Sebastien Bacher on 2013-07-02
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Application Menu Indicator
Won't Fix
Undecided
Unassigned
Unity
Fix Released
Low
Marco Trevisan (Treviño)
indicator-appmenu (Ubuntu)
Undecided
Unassigned
unity (Ubuntu)
Undecided
Marco Trevisan (Treviño)

Bug Description

In saucy those warnings are displayed by the unity-panel-service on every alt-tab:

"Breakpoint 1, g_log (log_domain=0x0, log_level=G_LOG_LEVEL_WARNING,
    format=0x80538fc "on_indicator_menu_show() called with a NULL entry")
    at /build/buildd/glib2.0-2.37.3/./glib/gmessages.c:1021
1021 in /build/buildd/glib2.0-2.37.3/./glib/gmessages.c
#0 g_log (log_domain=0x0, log_level=G_LOG_LEVEL_WARNING,
    format=0x80538fc "on_indicator_menu_show() called with a NULL entry")
    at /build/buildd/glib2.0-2.37.3/./glib/gmessages.c:1021
#1 0xb7f7a0e5 in _indicator_object_marshal_VOID__POINTER_UINT (
    closure=0x817cb50, return_value=0x0, n_param_values=3,
    param_values=0xbfffe050, invocation_hint=0xbfffdffc, marshal_data=0x0)
    at indicator-object-marshal.c:162
#2 0xb76789ce in g_closure_invoke (closure=0x817cb50,
    return_value=return_value@entry=0x0, n_param_values=3,
    param_values=param_values@entry=0xbfffe050,
    invocation_hint=invocation_hint@entry=0xbfffdffc)
    at /build/buildd/glib2.0-2.37.3/./gobject/gclosure.c:777
#3 0xb768c029 in signal_emit_unlocked_R (node=node@entry=0x81486d0, detail=0,
    instance=0x8184048, emission_return=emission_return@entry=0x0,
    instance_and_params=0xbfffe050)
    at /build/buildd/glib2.0-2.37.3/./gobject/gsignal.c:3582
#4 0xb7693dc9 in g_signal_emit_valist (instance=instance@entry=0x8184048,
    signal_id=signal_id@entry=224, detail=detail@entry=0,
    var_args=0xbfffe240 "", var_args@entry=0xbfffe238 "")
    at /build/buildd/glib2.0-2.37.3/./gobject/gsignal.c:3326
#5 0xb76944d1 in g_signal_emit_by_name (instance=0x8184048,
    detailed_signal=detailed_signal@entry=0xb579012d "menu-show")
    at /build/buildd/glib2.0-2.37.3/./gobject/gsignal.c:3422
#6 0xb5788e05 in window_show_menu (mw=0x0, entry=entry@entry=0x0,
    timestamp=0, user_data=user_data@entry=0x8184048)
    at indicator-appmenu.c:1359
#7 0xb5788f25 in switch_active_window (iapp=iapp@entry=0x8184048,
    active_window=active_window@entry=0x806f2e8) at indicator-appmenu.c:894
#8 0xb57891a5 in switch_default_app (iapp=0x8184048, newdef=0x8194db8,
    active_window=0x806f2e8) at indicator-appmenu.c:978
#9 0xb6fee48e in ffi_call_SYSV () from /usr/lib/i386-linux-gnu/libffi.so.6
#10 0xb6fee1ef in ffi_call () from /usr/lib/i386-linux-gnu/libffi.so.6
#11 0xb76795b1 in g_cclosure_marshal_generic_va (closure=0x8186dd8,
    return_value=0x0, instance=0x8133110, args_list=0xbfffe5ec "",
    marshal_data=0x0, n_params=2, param_types=0x81a38d8)
    at /build/buildd/glib2.0-2.37.3/./gobject/gclosure.c:1550
#12 0xb7678c0e in _g_closure_invoke_va (closure=closure@entry=0x8186dd8,
    return_value=return_value@entry=0x0, instance=instance@entry=0x8133110,
    args=args@entry=0xbfffe5ec "", n_params=2, param_types=0x81a38d8)
    at /build/buildd/glib2.0-2.37.3/./gobject/gclosure.c:840
#13 0xb769388d in g_signal_emit_valist (instance=instance@entry=0x8133110,
    signal_id=signal_id@entry=248, detail=detail@entry=0,
    var_args=var_args@entry=0xbfffe5ec "")
    at /build/buildd/glib2.0-2.37.3/./gobject/gsignal.c:3234
#14 0xb7694013 in g_signal_emit (instance=instance@entry=0x8133110,
    signal_id=248, detail=detail@entry=0)
    at /build/buildd/glib2.0-2.37.3/./gobject/gsignal.c:3382
#15 0xac7be2d0 in bamf_matcher_on_active_window_changed (proxy=0x80b6998,
    old_path=0x814ab70 "",
    new_path=0x8150a78 "/org/ayatana/bamf/window73400367", matcher=0x8133110)
    at bamf-matcher.c:199
#16 0xb6fee48e in ffi_call_SYSV () from /usr/lib/i386-linux-gnu/libffi.so.6
#17 0xb6fee1ef in ffi_call () from /usr/lib/i386-linux-gnu/libffi.so.6
#18 0xb7679249 in g_cclosure_marshal_generic (closure=0x8187038,
    return_gvalue=0x0, n_param_values=3, param_values=0x8149e80,
    invocation_hint=0xbfffe85c, marshal_data=0x0)
    at /build/buildd/glib2.0-2.37.3/./gobject/gclosure.c:1454
#19 0xb76789ce in g_closure_invoke (closure=0x8187038,
    return_value=return_value@entry=0x0, n_param_values=3,
    param_values=param_values@entry=0x8149e80,
    invocation_hint=invocation_hint@entry=0xbfffe85c)
    at /build/buildd/glib2.0-2.37.3/./gobject/gclosure.c:777
#20 0xb768c029 in signal_emit_unlocked_R (node=node@entry=0x8178c70,
    detail=detail@entry=0, instance=instance@entry=0x80b6998,
    emission_return=emission_return@entry=0x0,
    instance_and_params=instance_and_params@entry=0x8149e80)
    at /build/buildd/glib2.0-2.37.3/./gobject/gsignal.c:3582
#21 0xb7692ea0 in g_signal_emitv (
    instance_and_params=instance_and_params@entry=0x8149e80, signal_id=264,
    detail=detail@entry=0, return_value=return_value@entry=0x0)
    at /build/buildd/glib2.0-2.37.3/./gobject/gsignal.c:3059
#22 0xac7c87e9 in _bamf_dbus_matcher_proxy_g_signal (proxy=0x80b6998,
    sender_name=0x814eb30 ":1.8", signal_name=0x8150830 "ActiveWindowChanged",
    parameters=0x81f4148) at bamf-gdbus-generated.c:4502
#23 0xb6fee48e in ffi_call_SYSV () from /usr/lib/i386-linux-gnu/libffi.so.6
#24 0xb6fee1ef in ffi_call () from /usr/lib/i386-linux-gnu/libffi.so.6
#25 0xb7679249 in g_cclosure_marshal_generic (closure=0x8090918,
    return_gvalue=0x0, n_param_values=4, param_values=0xbfffec90,
    invocation_hint=0xbfffec3c,
    marshal_data=0xac7c86a0 <_bamf_dbus_matcher_proxy_g_signal>)
    at /build/buildd/glib2.0-2.37.3/./gobject/gclosure.c:1454
#26 0xb76774f4 in g_type_class_meta_marshal (closure=0x8090918,
    return_value=0x0, n_param_values=4, param_values=0xbfffec90,
    invocation_hint=0xbfffec3c, marshal_data=0x48)
    at /build/buildd/glib2.0-2.37.3/./gobject/gclosure.c:970
#27 0xb76789ce in g_closure_invoke (closure=closure@entry=0x8090918,
    return_value=return_value@entry=0x0, n_param_values=4,
    param_values=param_values@entry=0xbfffec90,
    invocation_hint=invocation_hint@entry=0xbfffec3c)
    at /build/buildd/glib2.0-2.37.3/./gobject/gclosure.c:777
#28 0xb768bc80 in signal_emit_unlocked_R (node=node@entry=0x8090958, detail=0,
    instance=0x80b6998, emission_return=emission_return@entry=0x0,
    instance_and_params=0xbfffec90)
    at /build/buildd/glib2.0-2.37.3/./gobject/gsignal.c:3620
#29 0xb7693dc9 in g_signal_emit_valist (instance=instance@entry=0x80b6998,
    signal_id=signal_id@entry=147, detail=detail@entry=0,
    var_args=0xbfffee08 "0\234~\254", var_args@entry=0xbfffedfc "\030x")
    at /build/buildd/glib2.0-2.37.3/./gobject/gsignal.c:3326
#30 0xb7694013 in g_signal_emit (instance=instance@entry=0x80b6998,
    signal_id=147, detail=detail@entry=0)
    at /build/buildd/glib2.0-2.37.3/./gobject/gsignal.c:3382
#31 0xb77b5e72 in on_signal_received (connection=0x80ae070,
    sender_name=0xb6007818 ":1.8",
    object_path=0xb600b9f0 "/org/ayatana/bamf/matcher",
    interface_name=0xb600bd68 "org.ayatana.bamf.matcher",
    signal_name=0xb600b738 "ActiveWindowChanged", parameters=0x81f4148,
    user_data=0x8175d10) at /build/buildd/glib2.0-2.37.3/./gio/gdbusproxy.c:925
#32 0xb77a4656 in emit_signal_instance_in_idle_cb (data=data@entry=0xb600a878)
    at /build/buildd/glib2.0-2.37.3/./gio/gdbusconnection.c:3743
#33 0xb75aa1e0 in g_idle_dispatch (source=source@entry=0xb6006a90,
    callback=0xb77a45c0 <emit_signal_instance_in_idle_cb>,
    user_data=0xb600a878) at /build/buildd/glib2.0-2.37.3/./glib/gmain.c:5235
#34 0xb75ad4de in g_main_dispatch (context=0x8097bb8, context@entry=0x809b888)
    at /build/buildd/glib2.0-2.37.3/./glib/gmain.c:3058
#35 g_main_context_dispatch (context=context@entry=0x8097bb8)
    at /build/buildd/glib2.0-2.37.3/./glib/gmain.c:3634
#36 0xb75ad888 in g_main_context_iterate (context=0x8097bb8,
    block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>)
    at /build/buildd/glib2.0-2.37.3/./glib/gmain.c:3705
#37 0xb75adceb in g_main_loop_run (loop=loop@entry=0x81eb210)
    at /build/buildd/glib2.0-2.37.3/./glib/gmain.c:3899
#38 0xb7aa1ccd in gtk_main ()
    at /build/buildd/gtk+3.0-3.8.2/./gtk/gtkmain.c:1156
#39 0x0804b8ab in main ()"

Related branches

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-appmenu (Ubuntu):
status: New → Confirmed
Haw Loeung (hloeung) wrote :

It seems to be more of when focus shifts between windows / applications rather than alt-tab.

I have two terminal sessions opened up side by side with focus-follows-mouse. I'm seeing these warnings whenever I move between the two terminals.

Haw Loeung (hloeung) wrote :

unity-services:
  Installed: 7.0.2+13.10.20130705.1-0ubuntu1
  Candidate: 7.0.2+13.10.20130705.1-0ubuntu1
  Version table:
 *** 7.0.2+13.10.20130705.1-0ubuntu1 0
        500 http://archive.ubuntu.com/ubuntu/ saucy/main amd64 Packages
        100 /var/lib/dpkg/status

Haw Loeung (hloeung) on 2013-07-12
Changed in unity (Ubuntu):
status: New → Confirmed
Haw Loeung (hloeung) wrote :

The relevant bits of code:

indicator-appmenu/src/indicator-appmenu.c switch_active_window() :

        /* Close any existing open menu by showing a null entry */
        window_show_menu(iapp->default_app, NULL, gtk_get_current_event_time(), iapp);

unity/services/panel-service.c on_indicator_menu_show():

  g_return_if_fail (PANEL_IS_SERVICE (self));
  if (entry == NULL)
    {
      g_warning ("on_indicator_menu_show() called with a NULL entry");
      return;
    }

Doesn't seem to like it when the entry is NULL.

Changed in indicator-appmenu:
status: New → Won't Fix
Changed in unity:
status: New → In Progress
importance: Undecided → Medium
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
milestone: none → 7.1.1
importance: Medium → Low
Changed in indicator-appmenu (Ubuntu):
status: Confirmed → Invalid
Changed in unity (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:unity at revision 3551, scheduled for release in unity, milestone 7.1.1

Changed in unity:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.1.1+13.10.20131004-0ubuntu1

---------------
unity (7.1.1+13.10.20131004-0ubuntu1) saucy; urgency=low

  [ Brandon Schaefer ]
  * Break the bump detection by moving to the first icon, then down 5
    pixels. Since bump detection needs to move in 3 different
    directions.
  * Move the switcher Alt+<ArrowKey> shortcut handling into nux, from
    compiz. Now nux handles these events instead of compiz. This way its
    makes much more sense code wise and we no longer ungrab the arrow
    gets from X... so Alt+LeftArrow will no longer open the hud. (LP:
    #969039)

  [ Andrea Azzarone ]
  * Fix bad redrawing of dash overlay scrollbar connector. (LP:
    #1233195)
  * Update icon_under_mouse before process mouse movemnt in the tooltip
    manager. (LP: #1172769, #1233666)
  * Hide the tooltip when an app is closed. (LP: #1172769)

  [ Marco Trevisan (Treviño) ]
  * TestIMTextEntry: fix failing tests with IBus, use TEST_F and TEST_P.
  * CairoBaseWindow: only regenerate blur texture when visible and
    damaged. (LP: #1233109)
  * CairoBaseWindow: add fade animator to control both QL and Tooltip
    Removing the animator from LauncherIcon, and handling the tooltip
    animation inside the QL and Tooltip base class.
  * PanelService: close a menu and re-send the keyevent when handling a
    combination Or when we try to open HUD/Dash. Also, close the active
    menu if a new application is opened and focused. (LP: #10905,
    #1234457, #1197071)
  * SimpleLauncherIcon: we need to restore the focus when closing the
    Overlay for activation. (LP: #909870)
  * LauncherIcon: don't try to show again quicklists or tooltip if
    center changed, just move them. (LP: #1234778)
  * AbstractLauncherIcon: add static icon_size property. (LP: #1073103)

  [ Christopher Lee ]
  * Preparing autopilot tests for an upcoming update in autopilot 1.3.

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 3554
 -- Ubuntu daily release <email address hidden> Fri, 04 Oct 2013 05:23:43 +0000

Changed in unity (Ubuntu):
status: In Progress → Fix Released
Stephen M. Webb (bregma) wrote :

Fix Released in Nux Unity 7.1.1.

Changed in unity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers