Tomboy does not start, indicator-application version skew

Bug #636132 reported by igi on 2010-09-12
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
indicator-application (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: tomboy

Tomboy does not start: neither at logon (it is set to start automatically in my startup list) or by menu command.

Trying to lauch it from terminal, this is what I get:
_________________________________________
Unhandled Exception: System.TypeInitializationException: An exception was thrown by the type initializer for AppIndicator.ApplicationIndicator ---> System.DllNotFoundException: libappindicator.so.0
  at (wrapper managed-to-native) AppIndicator.ApplicationIndicator:app_indicator_get_type ()
  at AppIndicator.ApplicationIndicator.get_GType () [0x00000] in <filename unknown>:0
  at GtkSharp.AppindicatorSharp.ObjectManager.Initialize () [0x00000] in <filename unknown>:0
  at AppIndicator.ApplicationIndicator..cctor () [0x00000] in <filename unknown>:0
  --- End of inner exception stack trace ---
  at Tomboy.TomboyIndicatorTray..ctor (Tomboy.NoteManager manager) [0x00000] in <filename unknown>:0
  at Tomboy.Tomboy.StartTrayIcon () [0x00000] in <filename unknown>:0
  at Tomboy.Tomboy.Main (System.String[] args) [0x00000] in <filename unknown>:0
_________________________________________

So it seems to be related to the Indicator applet (I oftenly get indicator-applet crashes at logon in Maverick beta).

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: tomboy 1.3.2-1ubuntu4
ProcVersionSignature: Ubuntu 2.6.35-20.29-generic 2.6.35.4
Uname: Linux 2.6.35-20-generic i686
Architecture: i386
Date: Sun Sep 12 04:18:02 2010
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
ProcEnviron:
 PATH=(custom, no user)
 LANG=it_IT.utf8
 SHELL=/bin/bash
SourcePackage: tomboy

Related branches

igi (igor-cali) wrote :
Jeff Waugh (jdub) wrote :

Tomboy runs fine on a number of my other machines (i686, but as was the initial reporter's machine), but on my main desktop box which has been upgraded since forever (probably warty), I see the same failure. Here are my package versions:

jdub@sliver:~$ dpkg -l | grep libappind
ii libappindicator0.1-cil 0.2.8-0ubuntu1 CLI bindings for libappindicator
ii libappindicator1 0.2.8-0ubuntu1 Application Indicators
ii python-appindicator 0.2.8-0ubuntu1 Python bindings for libappindicator

Notably, I have libappindicator1 (which unsurprisingly contains the .so.1 library), but the -cil library of the same version is trying to load .so.0. I've done an apt-get install --reinstall just in case it was something to do with .net assembly installation, but it seems not.

Jeff Waugh (jdub) wrote :

On further investigation, it's definitely a problem with indicator-application.

summary: - Tomboy does not start
+ Tomboy does not start, indicator-application version skew
affects: tomboy (Ubuntu) → indicator-application (Ubuntu)
Changed in indicator-application (Ubuntu):
status: New → Confirmed
Jeff Waugh (jdub) wrote :

Further investigation:
 * My other machines have libappindicator0=0.2.3-0ubuntu2 installed.
 * libappindicator0.1-cil does not depend on libappindicatorN at all, but should.
 * libappindicator0.1-cil should be updated to dlopen libappindicator1.

Jo Shields (directhex) wrote :

bindings/mono/appindicator-sharp.dll.config.in hard-codes the expected SONAME to 0 - it should follow the SONAME via autohell magicks, or hard-code to 1.

bindings/mono/appindicator-sharp.dll.config.in tries to map appindicator-sharp.dll to libappindicator.so.X - it should be appindicator.dll (or whatever you would call the C library in a Windows port of indicator-application) that is bound

bindings/mono/ApplicationIndicator.custom and
bindings/mono/app-indicator.sources.xml specifically name libappindicator.so.0 as the lib to import - this should be appindicator.dll (or whatever name you picked in the step above)

Those three bugs fixed should clean up the issue,

Jo Shields (directhex) wrote :

Please try the indicator-application packages on https://launchpad.net/~directhex/+archive/monoxide/+packages

igi (igor-cali) wrote :

#directhex: I have installed updates on your PPA. It works now. I'll propose for merging.

Changed in indicator-application (Ubuntu):
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-application - 0.2.9-0ubuntu1

---------------
indicator-application (0.2.9-0ubuntu1) maverick; urgency=low

  [ Ted Gould ]
  * New upstream release.
    * Fix Mono binding versioning and build (LP: #636132)
    * Fix submenus with Glade applications (LP: #608219)
    * Add new functions to Mono and Python bindings
  * debian/libappindicator0.1-cil.installcligac: Add the 0.1
    policy file.

  [ Didier Roche ]
  * debian/control:
    - build with latest libindicator-dev for ABI breakage (LP: #637692)
 -- Didier Roche <email address hidden> Wed, 22 Sep 2010 20:01:04 +0200

Changed in indicator-application (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers