Keyboard layout part of indicator applet disappears

Bug #621838 reported by Vladimir Savic on 2010-08-21
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Application Indicators
Fix Released
Medium
Ted Gould
Ayatana Ubuntu
Medium
Ted Gould
indicator-application (Ubuntu)
High
Canonical Desktop Experience Team

Bug Description

Binary package hint: indicator-applet

I can't really figure out under what circumstances applet disappears. It really puzzles me...
Vanishing act seems to happen at random times without crash notice. Unfortunately, the only proof I have is a screenshot.

Related branches

It's not random!
Keyboard layout indicator disappears with "key" icon (is it called gnome keyring?) after update manager is closed. I have no idea if it matters - since I use Maverick, I'm not waiting for Update Manager show me there are updates. Usually, I start update manager on my own at random times at day.

Nope. Looks like this isn't dupe since what you marked "Fix released" (bug #623205) doesn't fix my problem. I still observe "vanishing act" after upgrade.

Thank you for your time.

Krzysztof Klimonda (kklimonda) wrote :

Unmarking it as a duplicate of 623205 as the problem hasn't been fixed with 0.2.6 release.. probably should be reassigned to indicator-application?

Changed in indicator-applet (Ubuntu):
status: New → Confirmed
David Barth (dbarth) wrote :

Karl: can you investigate that bug for now? Thanks.

Changed in indicator-applet:
assignee: nobody → Karl Lattimer (karl-qdh)
importance: Undecided → Medium
milestone: none → ubuntu-10.10
Sebastien Bacher (seb128) wrote :

The issue is not specific to the keyboard layout, the libappindicator users just drop of the applet sometimes

affects: indicator-applet (Ubuntu) → indicator-application (Ubuntu)
Changed in indicator-application (Ubuntu):
importance: Undecided → High
assignee: nobody → Canonical Desktop Experience Team (canonical-dx-team)
Sebastien Bacher (seb128) wrote :

it seems to happen for example when closing update-manager, the other icons get dropped at the same time the polkit one is

David Barth (dbarth) wrote :

Seems the issue is really with the indicator itself, as clarified by seb128.
Ted: i think then it's more up to you to investigate it further.

Changed in indicator-applet:
assignee: Karl Lattimer (karl-qdh) → Ted Gould (ted)
Ted Gould (ted) wrote :

Okay, it appears to be because the service is sending the removal signal 3 times for the indicator sometimes.

2322 signal sender=:1.76 -> dest=(null destination) serial=221 path=/org/ayatana/indicator/application/service; interface=org.ayatana.indicator.application.service; member=ApplicationRemoved
2323 int32 2
2324 signal sender=:1.76 -> dest=(null destination) serial=222 path=/org/ayatana/indicator/application/service; interface=org.ayatana.indicator.application.service; member=ApplicationRemoved
2325 int32 2
2326 signal sender=:1.76 -> dest=(null destination) serial=223 path=/org/ayatana/indicator/application/service; interface=org.ayatana.indicator.application.service; member=ApplicationRemoved
2327 int32 2

Ted Gould (ted) on 2010-09-07
affects: indicator-applet → indicator-application
Changed in indicator-application:
milestone: ubuntu-10.10 → none
Changed in ayatana-ubuntu:
milestone: none → ubuntu-10.10
assignee: nobody → Ted Gould (ted)
status: New → Confirmed
Changed in indicator-application:
status: New → Confirmed
Changed in ayatana-ubuntu:
importance: Undecided → Medium
Ted Gould (ted) on 2010-09-08
Changed in indicator-application:
milestone: none → 0.2.7
status: Confirmed → In Progress
Changed in ayatana-ubuntu:
status: Confirmed → In Progress
Ted Gould (ted) on 2010-09-09
Changed in indicator-application:
status: In Progress → Fix Released
Changed in ayatana-ubuntu:
status: In Progress → Fix Released

Released fix works for me!
Thank you

Ted Gould (ted) on 2010-09-16
Changed in indicator-application (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments