no more icon update taken into account

Bug #594199 reported by Didier Roche on 2010-06-14
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Application Indicators
Fix Released
Medium
Cody Russell
indicator-application (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: indicator-application

On maverick, with indicator-application 0.2.0-0ubuntu2, there is no icon change state taken into account.

This happens as well with rhythmbox (when you click on play) than on python binding.
Little script from seb128 to test it: http://paste.ubuntu.com/449686/

Related branches

Didier Roche (didrocks) on 2010-06-14
Changed in indicator-application (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
Changed in indicator-application:
status: New → Triaged
importance: Undecided → Medium
David Barth (dbarth) wrote :

It's a maverick regression. I'm up to date on Lucid, including all new dbusmenu libs from the daily.
But the fact that it's broken with both python, mono and C apps (RB) indicates that this is more on the library side than the bindings themselves.

David Barth (dbarth) wrote :

A newer version of GTK combined with the latest indicator code may be the cause. Hence, assigning to Cody.

Changed in indicator-application:
assignee: nobody → Cody Russell (bratsche)
Ted Gould (ted) on 2010-06-18
Changed in indicator-application:
status: Triaged → Fix Committed
milestone: none → 0.2.1
Changed in indicator-application (Ubuntu):
status: Triaged → Fix Committed
Ted Gould (ted) on 2010-06-21
Changed in indicator-application:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-application - 0.2.1-0ubuntu1

---------------
indicator-application (0.2.1-0ubuntu1) maverick; urgency=low

  [ Ted Gould ]
  * New upstream release.
    * Fix icon updating (LP: #594199)
    * Change Mono bindings to only parse particular files (LP: #592706)
    * Make a policy for migrating the mono bindings
    * Test fixes to make them more reliable
  * debian/control: Fixing version numbers
  * debian/control: Making the 0.1-cil replace and provide the 0.0-cil
  * debian/libappindicator0.1-cil.installcligac: Add the policy.dll
    file to the install.

  [Ken VanDine]
  * renamed cil binary to libappindicator0.1 to match the assembly
    version (LP: #592706)
 -- Didier Roche <email address hidden> Tue, 22 Jun 2010 09:31:43 +0200

Changed in indicator-application (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers