apps using the mono bindings fail to load

Bug #592706 reported by Ken VanDine on 2010-06-11
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Application Indicators
Fix Released
High
Unassigned
indicator-application (Ubuntu)
High
Unassigned
tomboy (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: indicator-application

Tomboy built against libappindicator0.1-cil fails to load with the following exception:

Unhandled Exception: System.TypeInitializationException: An exception was thrown by the type initializer for AppIndicator.ApplicationIndicator ---> System.EntryPointNotFoundException: app_lru_file_get_type
  at (wrapper managed-to-native) AppIndicator.AppLruFile:app_lru_file_get_type ()
  at AppIndicator.AppLruFile.get_GType () [0x00000]
  at GtkSharp.AppindicatorSharp.ObjectManager.Initialize () [0x00000]
  at AppIndicator.ApplicationIndicator..cctor () [0x00000]
  --- End of inner exception stack trace ---
  at Tomboy.TomboyIndicatorTray..ctor (Tomboy.NoteManager manager) [0x00000]
  at Tomboy.Tomboy.StartTrayIcon () [0x00000]
  at Tomboy.Tomboy.Main (System.String[] args) [0x00000]

This is caused by the use of appindicator-0.0 instead of appindicator-0.1 at some places and by the move of the library files to a different directory in the source code, making them unfindable for the GAPI parser. Two branches are associated with this bug that fix those two issues.

Related branches

Changed in indicator-application:
importance: Undecided → High
Sense Egbert Hofstede (sense) wrote :

This is probably related to the fact that it seems that the libappindicator0.1-cil package seems to be putting everything in directories called 'appindicator-sharp-0.0' whereas the Makefiles and the .pc file points to 'appindicator-sharp-0.1'.

The packaging and the source code seem to have diverged a bit when the packaging was fixed in order to comply to the Debian CLI Policy. I'm not sure what would be the best way to fix it -- presumably something in the packaging needs to be changed -- but the best people to ask this would probably be Jo Shields or Chow Loong Jin.

Didier Roche (didrocks) wrote :

This breaks banshee as well

Changed in indicator-application:
status: New → Triaged
Changed in indicator-application (Ubuntu):
importance: Undecided → High
status: New → Triaged
Ken VanDine (ken-vandine) wrote :

lp:~ubuntu-desktop/indicator-application/ubuntu fixes the part of the problem, bumps the package to 0.1 and finds the dll. However tomboy still fails to start, but it doesn't blow up immediately anymore.

Jo Shields (directhex) wrote :

At a glance, the exception looks like the C library has changed ABI (i.e. the binding is for the earlier version of the lib, which wasn't SONAME-bumped) and simply needs rebuilding. But I could be wrong.

description: updated
Ted Gould (ted) on 2010-06-18
Changed in indicator-application:
status: Triaged → Fix Committed
Changed in tomboy (Ubuntu):
status: New → Invalid
Changed in indicator-application:
milestone: none → 0.2.1
Ted Gould (ted) on 2010-06-21
Changed in indicator-application:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-application - 0.2.1-0ubuntu1

---------------
indicator-application (0.2.1-0ubuntu1) maverick; urgency=low

  [ Ted Gould ]
  * New upstream release.
    * Fix icon updating (LP: #594199)
    * Change Mono bindings to only parse particular files (LP: #592706)
    * Make a policy for migrating the mono bindings
    * Test fixes to make them more reliable
  * debian/control: Fixing version numbers
  * debian/control: Making the 0.1-cil replace and provide the 0.0-cil
  * debian/libappindicator0.1-cil.installcligac: Add the policy.dll
    file to the install.

  [Ken VanDine]
  * renamed cil binary to libappindicator0.1 to match the assembly
    version (LP: #592706)
 -- Didier Roche <email address hidden> Tue, 22 Jun 2010 09:31:43 +0200

Changed in indicator-application (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers