Toggle state of 'toggle-main-window' not updated when window is shown after launch with running instance

Bug #564526 reported by Xhacker Liu on 2010-04-16
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Application Indicators
Invalid
Undecided
Unassigned
Transmission
Fix Released
Unknown
indicator-application (Ubuntu)
Undecided
Unassigned
Lucid
Undecided
Unassigned
transmission (Ubuntu)
Low
Krzysztof Klimonda
Lucid
Low
Krzysztof Klimonda

Bug Description

If you launch Transmission --via e.g. a starter -- when an instance is already running the window is raised. However, the state of the 'toggle-main-window' action, used by the GtkStatusIcon and the Application Indicator, isn't updated when the window was previously minimised to the tray.

Binary package hint: indicator-application

0.My English is not good enough to express the bug. So, please look at the video.

1.Now ererything is good. I am toggling Transmission.

2.And then press the Transmission panel icon...

3.Transmission appears.

4.But "Display Transmission" in the appindicator not checked.

5.Click "Display Transmission".

6.Now checked, but no Transmission.

I'm attaching a video...

Xhacker Liu (xhacker) wrote :
Krzysztof Klimonda (kklimonda) wrote :

Thank you for your report, I'm going to mark the transmission task as Confirmed for the time being as I was able to reproduce it myself but I'm not sure whether this is a bug in transmission itself or in the indicator-application.
It is most likely not going to get fixed in Lucid as the bug is a small one and we are already past the Final Freeze.

Changed in transmission (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
Charles Kerr (charlesk) wrote :

Sense, since you wrote this patch and since I don't currently have easy access to a 10.04 box, could you look into this?

tags: added: indicator-application
Sense Egbert Hofstede (sense) wrote :

Thank you for illustrating this bug with a video, it made the issue very clear.

The bug is caused by the fact that on hide and show events that are not caused by interaction with the icon the toggle state of the menu item doesn't change. I'll write a patch to fix this issue.

Changed in indicator-application:
status: New → Invalid
Changed in indicator-application (Ubuntu):
status: New → Invalid
Changed in transmission (Ubuntu):
assignee: nobody → Sense Hofstede (qense)
status: Confirmed → In Progress
Sense Egbert Hofstede (sense) wrote :

I'm attaching a one line patch that fixes this issue.

summary: - Toggle Transmission's display behave wrong
+ Toggle state of 'toggle-main-window' not updated when window is shown
+ after launch with running instance
description: updated
Changed in transmission (Ubuntu):
assignee: Sense Hofstede (qense) → nobody
status: In Progress → Triaged
Sense Egbert Hofstede (sense) wrote :
Changed in transmission:
status: Unknown → New
Changed in transmission:
status: New → Fix Released

Accepted transmission into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in transmission (Ubuntu):
assignee: nobody → Krzysztof Klimonda (kklimonda)
Changed in transmission (Ubuntu Lucid):
status: Triaged → Fix Committed
tags: added: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package transmission - 1.92-0ubuntu2.1

---------------
transmission (1.92-0ubuntu2.1) lucid-proposed; urgency=low

  * Fix the indicator status menu item so it always reflects the Transmission
    window's status. (LP: #564526)
 -- Krzysztof Klimonda <email address hidden> Wed, 28 Apr 2010 08:27:35 +0200

Changed in transmission (Ubuntu Lucid):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Copied lucid-proposed to maverick.

Changed in transmission (Ubuntu):
status: Fix Committed → Fix Released
Changed in transmission (Ubuntu Lucid):
status: Fix Released → Fix Committed

I can confirm that this is fixed with the Transmission Package from Proposed.

Martin Pitt (pitti) on 2010-05-04
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package transmission - 1.92-0ubuntu2.1

---------------
transmission (1.92-0ubuntu2.1) lucid-proposed; urgency=low

  * Fix the indicator status menu item so it always reflects the Transmission
    window's status. (LP: #564526)
 -- Krzysztof Klimonda <email address hidden> Wed, 28 Apr 2010 08:27:35 +0200

Changed in transmission (Ubuntu Lucid):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.