libappindicator-cil-dev's .pc file points to the wrong place

Bug #564506 reported by Chow Loong Jin
92
This bug affects 16 people
Affects Status Importance Assigned to Milestone
banshee-community-extensions (Ubuntu)
Undecided
Chow Loong Jin
indicator-application (Ubuntu)
Critical
Unassigned

Bug Description

Banshee Community Extensions currently FTBFS due to the indicator-application's
.pc file pointing to the wrong place. As a result, all appications which use
appindicator-sharp-0.1.pc will fail to build. I will attach a patch shortly to
fix this.

  affects ubuntu/indicator-application
  importance critical
  assignee hyperair
  status inprogress

--
Kind regards,
Chow Loong Jin (GPG: 0x8F02A411)
Ubuntu Developer

Related branches

Revision history for this message
Chow Loong Jin (hyperair) wrote :
Changed in indicator-application (Ubuntu):
milestone: none → ubuntu-10.04
Revision history for this message
Jo Shields (directhex) wrote :

This patch completes a large number of fixups on indicator-application, including this one.

* CLI policy compatible install location and package names
* Fix pcfile
* Insert correct rule dependencies in debian/rules to make sure dh_makeshlibs on libappindicator0 happens before dh_clideps on libappindicator0.0-cil (removes need for manual dependency). Also, version the dependency so packages built against (and needing) libappindicator0 will version that dependency automatically

The build-deps in banshee-community-extensions will need to be tweaked due to including the API version in the package file containing the API-versioned pcfile (the alternative is to remove the version from both package name and pcfile name, but as per policy, it must match).

Jo Shields (directhex)
Changed in indicator-application (Ubuntu):
status: In Progress → Confirmed
Changed in indicator-application (Ubuntu):
status: Confirmed → Triaged
Changed in banshee-community-extensions (Ubuntu):
status: New → Triaged
assignee: nobody → Chow Loong Jin (hyperair)
Changed in indicator-application (Ubuntu):
assignee: Chow Loong Jin (hyperair) → nobody
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package banshee-community-extensions - 1.6.0-1ubuntu4

---------------
banshee-community-extensions (1.6.0-1ubuntu4) lucid; urgency=low

  * debian/control:
    + Build-dep on libappindicator0.1-cil-dev instead, due to adding of
      the API version number into the name of the package (LP: #564506)
 -- Chow Loong Jin <email address hidden> Sat, 17 Apr 2010 14:55:24 +0800

Changed in banshee-community-extensions (Ubuntu):
status: Triaged → Fix Released
Revision history for this message
Jack Deslippe (jdeslip) wrote :

Are the lubuntu4 packages supposed to be available? I don't see them in my synaptic and still have this bug. lubuntu2 is the latest version I see.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-application - 0.0.19-0ubuntu4

---------------
indicator-application (0.0.19-0ubuntu4) lucid; urgency=low

  * bindings/mono/appindicator-sharp-0.1.pc.in:
    + Fix pcfile to point to library install location (LP: #564506)
  * debian/control,
    debian/libappindicator0-cil.install,
    debian/libappindicator0-cil.installcligac,
    debian/libappindicator-cil-dev.install,
    debian/libappindicator0.0-cil.install,
    debian/libappindicator0.0-cil.installcligac,
    debian/libappindicator0.1-cil-dev.install:
    + Rename packages to comply with Debian CLI policy
  * debian/libappindicator0.0-cil.install,
    debian/libappindicator0.0-cil.installcligac:
    + Fix library install location to comply with Debian CLI policy
  * debian/control,
    debian/rules:
    + Pass CSC variable to use mono-csc default compiler from mono-devel
      2.4.3, rather than the default 2.0-only compiler
  * debian/rules:
    + Fix processing of rules to track dependency information on Mono
      binding, by running rules in correct order
 -- Jo Shields <email address hidden> Fri, 16 Apr 2010 10:42:48 +0100

Changed in indicator-application (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers