icons not aligned in the indicator

Bug #519804 reported by Luca Ferretti on 2010-02-10
94
This bug affects 17 people
Affects Status Importance Assigned to Milestone
indicator-application (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: rhythmbox

The new menu showed clicking on Rhythmbox notification icon has bad labels/icons alignment and doesn't follow the other GTK+ plain menus.

Here is attached a picture about current appearance and how it should be. However I think this is not a Rhythmbox only related issue, but more generally to all libindicate based notification icons. Please note that in order to show an icon for a menu entry overriding the current "no icons in menu" default in GNOME, should be used the gtk-image-menu-item-set-always-show-image() function[1] (or similar other)

[1] http://library.gnome.org/devel/gtk/stable/GtkImageMenuItem.html#gtk-image-menu-item-set-always-show-image

ProblemType: Bug
Architecture: i386
Date: Wed Feb 10 13:37:07 2010
DistroRelease: Ubuntu 10.04
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20100113)
Package: rhythmbox 0.12.6-1ubuntu8
ProcEnviron:
 LANGUAGE=it_IT.utf8
 LANG=it_IT.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-12.17-generic
SourcePackage: rhythmbox
Uname: Linux 2.6.32-12-generic i686

Luca Ferretti (elle.uca) wrote :
Pedro Villavicencio (pedro) wrote :

Thanks for the report Luca, confirming, same issue here.

summary: - Wrong icons appearance in notification icon menu
+ icons not aligned in the indicator
Changed in rhythmbox (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
status: New → Confirmed
Omer Akram (om26er) wrote :

This is the expected/default behavior for all applications using indicator-application

Changed in rhythmbox (Ubuntu):
status: Confirmed → Invalid
Dylan McCall (dylanmccall) wrote :

Omer, this is NOT the proper behaviour.

See this document, which clearly specifies that the current appearance is incorrect. There is a mockup of what the correct implementation should be:

https://wiki.ubuntu.com/CustomStatusMenuDesignGuidelines

Curiously, the prominently labelled misbehaviour has propagated to other indicators. I'm happy to work on this if it's necessary (and if I have the time). Do we need some kind of "always-show-icon" flag for these to be passed over dbus? (To fit with how GNOME normally does menu icons these days).

Changed in rhythmbox (Ubuntu):
status: Invalid → Confirmed
Sebastien Bacher (seb128) wrote :

the issue there is an indicator one not a bug in rhythmbox

affects: rhythmbox (Ubuntu) → indicator-application (Ubuntu)
Changed in indicator-application (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
Matthew Paul Thomas (mpt) wrote :

Thanks for the report, but this change is deliberate. <https://wiki.ubuntu.com/CustomStatusMenuDesignGuidelines#icons> The icons should not be shown by default, which is bug 528527.

Changed in indicator-application (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers