network icon disappeared in xubuntu

Bug #1302462 reported by Antoine Pitrou on 2014-04-04
218
This bug affects 49 people
Affects Status Importance Assigned to Milestone
indicator-application (Ubuntu)
Critical
Unassigned

Bug Description

Following the latest Xubuntu 14.04 updates, the network icon disapperead from the xfce panel.
I tried the workaround mentioned on https://wiki.ubuntu.com/Xubuntu/Roadmap/Specifications/Trusty/Gtk3Indicators
("""As a workaround, put "INDICATOR_ALLOW_NO_WATCHERS=yes" in /etc/environment and reboot""") but it didn't fix anything.

I can bring the icon into the panel by running "sudo nm-applet", unfortunately this still isn't functional since any interactive dialog needed by NetworkManager (for example a wifi password dialog) will never display, and therefore connecting will fail.

(I filed this bug against xfce4-panel, but there might be a better choice)

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: xfce4-panel 4.11.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.13.0-22.44-generic 3.13.8
Uname: Linux 3.13.0-22-generic x86_64
ApportVersion: 2.14-0ubuntu1
Architecture: amd64
CurrentDesktop: XFCE
Date: Fri Apr 4 12:11:51 2014
InstallationDate: Installed on 2014-03-01 (33 days ago)
InstallationMedia: Xubuntu 14.04 LTS "Trusty Tahr" - Alpha amd64 (20140225)
ProcEnviron:
 LANGUAGE=fr_FR
 TERM=xterm
 PATH=(custom, no user)
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
SourcePackage: xfce4-panel
UpgradeStatus: No upgrade log present (probably fresh install)

Antoine Pitrou (pitrou) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xfce4-panel (Ubuntu):
status: New → Confirmed
taj (othertaj) wrote :

Fix (for me Xubuntu 14.04 x64): I installed xfce4-goodies. Possibly only xfce4-indicator-plugin would also work.
One of the items that can be added to the panel is: Indicator Plugin
That will indicate Bluetooth, Wifi, battery status, volume

Antoine Pitrou (pitrou) wrote :

> One of the items that can be added to the panel is: Indicator Plugin
> That will indicate Bluetooth, Wifi, battery status, volume

Oh wow, it worked, thank you!

Sebastian Gebhard (sege) wrote :

>> One of the items that can be added to the panel is: Indicator Plugin
>> That will indicate Bluetooth, Wifi, battery status, volume

> Oh wow, it worked, thank you!

Workaround works for me too! But still, this is not the way it should behave!

PierU (ugo235) wrote :

Hi all,

same issue for me after upgrading from 13.10 to 14.04 : all the icons have gone from the notification area (except a new one naled "iBus")

ಸతీशः (bdsatish) wrote :

Same for me too. As a work around: Open Terminal --> "sudo nm-applet" --> Press Ctrl Z --> close terminal.

ಸతీशः (bdsatish) wrote :

Another workaround mentioned in [1]:

put "INDICATOR_ALLOW_NO_WATCHERS=yes" in
    /etc/environment and reboot.

[1]: https://lists.ubuntu.com/archives/xubuntu-users/2014-April/006642.html

S4qFBxkFFg (s4qfbxkffg) wrote :

bdsatish - should that be with inverted commas, or without?
i.e. should the following go in the file:
"INDICATOR_ALLOW_NO_WATCHERS=yes"
or should it be:
INDICATOR_ALLOW_NO_WATCHERS=yes

Dave H (dave-hills-2009) wrote :

clean insatll of 14.04 AM64 + updates on a HP ENY6 Sleekbook, no WIFI indicator. "sudo nm-applet" worked for me too.

Hristo Erinin (zorlem) wrote :

The suggestion from https://bugs.launchpad.net/ubuntu/+source/lxpanel/+bug/1308348/comments/44 (disabling Indicator Application service from "Session and Startup"->"Application Autostart") made the icons appear again. Looks like a bug with integration between XFCE4 tray and Indicator-enabled application notifications.

Horst Schirmeier (horst) wrote :

This is also broken in Ubuntu 14.04, not only in Xubuntu.

Horst Schirmeier (horst) wrote :

Even when I started nm-applet manually, existing WiFi connections didn't work anymore (timeout without any further error message). Removing the contents of /etc/NetworkManager/system-connections/ and entering the credentials again helped. Seems to be some migration issue.

Changed in xfce4-panel (Ubuntu):
importance: Undecided → Critical
Robert Drop (robsbkai) wrote :

I also removed , by accident , my icon for wireless network connection.

When I put in the terminal : sudo nm-applet

I have my icon back for the wireless connections.

However , when I close my laptop and start again the icon is gone again .

What must I do , so it will be there every time I restart my laptop ????

Robert.

The first comments state that the Indicator Plugin was either not installed or not added to the panel (comment #2). If you have removed the indicator area knowingly, you should disable the autostart entry for the Indicator Application service (comment #11).

Running "sudo nm-applet" is not recommended (it may alter file permissions, and therefore break some functionality). Try "dbus-launch nm-applet" instead. Now, does the icon appear in the notification area or indicator area of the panel?

Changed in xfce4-panel (Ubuntu):
status: Confirmed → Incomplete
Alberto Jovito (thedemon007) wrote :

Same issue i update xubuntu 12.04 to 14.04 trusty. I fix adding "Indicator Panel" to the panel. In Spanish this is called "Complemento de indicador".

Source:
http://askubuntu.com/questions/449658/networkmanager-tray-nm-applet-is-gone-after-upgrade-to-14-04-trusty

midopa (midopa) wrote :

After running "dbus-launch nm-applet" the icon has returned. Gonna reboot and see if it persists.

midopa (midopa) wrote :

Nvm. It appears the indicator plugin somehow got modified at some point. I don't recall intentionally doing this.

However, this was fixed by simply removing the existing indicator plugin from the panel and adding it again.

May require customization based on your tastes.

midopa (midopa) wrote :

... But clicking on any of the menu options from an item in the panel don't do anything.

midopa, that sounds like bug 1311685.

andso (andso) wrote :

yes, for me also,
and i am tired, of having to correct some disturbs
after each upgrade
I did not think the marvalous open source world
was this nightmare

andso (andso) wrote :

What you need to do is edit /etc/xdg/autostart/nm-applet.desktop with your favorite text editor as admin.
Go down to the Exec line and change the entry from nm-applet to dbus-launch nm-applet.
Go to the NoDisplay=true line and change to NoDisplay=false.
Save the file and reboot!

from http://askubuntu.com/questions/449658/networkmanager-tray-nm-applet-is-gone-after-upgrade-to-14-04-trusty

As mentioned in comment #15, a misconfiguration is the main cause for this particular problem.

We need to test the fix from bug 1411959 and eventually backport it to 14.04.

affects: xfce4-panel (Ubuntu) → indicator-application (Ubuntu)
tlewis (tlewis) wrote :

Even though I use Lubuntu, somehow recently my network applet disappeared from LXpanel as well. I could not figure out what caused this or what to do to restore it. Nm-applet is still in my autostart and does seem to be working on boot up. I was unable to start it via terminal unless using root. However, I found this bug which seems to fit the problem I am facing and Lubuntu uses the same network manager applet as Xubuntu. Using the workaround mentioned in comment #15 of that bug does work for me as well. So I believe Lubuntu is also affected by this bug. To be on the safe side, I did file a separate bug report (Bug #1434240) in case I am facing a different issue.

Hamid Asmat (goodthings1st) wrote :

To FIx this problem we just have to change a value in "nm-applet.desktop" file that is available in /etc folder. what u have to is to change one value

1. first enter this command in terminal

        sudo gedit /etc/xdg/autostart/nm-applet.desktop

2. when the file is opened change the value of ICON as below

       original value of ICON=nm-device-wireless

      converted value is

           ICON=nm-applet
3. save the file and Reboot

after reboot you will see the wifi indicator .

Regards
Hamid Asmat
Lecturer
University of Haripur

Yo (yleduc) on 2015-04-10
Changed in indicator-application (Ubuntu):
status: Incomplete → Fix Released
Hal (river-monk) wrote :

this is broken in Xubuntu 16.04 also.

"ಸతీशः (bdsatish) wrote on 2014-04-24: #7
Same for me too. As a work around: Open Terminal --> "sudo nm-applet" --> Press Ctrl Z --> close terminal."

worked for me. x64 XUbuntu 16.04LTS

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers