warning "Application already exists, re-requesting properties"

Bug #1297437 reported by Sebastien Bacher on 2014-03-25
72
This bug affects 14 people
Affects Status Importance Assigned to Milestone
indicator-application (Ubuntu)
Low
Sebastien Bacher

Bug Description

Using current trusty (beta candidate), the indicator-application.log has warnings regularly logged

"Application already exists, re-requesting properties"

Backtrace of one of those

#0 g_log (
    log_domain=log_domain@entry=0x804d9f6 "indicator-application-service",
    log_level=log_level@entry=G_LOG_LEVEL_WARNING,
    format=format@entry=0x804e328 "Application already exists, re-requesting properties.") at /build/buildd/glib2.0-2.39.92/./glib/gmessages.c:1067
#1 0x0804c790 in application_service_appstore_application_add (
    appstore=0x99dac18, dbus_name=0x99e35a0 ":1.665",
    dbus_object=0x99e6af0 "/org/ayatana/NotificationItem/tomboy_notes")
    at application-service-appstore.c:1009
#2 0x0804d31c in _notification_watcher_server_register_status_notifier_item (
    appwatcher=0x99d3128,
    service=0x99e6af0 "/org/ayatana/NotificationItem/tomboy_notes",
    method=0x99e48f8) at application-service-watcher.c:254
#3 0xb77490b6 in invoke_object_method (message=0x99e44a8,
    connection=0x99dd7d8,
    method=0x804ed1c <dbus_glib.notification_watcher_server_methods>,
    object_info=0x804ed04 <dbus_glib.notification_watcher_server_object_info>,
    object=0x99d3128) at dbus-gobject.c:1899
#4 object_registration_message (connection=0x99dd7d8,
    message=message@entry=0x99e44a8, user_data=user_data@entry=0x99d34b0)
    at dbus-gobject.c:2161
#5 0xb72572f8 in _dbus_object_tree_dispatch_and_unlock (tree=0x99ceec0,
    message=message@entry=0x99e44a8,
    found_object=found_object@entry=0xbfa0234c)
    at ../../dbus/dbus-object-tree.c:862
#6 0xb724837d in dbus_connection_dispatch (
    connection=connection@entry=0x99dd7d8) at ../../dbus/dbus-connection.c:4672
#7 0xb7745f0d in message_queue_dispatch (source=source@entry=0x99e0118,
    callback=0x0, user_data=0x0) at dbus-gmain.c:90
#8 0xb74981e3 in g_main_dispatch (context=0x99d2a58, context@entry=0x99e0118)
    at /build/buildd/glib2.0-2.39.92/./glib/gmain.c:3064
#9 g_main_context_dispatch (context=context@entry=0x99d2a58)
    at /build/buildd/glib2.0-2.39.92/./glib/gmain.c:3663
#10 0xb7498468 in g_main_context_iterate (context=0x99d2a58,
    block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>)
    at /build/buildd/glib2.0-2.39.92/./glib/gmain.c:3734
#11 0xb749876b in g_main_loop_run (loop=0x99d8390)
    at /build/buildd/glib2.0-2.39.92/./glib/gmain.c:3928

Related branches

Sebastien Bacher (seb128) wrote :

To reproduce:
- install tomboy, run it
- open the indicator
- click on one of the notes

Changed in indicator-application (Ubuntu):
importance: Undecided → Low
assignee: nobody → Sebastien Bacher (seb128)
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-application - 12.10.1+14.04.20140402-0ubuntu1

---------------
indicator-application (12.10.1+14.04.20140402-0ubuntu1) trusty; urgency=low

  [ Sebastien Bacher ]
  * Don't output warnings about properties re-requests, debug is enough
    (LP: #1297437)
 -- Ubuntu daily release <email address hidden> Wed, 02 Apr 2014 15:17:39 +0000

Changed in indicator-application (Ubuntu):
status: In Progress → Fix Released
SergeyIT (serge-i-t) wrote :

There is the same problem in lubuntu 16.04 (xenial).
...
Apr 5 19:00:12 localhost com.canonical.indicator.application[1125]: (process:4138): indicator-application-service-WARNING **: Application already exists, re-requesting properties.
Apr 5 19:00:16 localhost com.canonical.indicator.application[1125]: message repeated 15 times: [ (process:4138): indicator-application-service-WARNING **: Application already exists, re-requesting properties.]
Apr 5 19:00:16 localhost com.canonical.indicator.application[1125]: (process:4138): indicator-application-service-WARNING **: Application already exists, re-requesting properties.
Apr 5 19:00:21 localhost com.canonical.indicator.application[1125]: message repeated 19 times: [ (process:4138): indicator-application-service-WARNING **: Application already exists, re-requesting properties.]
....

F-3000 (f3000d) wrote :

This problem also appears with Ubuntu MATE 16.04.

Nov 14 15:50:04 --- com.canonical.indicator.application[1390]: (process:1989): indicator-application-service-WARNING **: Application already exists, re-requesting properties.
Nov 14 15:52:04 --- com.canonical.indicator.application[1390]: (process:1989): indicator-application-service-WARNING **: Application already exists, re-requesting properties.
Nov 14 15:54:04 --- com.canonical.indicator.application[1390]: (process:1989): indicator-application-service-WARNING **: Application already exists, re-requesting properties.

I got version 12.10.1+15.04.20150128-0ubuntu1 installed.

Harald Engels (harald-engels) wrote :

I can confirm this problem on Ubuntu MATE 16.04.1 (Xenial). Indicator seems to work but the warning appears in syslog:
Dec 4 04:02:32 --- com.canonical.indicator.application[1840]: (process:2196): indicator-application-service-WARNING **: Application already exists, re-requesting properties.

Looks like this bug needs to be re-opened because I'm getting the same behavior on Lubuntu 16.04 LTS. I noticed under "autostart applications" in the "default LXDE applications" settings, the "application indicator" was unselected, so I selected it -- the warnings went away, but the indicators in the system tray completely vanished (including network/wifi options)...even after attempting to manually add/remove them from the panel options. Unselected it again, rebooted, indicators are back but also the warning as well.

clepsdyrae (myopenid) wrote :

Same thing is happening in Lubuntu 16.10.

Andrew Khalymon (akhalymon) wrote :

Having this as well on Lubuntu 16.04.

maravento (maravento) wrote :

confirm bug in Ubuntu Mate 16.04.3
com.canonical.indicator.application[7815]: (process:10361): indicator-application-service-WARNING **: Application already exists, re-requesting properties.

Hello everyone,

I have the same bug:

com.canonical.indicator.application[927]: (process:1132): indicator-application-service-WARNING **: Application already exists, re-requesting properties

Distro: Lubuntu 16.04.06, kernel 4.15.0-46-generic.

My laptop often reboots by itself, checking in the logs the indicator-application is always the last message. May it be the reason of the unexpected reboots?

Moshe Caspi (mcaspi12) wrote :

Daniele, this is not the reason.

Sebasien, in my case, connecting a Wireless USB Adapter, and only this, triggers the messages appearance. It might be that certain hardware is the reason for all the above reports. Are you willing to open the issue given more information?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers